Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Will Windows ME support Firefox 3.6? I can't seem to load it.

  • 1 reply
  • 7 have this problem
  • 3 views
  • Last reply by TonyE

more options

This question says it all!

All Replies (1)

more options

Firefox 3.6 will not work on Windows ME, it requires at least Windows 2000 - http://www.mozilla.com/firefox/system-requirements.html

Support for Windows ME was dropped when Firefox 3 was released, you already have the last version that worked on Windows ME.