X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

ISP Forcing Redirect ( DNS - http://dnssearch.rr.com )

Posted

-Good day all,

---My service provider has recently implemented this DNS Redirect to http://dnssearch.rr.com/ . Where I use to type sites I have visted into the address bar (E.G., "eBay" or "hotmail") and it would automatically take me to the said site, the redirect pushed me to a search page, like malware would. Now, after weeks of fighting with cookies and such to OPT OUT of http://dnssearch.rr.com and numerous complaints to my provider, including eMails mentioning how I have opted out umpteen times (it wasn't my cookies, cachet, etc.,), and them forcing the site on me required me adding it to my HOST file and that altering settings on my PC is hacking and tresspassing on private property (I drilled them about all I could think of... after weeks of fighting this new "game" they started) and most important, hijacking, the site is gone and there are no more browser redirects. However,

---The function no longer works when I type a recent site into my address bar. I go straight to www.google.com, which I set as my default search page. How do I get it back?

---It's not plugins or add-ons, these do not apply.

---I have completely uninstalled Firefox (using Revo) and reinstalled and the problem is still there.

browser.fixup.alternate.enabled = false keyword.enabled = true

_edit_:

---Forgot, my Wife's laptop is experiencing the redirect problem. I haven't bothered with it because if it was something I accidentally did to my PC that changed a setting, I wouldn't want to reenact the crime on hers. She enjoys the keyword function as well as I, and it would be instant death if something I did ended her enjoyment.

Modified by AKA3Toes

Chosen solution

You are welcome.

Complain to your ISP if you believe they will listen.

I left RR and CC behind a long time ago for their shenanigans!

Read this answer in context 0

Additional System Details

This started when...

Roadrunner.com threw DNS redirect at me 2 months ago

Installed Plug-ins

  • 1.9.0042.0
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.4"
  • Default Plug-in
  • Shockwave Flash 10.1 r102
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.615
  • DivX Web Player version 2.0.2.40
  • Next Generation Java Plug-in 1.6.0_21 for Mozilla browsers
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 ( .NET CLR 3.5.30729; .NET4.0E)

More Information

Windows XP Pro SP2

Helper7677 165 solutions 1653 answers

Helpful Reply

Have you tried setting the following preferences:

  • browser.fixup.alternate.enabled=true
    • True (default): Try to fix up http://foo to http://(prefix)foo(suffix)
    • False: Do not second-guess the user
  • browser.fixup.alternate.prefix=www.
    • The prefix to prepend when attempting to fix an entered URL. Default is "www." (includes full stop). Requires browser.fixup.alternate.enabled be true.
  • browser.fixup.alternate.suffix=.com
    • The suffix to append when attempting to fix an entered URL. Default is ".com". Requires browser.fixup.alternate.enabled be true.
  • Source: http://kb.mozillazine.org/About:config_entries#Browser (scroll down to the 3 pref items)

"I go straight to www.google.com, which I set as my default search page."
Does this mean you reset the keyword.URL pref? You may need to do so.

For all of the above prefs (about:config entries), see: http://kb.mozillazine.org/About:config



The information submitted with your question indicates that you have out of date plugins with known security issues that should be updated. To see the plugins submitted with your question, click "More system details..." to the right of your original question post.

  • Next Generation Java Plug-in 1.6.0_21 for Mozilla browsers
  1. Check your plugin versions: http://www.mozilla.com/en-US/plugincheck/
    • Note: plugin check page does not have information on all plugin versions
  2. Update Java:

Question owner

-Thanks!,

---That did it. What it was in short:

  1. -Roadrunner (Time Warner Broadband) forced a DNR Redirect on its customers named http://dnssearch.rr.com which they have done in the past as well as comcast (IIRC) with http://dnssearch.com 4-5 years ago.
  2. -Reinstalling FF, editing registry, malware scans, registry restoration, registry cleaning after uninstalling FF, changing settings in about:config to http://www.google.com/search?ie=UTF-8&oe=utf-8&q= (default for Mozilla products) did nothing.
  3. -Read down a little further in Possible values and their effects at [http://kb.mozillazine.org/Keyword.URL] and see it says "For Firefox & Sunbird use the string http://www.google.com/search?btnI=I%27m+Feeling+Lucky&ie=UTF-8&oe=UTF-8&q=

---Browser hijack repaired thanks to Helper7677 and a little patience to read over something I already read... and notice that the "most" in "in most Mozilla products" was followed by "in Firefox and Sunbird the default is “http://www.google.com/search?btnI=I%27m+Feeling+Lucky&ie=UTF-8&oe=UTF-8&q="

Question owner

---Who do I complain to regarding the browser hijack that my ISP implemented?

Helper7677 165 solutions 1653 answers

Chosen Solution

You are welcome.

Complain to your ISP if you believe they will listen.

I left RR and CC behind a long time ago for their shenanigans!

the-edmeister
  • Top 10 Contributor
  • Moderator
3197 solutions 24401 answers

Opt out of the Roadrunner web error “redirection service”.
http://naterocks.com/2008/04/17/opt-out-of-the-new-roadrunner-web-error-redirection-service/

Comcast has a similar opt out feature available.
http://coreygilmore.com/blog/2009/07/23/opt-out-of-comcasts-dns-helper/
https://dns-opt-out.comcast.net/

Question owner

---Ummm, okay. Guess it was too hard to understand that I said in the first paragraph, I had OPTED OUT UMPTEEN TIMES! Now suggest I clear cookies or cache and I will redirect you to another paragraph... LOL. (cup of coffee for the-... edmeister. Drinkin the coffee, makin the copies, typin responses, ederoni, eddy boy, edsteroanski, ederooni... e-e-e-e-e-e-e-ed).

:-D

---Yeah Helper7677, like I said, I eMailed them and* contacted them. Their response, they "... didn't know how to handle the problem, but we can set up a service call". I said, "No, I just want you to reverse what you did to my browser.". They stopped the redirect, it was just up to you to show me how to change keyword: back to default.

---Now to go double check the settings in the browser on the wife's laptop. I don't want to reset anything just yet. Tryin' to think of how o get a snapshot & screen cap for evidence... lol.

---BTW! As I said, it was solved by me reading from the link Helper7677 posted. Might want to read that in case it happens to you. Flag it in your memory inbox as well so you can find it when you forget.

---Keep up people, though lengthy it wasn't a book. If you fall behind too much I might start thinking I am talking to someone in India... like AOL tech support.

:-P

Modified by AKA3Toes

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96798 answers

You can set alternative DNS servers like Google or OpenDNS to prevent your ISP from redirecting you.

See http://kb.mozillazine.org/Error_loading_websites#DNS

Question owner

-Again,

---This was solved by following the link from Helper7677. Maybe the third time will be a charm in regards to reading comprehension... no need to bump answer count any more... nothing to answer here, move along and please don't clutter the thread any more.

---Roadrunner has done this 3 times already since 2006, so it will undoubtedly happen again. So; Once again, for those who may encounter the same issue, not for those who want to confuse the thread by adding non-productive posts and bump their answer count.

-Thanks!,

---That did it. What it was in short:

  1. -Roadrunner (Time Warner Broadband) forced a DNR Redirect on its customers named http://dnssearch.rr.com which they have done in the past as well as comcast (IIRC) with http://dnssearch.com 4-5 years ago.
  2. -Reinstalling FF, editing registry, malware scans, registry restoration, registry cleaning after uninstalling FF, changing settings in about:config to http://www.google.com/search?ie=UTF-8&oe=utf-8&q= (default for Mozilla products) did nothing.
  3. -Read down a little further in Possible values and their effects at [http://kb.mozillazine.org/Keyword.URL] and see it says "For Firefox & Sunbird use the string http://www.google.com/search?btnI=I%27m+Feeling+Lucky&ie=UTF-8&oe=UTF-8&q=

---Browser hijack repaired thanks to Helper7677 and a little patience to read over something I already read... and notice that the "most" in "in most Mozilla products" was followed by "in Firefox and Sunbird the default is “http://www.google.com/search?btnI=I%27m+Feeling+Lucky&ie=UTF-8&oe=UTF-8&q="

Question owner

---They're back at it again. The choice to OPT OUT must only be good for, and need reminder after, 90 days. So far it hasn't been a hijack, settings applied at about:config are still active.

---I've also added, since I don't use DNS redirect, don't have problems with misspelling in the location bar and therefor have no need for DNS cache, disabling of the DNS Cache entirely, through about:config as described here:

[to Disable Firefox DNS Cache]

Modified by AKA3Toes