X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Empty preview windows on YouTube

Posted

Well here's the screenshot of my problem: http://img177.imageshack.us/img177/7263/flashorsomething.jpg

As you can see preview windows on YouTube don't load. Also - user menu won't show.

I think it's a problem with flash plug-in, since the problem started right after I was updating it (even though I didn't need to I guess). And that leads to another problem; I tried to update it since instead of videos on people's profiles I would get error saying that I got Java Script disabled or old Flash version - it was wrong then, it is wrong now - now, cause it still gives me that error.

I post here, because on Google Chrome YouTube works perfectly fine.

I tried to reinstall flash, didn't help. Some suggestions?

EDIT: Also, now I see that YouTube on Firefox got some basic problems with functionality, like can't view "more" of videos description and so on... eh. It gots to be flash or something.

Modified by hoolaka

Chosen solution

Interestingly enough I had this problem and spent the last 3 hrs tracking it down with the help of several VMs and about:support... but stranger yet is that I searched for Dom.storage.enabled (the key to the solution) and ended up here via google, even though that string is nowhere on this page... how odd (old cached copy?? if so, why was that comment/reply [re]moved??).

Anyways, I wanted to say that I fixed this by searching my variables in about:support as it filters out only the core browser vars that have been changed from defaults, as there are way too many to sort through if you have to root through about:config looking at every extension vars. (Note to devs: it would be handyto have multi-word inline search as well as the option to filter out non-built-in variables in about:config --> would make for some speedier problem resolutions)

The solution? Dom.storage.enabled was improperly set to FALSE. No clue what changed it, but it was definitely something in the last couple of days. I could view youtube videos individually, but would get the "Hello... javascript is disabled or you have an old version of flash" msg on any channel's main page. Also, I couldn't click on any of the java?-based controls on youtube, such as the like/dislike et. al. below videos, the menu that dropped down when clicking on your profile name in the upper-right, and many other issues as well. I also couldn't click on any "javascript:" links (nothing would happen) on, for ex., Asus' support site, among countless other oddities that have all been fixed with the solution below. I'm sure this would all make perfect sense if I knew a little more about the DOM storage but for now a rough practical description will have to do.

For those who skipped the above paragraph, here's the quick fix: Go to about:config and set dom.storage.enabled to TRUE and, unless you have other problems as well, you should be in good stead.

Registered just to share this one as we all need to give back to the help forums once in a while, eh?

~BC

Read this answer in context 39

Additional System Details

This happened

Every time Firefox opened

This started when...

Yesterday, when I was trying to do some flash updates (even though it wasn't needed)

Installed Plug-ins

  • EA Battlefield Heroes Updater
  • PDF-XChange Viewer Netscape Gecko Plugin
  • Office Plugin for Netscape Navigator
  • np-mswmp
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.448
  • Winamp Application Detector
  • Default Plug-in
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Google Update
  • Shockwave Flash 10.1 r85
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.615
  • QUAKE LIVE
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • 4.0.50524.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12

More Information

Informacje o aplikacji
Nazwa
Firefox
Wersja
3.6.12
Katalog profilu
Otwórz folder zawierający
Zainstalowane wtyczki
about:plugins
Konfiguracja kompilacji
about:buildconfig
Rozszerzenia
Nazwa
Wersja
Włączone
ID
Java Console
6.0.11
true
{CAFEEFAC-0016-0000-0011-ABCDEFFEDCBA}
Java Console
6.0.13
true
{CAFEEFAC-0016-0000-0013-ABCDEFFEDCBA}
Java Console
6.0.15
true
{CAFEEFAC-0016-0000-0015-ABCDEFFEDCBA}
Java Console
6.0.16
true
{CAFEEFAC-0016-0000-0016-ABCDEFFEDCBA}
Java Console
6.0.17
true
{CAFEEFAC-0016-0000-0017-ABCDEFFEDCBA}
Zrzuta
1.0
false
zrzuta.eu@gmail.com
Battlefield Heroes Updater
4.0.53.0
true
battlefieldheroespatcher@ea.com
XfireXO Toolbar
2.5.8.6
true
{5e5ab302-7f65-44cd-8211-c1d4caaccea3}
Microsoft .NET Framework Assistant
1.0
false
{20a82645-c095-46ed-80e3-08825760534b}
Java Console
6.0.20
true
{CAFEEFAC-0016-0000-0020-ABCDEFFEDCBA}
TinEye Reverse Image Search
1.0
true
tineye@ideeinc.com
Firefox Synchronisation Extension
7.3.3.42
true
{A27F3FEF-1113-4cfb-A032-8E12D7D8EE70}
Java Console
6.0.22
true
{CAFEEFAC-0016-0000-0022-ABCDEFFEDCBA}
Java Quick Starter
1.0
true
jqs@sun.com
Zmodyfikowane ustawienia
Nazwa
Wartość
accessibility.typeaheadfind.flashBar
0
browser.history_expire_days.mirror
180
browser.places.importBookmarksHTML
false
browser.places.importDefaults
false
browser.places.leftPaneFolderId
-1
browser.places.migratePostDataAnnotations
false
browser.places.smartBookmarksVersion
2
browser.places.updateRecentTagsUri
false
browser.startup.homepage_override.buildID
20100914073604
browser.startup.homepage_override.mstone
rv:1.9.2.12
browser.tabs.warnOnClose
false
dom.max_script_run_time
1800
dom.storage.enabled
false
extensions.lastAppVersion
3.6.12
network.cookie.prefsMigrated
true
network.security.ports.banned
8118,8123,9050,9051
places.history.expiration.transient_current_max_pages
64374
places.last_vacuum
1286973924
print.print_printer
Send To OneNote 2007
print.printer_Send_To_OneNote_2007.print_bgcolor
false
print.printer_Send_To_OneNote_2007.print_bgimages
false
print.printer_Send_To_OneNote_2007.print_command
print.printer_Send_To_OneNote_2007.print_downloadfonts
false
print.printer_Send_To_OneNote_2007.print_edge_bottom
0
print.printer_Send_To_OneNote_2007.print_edge_left
0
print.printer_Send_To_OneNote_2007.print_edge_right
0
print.printer_Send_To_OneNote_2007.print_edge_top
0
print.printer_Send_To_OneNote_2007.print_evenpages
true
print.printer_Send_To_OneNote_2007.print_footercenter
print.printer_Send_To_OneNote_2007.print_footerleft
&PT
print.printer_Send_To_OneNote_2007.print_footerright
&D
print.printer_Send_To_OneNote_2007.print_headercenter
print.printer_Send_To_OneNote_2007.print_headerleft
&T
print.printer_Send_To_OneNote_2007.print_headerright
&U
print.printer_Send_To_OneNote_2007.print_in_color
true
print.printer_Send_To_OneNote_2007.print_margin_bottom
0.5
print.printer_Send_To_OneNote_2007.print_margin_left
0.5
print.printer_Send_To_OneNote_2007.print_margin_right
0.5
print.printer_Send_To_OneNote_2007.print_margin_top
0.5
print.printer_Send_To_OneNote_2007.print_oddpages
true
print.printer_Send_To_OneNote_2007.print_orientation
0
print.printer_Send_To_OneNote_2007.print_pagedelay
500
print.printer_Send_To_OneNote_2007.print_paper_data
9
print.printer_Send_To_OneNote_2007.print_paper_height
11,00
print.printer_Send_To_OneNote_2007.print_paper_size_type
0
print.printer_Send_To_OneNote_2007.print_paper_size_unit
1
print.printer_Send_To_OneNote_2007.print_paper_width
8,50
print.printer_Send_To_OneNote_2007.print_reversed
false
print.printer_Send_To_OneNote_2007.print_scaling
1,00
print.printer_Send_To_OneNote_2007.print_shrink_to_fit
true
print.printer_Send_To_OneNote_2007.print_to_file
false
print.printer_Send_To_OneNote_2007.print_unwriteable_margin_bottom
0
print.printer_Send_To_OneNote_2007.print_unwriteable_margin_left
0
print.printer_Send_To_OneNote_2007.print_unwriteable_margin_right
0
print.printer_Send_To_OneNote_2007.print_unwriteable_margin_top
0
privacy.clearOnShutdown.cookies
false
privacy.clearOnShutdown.offlineApps
true
privacy.cpd.siteSettings
true
privacy.item.offlineApps
true
privacy.popups.showBrowserMessage
false
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.warn_viewing_mixed
false

firemind 0 solutions 1 answers

Helpful Reply

Recently flash and java updates were available and installed then yesterday things brgan to go wrong when working in youTube until finally I got this error and javascript and flash seemed to stop working on main channel pages.

"Hello, you either have JavaScript turned off or an old version of Adobe's Flash Player. Get the latest Flash player. " i could watch videos off of the main pages. Javascript on the main page (for example switching between uploads/favourites and so on is impossible).

I played around with plugins and add-ons and nothing working I reinstalled Flash player 10,1,85,3 , I reinstalled Firefox 3.6.12 and even tried a system restore. YouTube worked fine in IE but not Firefox.

My only extension is addblock plus.

I do not allow cookies by default but this never caused problems before. I experimented with allowing a session cookie from YouTube and javascript worked. I don't have to be logged in I just have to have a cookie to make javascript work.

bcbigb 1 solutions 6 answers

Chosen Solution

Interestingly enough I had this problem and spent the last 3 hrs tracking it down with the help of several VMs and about:support... but stranger yet is that I searched for Dom.storage.enabled (the key to the solution) and ended up here via google, even though that string is nowhere on this page... how odd (old cached copy?? if so, why was that comment/reply [re]moved??).

Anyways, I wanted to say that I fixed this by searching my variables in about:support as it filters out only the core browser vars that have been changed from defaults, as there are way too many to sort through if you have to root through about:config looking at every extension vars. (Note to devs: it would be handyto have multi-word inline search as well as the option to filter out non-built-in variables in about:config --> would make for some speedier problem resolutions)

The solution? Dom.storage.enabled was improperly set to FALSE. No clue what changed it, but it was definitely something in the last couple of days. I could view youtube videos individually, but would get the "Hello... javascript is disabled or you have an old version of flash" msg on any channel's main page. Also, I couldn't click on any of the java?-based controls on youtube, such as the like/dislike et. al. below videos, the menu that dropped down when clicking on your profile name in the upper-right, and many other issues as well. I also couldn't click on any "javascript:" links (nothing would happen) on, for ex., Asus' support site, among countless other oddities that have all been fixed with the solution below. I'm sure this would all make perfect sense if I knew a little more about the DOM storage but for now a rough practical description will have to do.

For those who skipped the above paragraph, here's the quick fix: Go to about:config and set dom.storage.enabled to TRUE and, unless you have other problems as well, you should be in good stead.

Registered just to share this one as we all need to give back to the help forums once in a while, eh?

~BC

bcbigb 1 solutions 6 answers

I should also mention that I had tried all of the normal things to fix that common error message, un/reinstalling java, flash, killing adblock etc (eventually did a safe mode start with all options checked and it didn't fix it, leading me to the few things a full safe start doesn't change --> browser vars)... None-the-less, if you're having other issues besides this, you may have whatever issue was solved by the reinstallations I just mentioned. try those as well.

Question owner

Actually your fix: "Go to about:config and set dom.storage.enabled to TRUE " solved it all.

Like in your case I had it set to False, nobody knows why.

Anyways, thank ya very much for this.

Modified by hoolaka

bcbigb 1 solutions 6 answers

One other note: I had tried several methods of testing java and flash installations to ensure they were working properly, including the official test sites, and all signs were that they were working fine, so throw that on top of the pile too.

Lastly, if anyone knows more about the DOM storage and/or knows what happened to either toggle this variable OR suddenly activate its use by firefox/flash/java etc. please comment. I have a feeling it was toggled rather than activated but would be curious to know if anyone has a clue as to what [could have] caused this. I have two environments, with JRE22/21 and flash 10.1.85.3 that were both affected at the same time and hadn't been updated recently (other than java on the JRE22 machine), so I'm at a loss for explanation so far as a smoking gun is concerned.

~BC

bcbigb 1 solutions 6 answers

Np... glad I could help... I'm getting an odd feeling like this is going to be a bigger issue than just this thread... like I'm going to wake up and get many calls from clients suddenly asking me what's wrong with their FF... ;-)

I'll cross my fingers that I'm wrong.

Question owner

DOOOOMED! :P

Well, but yeah, it was kinda weird, never happened before, and there was no special reason (that I could notice ofcourse), besides updating that flash plug-in.

I don't know, I'm kinda noobie in here, everything works perfectly fine now, will see about the future. Thanks again though.

bcbigb 1 solutions 6 answers

http://kb.mozillazine.org/Dom.storage.enabled

Last update... it looks like this is related to an HTML5 spec called Web Applications 1.0 that specifies the requirement(?) for this persistent cookie repository. Youtube is aggressively using HTML5 on many parts of their site so it's possible they just made a change to it that now requires this to be enabled and perhaps it wasn't the default on older builds of FF. No time to test but if someone wants to follow up I'd suggest grabbing 3.6 vanilla, 3.5 vanilla etc. as this was apparently checked in in 2006, meaning it could have been implemented but disabled long ago, eventually being grandfathered in through update after update until now it's causing problems in 3.6+ when it has now been changed to default=TRUE. Just a hypothesis as I tweak/extend the hell out of my browser but have never done anything that could conceivably touch that var.

~BC

pkgannon 0 solutions 1 answers

yes! thank you. Setting the DOM.STORAGE.ENABLE = TRUE did the trick. And for those that don't know .. you put "about:config" in the location bar in firefox.. (ie. the url)

chr155yb0y72 0 solutions 4 answers

much thanks for the help, all fixed now and working again. i would like to find out how it changed thou, no new add-ons or updates installed and it still messed up? i only noticed this problem on youtube, all other sites seem to be okay or unaffected by this.

chr155yb0y72 0 solutions 4 answers

This will sort the problem if you have not already fixed it .. you put "about:config" in the location bar in firefox.. (ie. the url) then locate the "dom.storage.enabled" from the list and then double click it so it changes the value from "false" to "true"

MoiUnMouton 0 solutions 1 answers

Many thanks, that's been really annoying me for a few hours now! Your solution worked like a charm.

But what was the cause? Didn't have the problem on my XP box, just on newly updated W7 machine. Didn't have the problem on IE on my W7 machine. Very strange. Is it Flash that's doing it? Or is it Steve Jobs spreading a virus that makes it look like it's a Flash problem......  :-)

cor-el
  • Top 10 Contributor
  • Moderator
10779 solutions 97010 answers

See also https://developer.mozilla.org/en/dom/storage (Storage location and clearing the data)

danypysyka 0 solutions 3 answers

other fixes?

Modified by danypysyka

danypysyka 0 solutions 3 answers

not warking again ..youtube...i have dom storage enabled set to true by default so is there another fix for this weird problems?thanks

Modified by danypysyka

danypysyka 0 solutions 3 answers

back again...if i check box accept cookies from sites youtube works normal ...if uncheck box i don't have preview windows and i can't click on search or description or like button so...check that box ..it will fix

Modified by danypysyka

usermind 0 solutions 1 answers

Yeh back again. Now turning Cookies on solves the problem. Weird problem, as I have cookies blocked by default. Also, Gtalk in Gmail works again.

I guess there`s no other solution than turning cookies on, right? :(

kionay 0 solutions 1 answers

OMG THANK YOU SO MUCH bcbigb i wish i could shake your hand right now i seached google, yahoo, yahoo answers, youtube videos themselves for the past hour i coulden't find the answer so i thought i'd go to last resort and ask mozilla live help when i happened to find this thread

and the feeling that someone else had the same problem and had also spent so much time figuring it out just makes me glad i use firefox all i had to do was set it to true and presto those million functions that no longer worked just worked again

not yahoo, yahoo answers, or google saved me, and you ( you awesome person) did thank you from the bottom of my heart

D
LeahStorm 0 solutions 3 answers

YES! The fix worked. Enable dom storage = true. I wonder what made it false. The only thing i did was update adobe flash player. Could that have done it?

NewPaltz75 0 solutions 2 answers

BC, after looking all over the Internet for a solution, I ran into articles telling me to uninstall Flash and then reinstall, etc..., but your solution was the only one that fixed the problem for me! I know very little about the insides of a computer, but the last paragraph of your instructions was very simple and it really worked. Thanks so much for sharing!