X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

The compose button will not work in Gmail - it does with IE.

Posted

The very top buttons calendar sign out etc, compose button, Tasks and contact buttons in Gmail do not work. All other buttons work. All work fine when using IE. I have upgraded Firefox, 3.6.12. Cleared all cached, cookies etc & rebooted.

Chosen solution

I have had about:config >dom.storage.enabled, set at false for a week or so now. There were no problems until the ff 3.6.12 update yesterday morning when I began having the same problems as all of you. I allowed all scripts, problem still persisted so I went back to about:config, toggled dom storage to true and voila, chat and compose started working again. Just to check, I switched it back to false and it stopped working again. You can use the add-on betterprivacy to autodelete dom storage cookies but it looks like google will no longer allow you to disable them completely.

more on enabling/dis-enabling in firefox, this is for windows but should be the same for other os: http://www.sevenforums.com/tutorials/106540-dom-storage-cookies-enable-disable.html

more on dom cookies: https://secure.wikimedia.org/wikipedia/en/wiki/Web_Storage

Read this answer in context 52

Additional System Details

Sites Affected

http://mail.google.com

Installed Plug-ins

  • Coupons, Inc. Coupon Printer DLL
  • Coupons, Inc. Coupon Printer Plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • Shockwave Flash 10.1 r85
  • Garmin Communicator Plug-In 2.7.3.0
  • GEPlugin
  • Picasa plugin
  • Yahoo Application State Plugin version 1.0.0.7
  • 4.0.50917.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Next Generation Java Plug-in 1.6.0_20 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 ( .NET CLR 3.5.30729)

More Information

yeltb 1 solutions 4 answers

Chosen Solution

I have had about:config >dom.storage.enabled, set at false for a week or so now. There were no problems until the ff 3.6.12 update yesterday morning when I began having the same problems as all of you. I allowed all scripts, problem still persisted so I went back to about:config, toggled dom storage to true and voila, chat and compose started working again. Just to check, I switched it back to false and it stopped working again. You can use the add-on betterprivacy to autodelete dom storage cookies but it looks like google will no longer allow you to disable them completely.

more on enabling/dis-enabling in firefox, this is for windows but should be the same for other os: http://www.sevenforums.com/tutorials/106540-dom-storage-cookies-enable-disable.html

more on dom cookies: https://secure.wikimedia.org/wikipedia/en/wiki/Web_Storage

Question owner

Perfect - solved the problem. Thanks!

Ducatiman 1 solutions 5 answers

Helpful Reply

Hi yeltb, I followed your instructions but whether I have dom-cookies set at true or false makes no difference in my case. I still can't compose or reply to mail while in the standard format. As for others, it works OK in basic HTML. I also have 3 other problems with Firefox which I assume are probably related to the same problem? 1) When I click "Add content to my zoo" I am not taken to the page where I can do this. I just get a white page with a few lines of text on it. i.e.

      . My Content
      . My Details
      > Read myZOO help  .... etc.

2) I can't view any video on the home page. Clicking on the arrow either does nothing or just refreshes the home page. 3) when I download any file, the download box pops up but nothing gets entered in it. It just stays blank, even though the download does occur. Regards, Ducatiman

mtesta57 0 solutions 1 answers

I just tried this solution (set to "true") and it DID FIXED THE PROBLEM in Firefox 3.6.12 I also disabled auto-delete DOMStorage in Firefox config, just to be sure. Yep, upgrading to Firefox 3.6.12 was the problem.

Thank you for the fix!

kstrating 0 solutions 1 answers

This solution worked for me, as well (compose email, etc. stopped working late afternoon 10/29.) What I'd like to know is how/why this worked, and what the "out of the blue" change was on Fri. evening (no upgrades at that time).

Question owner

Not sure WHY it stopped working but, I have noticed that I cannot automatically add passwords - not sure if it is connected.

Crystalsno 0 solutions 12 answers

I'm running windows xp still, not win 7. So I'll wait until firefox and or google have a solution as I'm not willing to void any warranties. I'll also send this to gmail so they can take a look at it and make a fix.

jimrouth 0 solutions 1 answers

Fixed the problem - thanks yeltb

legalr 0 solutions 1 answers

Thank you! Works just fine now!!!

greatwebs 0 solutions 2 answers

Thanks. That works.

kkh 0 solutions 1 answers

Thank you !!! That solved it for me.

Modified by kkh

wilbert 0 solutions 1 answers

All I did was ..... uninstall Gmail notifier and Problem fix.