X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

My homepage comes up in Chinese and I can't read it or change to English

Posted

I am living in China but I have all my setting to English as I am not Chinese. However, my homepage has defaulted to a Chinese version which I can't read and it gives no place to change back to English. I have tried changing it manually in Tools but it reverted to Chinese again.

Chosen solution

Use http://www.google.com/ncr to set the default language for the Google site.

  • Such details are stored in a cookie.
  • You need an allow cookie exception (Tools > Options > Privacy > Cookies: Exceptions) to keep that cookie, especially for secure websites and if you let cookies expire when Firefox closes
  • Make sure that you do not use Remove recent browsing, search and download history to clear the "Cookies" and the "Site Preferences"
Read this answer in context 8

Additional System Details

This happened

Every time Firefox opened

This started when...

With the new version of Firefox installed only hours ago

Installed Plug-ins

  • Default Plug-in
  • Shockwave Flash 10.1 r85
  • Picasa plugin
  • Next Generation Java Plug-in 1.6.0_21 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 4.0.50917.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.4"
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 (.NET CLR 3.5.30729)

More Information

OS is XP and current browser should be Google but I am having problems with that which I have notified today.

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Chosen Solution

Use http://www.google.com/ncr to set the default language for the Google site.

  • Such details are stored in a cookie.
  • You need an allow cookie exception (Tools > Options > Privacy > Cookies: Exceptions) to keep that cookie, especially for secure websites and if you let cookies expire when Firefox closes
  • Make sure that you do not use Remove recent browsing, search and download history to clear the "Cookies" and the "Site Preferences"

Question owner

Brilliant! Thank you so much.

In fact I had set up an account more than a year ago but never knew how to get it back again. The URL you gave brought it up immediately. Now I have saved the URL in my bookmarks.

SORScrub 0 solutions 2 answers

go to tools, options, content and then pick your language

Question owner

Initially, I was delighted with the solution. However, only a few days later, firefox stopped letting me access Google or Gmail and after reinstalling firefox and trying many other solutions from other forums, I finally just stopped using firefox.

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Make sure that the pref dom.storage.enabled is set to true on the about:config page.

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.

Question owner

Thanks for the suggestion cor-el. I did as you said but there is no 'pref.dom.' of any kind in my about config page.

After I stopped using Firefox, I installed Chrome and for the first two days it was absolutely amazing, fast, accurate and problem free. After that I find I have repeated problems every single day. Sometimes can't access browser. Sometimes can't access gmail. Most days it also reverts to Chinese, despite my repeatedly resetting English as the default. Here are some error msgs I get:

  {http%7Bhttp  when I try to search in Chrome

Error 107 (net::ERR_SSL_PROTOCOL_ERROR): SSL protocol error. gmail won’t sign out. Error 107 (net::ERR_SSL_PROTOCOL_ERROR): SSL protocol error. cant get gmail Error 107 (net::ERR_SSL_PROTOCOL_ERROR): SSL protocol error. Cant access bookmarks in Chrome

Error 107 (net::ERR_SSL_PROTOCOL_ERROR): Unknown error. Error 112 (net::ERR_NO_SSL_VERSIONS_ENABLED): Unknown error. Error 101(net::ERR_NO_SSL_VERSIONS_ENABLED): Unknown error.

I've tried many solutions found at various forums but none has permanently solved the problems.

One message says that the problem is with Chrome itself which has bugs but then, why do I also have problems with Firefox?? The reason I am demented is because I spend significant lengths of time just trying to get access to information or my email. Would be eternally grateful for a permanent solution and would really prefer to go back to Firefox if the problems there were resolved.

sempre 0 solutions 2 answers

1. Selecting a language in Tools>Options>Content, does nothing to change home-page. 2. The ONLY place I see to attempt to choose a home-page is in:

    Tools>Options>General, by erasing the existing page in the tab shown and    typing in your choice. However, as is the case with my Italian pc, it may not

solve the problem, since it's hardwired in Italian for marketing reasons. 3. I could'nt find any references to cookies in the Tool section

sempre 0 solutions 2 answers

To change home page; type in a new tab and bring up the site you want onto

 the screen, (current page). Then go to Tools>Options>General, and then, across from "Home Page"  click onto "Use Current Page".  Then click "OK" and it should work, as it did on my Italian computer.