Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

cannot upgrade firefox beyound version 2.0.0.20?

  • 2 replies
  • 7 have this problem
  • Last reply by erichoran

more options

I am on a Mac G4 running 10.3.9 and can not upgrade firefox beyond version 2.0.0.20. Is this correct?

All Replies (2)

more options

That is correct, Firefox 3.* versions require at least OS X 10.4, and Firefox 4 will require OS X 10.5

more options

Do you know if I can upgrade my G4 Mac to run OS X 10.4 or not?