Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

double-clicking downloads open in wrong application

  • 1 reply
  • 39 have this problem
  • Last reply by aquarium

more options

i've got firefox set up to open multimedia files using vlc. likewise, my os (ubuntu studio 10.04) is set to do the same thing. however, i prefer to save multimedia files to my hard disk before opening them.

i get the right prompt from firefox, and the file downloads fine. however, if i double-click the file in the firefox download manager it opens in movie player rather than vlc.

why are these files opening in movie player? how can i get them to open in the proper application?

i've gone through the preferences->applications->menu, and everything is set to either 'always ask' or 'vlc'; there are no entries for movie player.

as i said above, these files are set in the os to open with vlc, and they do open correctly from an explorer (nautilus) window.

a workaround is to right-click on the downloaded file in the download manager, open file location, find the file and open it properly, but it's a real pain and probably not intended behaviour.

am i missing something completely? or is this a bug?

edit: i now see below that the totem plugin is designed to handle audio and video streams, though streaming media isn't exactly the problem. i do have the vlc mozilla plugin installed, but it doesn't appear on the list below.

All Replies (1)

more options

I'm having a somewhat related video playback problem in that some videos seem to be opening directly in Firefox without an obvious player. So there's no capability for changing settings. The video plays once then freezes mid-frame. I don't know if its using media player, quicktime, or vlc, or what. But the playback has the feel of media player. Some files open as expected in media player.

I've been having this problem with videos since upgrading to Firefox 4.0. It didn't happen with 3.x so I assume that its a version 4.0 bug.