Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I'm running MAC OSX 10.3.9 and want to upgrade Firefox but I can't?

  • 1 reply
  • 28 have this problem
  • 2 views
  • Last reply by TonyE

more options

I want to upgrade from v. 2 to v. 3.

All Replies (1)

more options

You will not be able to upgrade, later versions of Firefox require at least OS X 10.4