X
Tap here to go to the mobile version of the site.

Support Forum

Associate ed2k protocol to program (eMule or aMule etc. )

Posted

Hello to the to the Firefox team ,

When one click a eMule or aMule (P2P) link , there is no

option to associate it with /usr/bin/ed2k (the P2P program) .

In former versions you had to go in "about:config" and enter a New then Boolean with as name :

    "network.protocol-handler.external.ed2k"  and value :
    "true" 

Then again New String "network.protocol-handler.app.ed2k"

with "/path/to/ed2k" as a value .

I have Firefox 3.6.7 on a Fedora 13 O.S. and the classic

doesn't do the trick . How comes ?

Now I get a warning window witch basically says : (translated & abbreviated from Dutch)

" don't now how to open this address , this protocol (ed2k) isn't associated with any program "

Only option is the OK button , end of history , no way to

associate , as explained in MIME types etc.. ...

I've no idea , and there seams to be nobody else having

the problem , there isn't anything in the FAQ's or the

knowledge base .

Thank you for the attention ,

Sincerely greeted

Martin

Hello to the to the Firefox team , When one click a eMule or aMule (P2P) link , there is no option to associate it with /usr/bin/ed2k (the P2P program) . In former versions you had to go in "about:config" and enter a New then Boolean with as name : "network.protocol-handler.external.ed2k" and value : "true" Then again New String "network.protocol-handler.app.ed2k" with "/path/to/ed2k" as a value . I have Firefox 3.6.7 on a Fedora 13 O.S. and the classic doesn't do the trick . How comes ? Now I get a warning window witch basically says : (translated & abbreviated from Dutch) " don't now how to open this address , this protocol (ed2k) isn't associated with any program " Only option is the OK button , end of history , no way to associate , as explained in MIME types etc.. ... I've no idea , and there seams to be nobody else having the problem , there isn't anything in the FAQ's or the knowledge base . Thank you for the attention , Sincerely greeted Martin

Additional System Details

Installed Plug-ins

  • The Totem 2.30.2 plugin handles video and audio streams.
  • DivX Web Player version 1.4.0.233
  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.
  • nspluginwrapper is a cross-platform NPAPI plugin viewer, in particular for linux/i386 plugins.This beta software is available under the terms of the GNU General Public License.
  • The IcedTea NPR Web Browser Plugin (using IcedTea6 1.8.1 (fedora-42.b18.fc13-x86_64)) executes Java applets.
  • Shockwave Flash 10.1 r82

Application

  • User Agent: Mozilla/5.0 (X11; U; Linux x86_64; nl; rv:1.9.2.7) Gecko/20100723 Fedora/3.6.7-1.fc13 Firefox/3.6.7

More Information

If I can provide more details , please ask me

cor-el
  • Top 10 Contributor
  • Moderator
12118 solutions 112638 answers

Chosen Solution

See http://kb.mozillazine.org/Register_protocol

Question owner

Thank you cor-el , that did it .

Thank you cor-el , that did it .
cor-el
  • Top 10 Contributor
  • Moderator
12118 solutions 112638 answers

Helpful Reply

You're welcome

You're welcome
perfectpitcher22 0 solutions 1 answers

I had this similar situation before but I managed to get around it through about:config. I just had to manually add protocol ed2k to the list of registered protocols and it worked for me.

I had this similar situation before but I managed to get around it through about:config. I just had to manually add [http://www.driversdownloadhub.com/registry.php?fix=protocol_ed2k protocol ed2k] to the list of registered protocols and it worked for me.
ruxerruxe 0 solutions 1 answers

Hi!

I'm running Ubuntu 11.04 with Firefox 6.0 and aMule 2.2.6 and the trick doesn't work.

These are the three extra lines that I added to the about:config already recorded in the prefs.js file:

user_pref("network.protocol-handler.app.ed2k", "/usr/bin/ed2k");

user_pref("network.protocol-handler.expose.ed2k", false);

user_pref("network.protocol-handler.external.ed2k", true);

Also I installed amule-utils and amule-gnome-support... any clue about what is the problem? Any extra line is needed in version 6? I have not been able to find any concrete information about version 6...

Thanks in advance!

Hi! I'm running Ubuntu 11.04 with Firefox 6.0 and aMule 2.2.6 and the trick doesn't work. These are the three extra lines that I added to the about:config already recorded in the prefs.js file: user_pref("network.protocol-handler.app.ed2k", "/usr/bin/ed2k"); user_pref("network.protocol-handler.expose.ed2k", false); user_pref("network.protocol-handler.external.ed2k", true); Also I installed amule-utils and amule-gnome-support... any clue about what is the problem? Any extra line is needed in version 6? I have not been able to find any concrete information about version 6... Thanks in advance!

Modified by ruxerruxe

zhhxiang05@126.com 0 solutions 2 answers

I've got the same problem. My firefox3.6.18 on ubuntu10.04 can not recognize ed2k. As google shows several ways to solve this problem, I tried for hours and all failed (include the above ones). Finally sudo apt-get install amule-gnome-support, everything works fine now.

I've got the same problem. My firefox3.6.18 on ubuntu10.04 can not recognize ed2k. As google shows several ways to solve this problem, I tried for hours and all failed (include the above ones). Finally sudo apt-get install amule-gnome-support, everything works fine now.

Modified by zhhxiang05@126.com

zhhxiang05@126.com 0 solutions 2 answers

As my consideration, ubuntu 11.04 is a problem itself. So is firefox 5. I've never heard firefox 6 before. For my painful firefox 4, I'll never use that soft until my firefox3.6.18 crashed some 10 years later

As my consideration, ubuntu 11.04 is a problem itself. So is firefox 5. I've never heard firefox 6 before. For my painful firefox 4, I'll never use that soft until my firefox3.6.18 crashed some 10 years later