X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Under 'Tools' my 'Private Browsing and 'Clear Recent History' are greyed out: how can I turn these options on?

Posted

On my Firefox menu the options Private Browsing and Clear Recent History are greyed out, so I am unable to turn them on or off. How do get these options? I cannot find abything in settings, etc. Thanks.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 8.2.4
  • Default Plug-in
  • Shockwave Flash 10.1 r82
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Java Plug-in 1.6.0_02 for Netscape Navigator (DLL Helper)

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.2.9) Gecko/20100824 Firefox/3.6.9 ( .NET CLR 3.5.30729)

More Information

the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24386 answers

Helpful Reply

You probably have Private Browsing turned on all the time in Options.

http://support.mozilla.com/en-US/kb/Private+Browsing

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Helpful Reply

Your above posted system details show outdated plugin(s) with known security and stability risks.

  • Adobe PDF Plug-In For Firefox and Netscape 8.2.4
  • Java Plug-in 1.6.0_02 for Netscape Navigator (DLL Helper)

Update the Java plugin to the latest version.

Update the Adobe Reader plugin to the latest version.


If you see a grayed "Stop Private Browsing" in the Tools menu then you are in private browsing mode as posted above.

  • You enter Private Browsing mode if you select: Tools > Options > Privacy > History: Firefox will: "Never Remember History"
  • To see all History settings, choose: Tools > Options > Privacy, choose the setting Firefox will: Use custom settings for history
  • Uncheck: [ ] "Automatically start Firefox in a private browsing session"

Question owner

Thanks kindly guys, problem solved.