X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I don't want firefox to reopen old windows when it restarts

Posted

On the rare occasions when Firefox crashes and I restart it I often end up getting the same problem that led to the initial crash because Firefox tries to restore all the windows from the previous session. I looked in the preferences but couldn't find a way to change this behavior. I don't want it to try and re-open old windows when it restarts, just go to my home page and let me reopen windows manually. Can I set that somehow?

Chosen solution

You can disable the resume from crash option by changing a hidden preference.

  1. Type about:config into the location bar and press enter
  2. Accept the warning message that appears, you will be taken to a list of preferences
  3. In the filter box type crash
  4. Double-click on the preference browser.sessionstore.resume_from_crash to change its value to false
Read this answer in context 20

Additional System Details

Installed Plug-ins

  • Gecko default plugin
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • iPhoto6
  • DivX Content Upload Plug-In: Uploads DivX video in your browser!
  • DivX Browser Plug-In: Plays DivX video in your browser!
  • RealPlayer Plugin
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Java Plug-In 2 for NPAPI Browsers
  • 4.0.50401.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.1 r82

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.9) Gecko/20100824 Firefox/3.6.9

More Information

TonyE
  • Moderator
1041 solutions 8840 answers

Chosen Solution

You can disable the resume from crash option by changing a hidden preference.

  1. Type about:config into the location bar and press enter
  2. Accept the warning message that appears, you will be taken to a list of preferences
  3. In the filter box type crash
  4. Double-click on the preference browser.sessionstore.resume_from_crash to change its value to false

Question owner

Thanks. Wish they would make that something editable via the UI but that solves the problem. Thank you.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

As an alternative you can set the pref browser.sessionstore.max_resumed_crashes to 0 on the about:config page to get the about:sessionrestore page immediately with the first restart after a crash has occurred or the Task Manager was used to close Firefox.

See:

http://kb.mozillazine.org/Browser.sessionstore.max_resumed_crashes
http://kb.mozillazine.org/Session_Restore#Restoring_a_session_after_a_crash
bazzer 0 solutions 2 answers

I'm having nightmares with this! I've added the following to prefs.js, but still the sessions resume after shutdown. It's not just a crash either, even if firefox exits gracefully, it happens. Is there some kind of log file I can interrogate to find out what's happening?

user_pref("browser.sessionstore.resume_from_crash", false);
user_pref("browser.sessionstore.max_windows_undo", 0);
user_pref("browser.sessionstore.max_tabs_undo", 0);
user_pref("browser.sessionstore.max_resumed_crashes", 0);
user_pref("browser.formfill.enable", false);
user_pref("browser.warnOnQuit", false);
user_pref("browser.tabs.warnOnClose", false);
user_pref("browser.startup.homepage_override.mstone", "ignore");
user_pref("browser.safebrowsing.enabled", false);
user_pref("browser.link.open_newwindow", 2);
user_pref("dom.disable_open_during_load", false);
user_pref("security.OCSP.enabled", 0);
user_pref("nglayout.initialpaint.delay", 0);
user_pref("content.notify.interval", 0);
user_pref("keyword.enabled", false);

Modified by cor-el

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

This can be a problem with the file sessionstore.js and sessionstore.bak in the Profile Folder

Delete the files sessionstore.js and sessionstore.bak and any existing files sessionstore-##.js with a number in the left part of the name like sessionstore-1.js to prevent Firefox from restoring a previous session.

See http://kb.mozillazine.org/Session_Restore

bazzer 0 solutions 2 answers

Thanks for the reply - there are no sessionstore.js or sessionstore.bak files! I thought it's odd behaviour - if these files don't exist, how does FF remember what was open?! Do these files normally grow in size as the time the user is browsing increases?

I can't help but feel maybe I've got some conflicting settings, effectively creating an 'unknown' state.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

If Firefox restores a session then that can only be done via a file sessionstore.js.

Make sure that you look in the correct location for the Firefox Profile Folder.

Help > Troubleshooting Information > Profile Directory > Open Containing folder

HellenMontgomery 0 solutions 1 answers

Helpful Reply

I am not a computer programmer and don't remember whatever I may have learned in DOS classes... When I open Firefox it goes DIRECTLY to a page that crashes my computer: originally I had to TURN OFF my computer to get out of it. NOW Mozilla Firefox goes directy to that page again, does not ask if I WANT to restore that session. I am thinking I will just DELETE all of Firefox from the Program menu

and then reload if I get around to it

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Set the pref browser.sessionstore.max_resumed_crashes to 0 on the about:config page to get the about:sessionrestore page immediately with the first restart after a crash has occurred or the Task Manager was used to close Firefox.

That will allow you to deselect the tab(s) that you do not want to reopen, but will allow to reopen the other tabs. See:

See http://kb.mozillazine.org/about%3Aconfig

pubpub 0 solutions 1 answers

G-sus Criiist, Firefox, what has happened to you? There are so many bugs and annoyances on this Firefox 9.0. Why in the world would you have to do all this coding sh*t just to get it not reopen pages after the crash? This has been an option in settings on ALL browsers for years.

What is WRONG with you Firefox? I just downloaded 9.0 this weekend and I've spent the entire weekend seeing one mess after another on your browser. Cripes.