Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I am unable to update Firefox/ to Firefox 3.6 on solaris OS

  • 6 replies
  • 11 have this problem
  • Last reply by utkarsh1425

more options

I have installed solaris X86 on my system, the default browser is Mozilla Fire fox, it is pre installed with Fire fox/ and when I try to upgrade I am unable to do so, I have checked for both the update methods, 1. by clicking on help and check for updates 2. by clicking on edit/preferences/advanced/update. I have also tried updating using the command pkgadd -d <package name> still I am unable to update, I get the same Fire fox/ in current version and grayed out option for "check for updates" & "fire fox" in update option. I have logged in as ROOT. Any help is appreciated. thanks in advance

All Replies (6)

more options

attaching the screen shot of the error

more options

How old is that version of Solaris?

Does it meet the System Requirements for Firefox 3+ versions?

Most Unix / Linux distros that come with Firefox disable the Check for Updates feature that is built into Firefox and provide their own Firefox updates thru their program repository instead.

more options

Did you ever figure out what your problem was? I am having the exact same problem. Version of Solaris is 10 (for x86). I installed Firefox 3.6.8 via pkgadd. The old version still comes up when you run either run the binary manually or you click on Firefox from the Launcher. It looks like we never upgraded...

more options

hi docteur99,

I have not tried any other steps in upgrading Firefox from 2.09 to 3.6 as soon as I do it weather successful or failed in upgradation I will let you know the steps.

my personal id is let me know yours so that I can be in touch with you.


more options

Did anyone ever solve this? I have the same issue. I removed all the mozilla and firefox packages, and deleted every instance of firefox I can find. I have tried the downloading it from and If I run firefox -version, it reports the correct version, but when I run firefox and check the help->about it still tells me that I am running

more options

Hi Pburdine,

It seems that with sun solaris is shipped its loaded with default mozilla 2.09 version even if you update it to the latest 3.XX version the next time you boot the machine & start FF it will take you back to 2.09 version.

1 either you can install a new version & create a desktop shortcut so that every time you need to use FF you click on the short cut & access FF

Thanks, Ut.