X
Tap here to go to the mobile version of the site.

Support Forum

How can I fix the security warning I keep getting regarding unencrypted connections?

Posted

When I surf the internet, I get a security warning saying that I am sending information over an unencrypted connection that can be viewed by a third party. I would like to resolved this.

When I surf the internet, I get a security warning saying that I am sending information over an unencrypted connection that can be viewed by a third party. I would like to resolved this.

Additional System Details

This happened

Every time Firefox opened

This started when...

Sunday August 22, 2010

Installed Plug-ins

  • Shockwave Flash 10.0 r45
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • Gecko default plugin
  • iPhoto6
  • Java Plug-In 2 for NPAPI Browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17334 solutions 156713 answers

Do you mean this warning message?

"Although this page is encrypted, the information you have entered is to be sent over an unencrypted connection and could easily be read by a third party"


That is the "PostToInsecureFromSecureMessage" warning and can't be suppressed.

The warning tells you that you are sending data from a secure site to a non secure http url.

Do you mean this warning message? <blockquote>"Although this page is encrypted, the information you have entered is to be sent over an unencrypted connection and could easily be read by a third party" </blockquote> That is the "PostToInsecureFromSecureMessage" warning and can't be suppressed. The warning tells you that you are sending data from a secure site to a non secure http url.

Question owner

Hi, the message is similar, it reads "security warning: the information you have entered is to be sent over an unencrypted connection and could easily be read by a third party. Are you sure you want to continue sending this information?"

I have never had this problem before when I was on the internet, it just started about 3 days ago. I receive this message when I'm reading the news, looking up stuff and when I'm reading and sending my emails.

Hi, the message is similar, it reads "security warning: the information you have entered is to be sent over an unencrypted connection and could easily be read by a third party. Are you sure you want to continue sending this information?" I have never had this problem before when I was on the internet, it just started about 3 days ago. I receive this message when I'm reading the news, looking up stuff and when I'm reading and sending my emails.
cor-el
  • Top 10 Contributor
  • Moderator
17334 solutions 156713 answers

You should be able to suppress that PostToInsecureFromInsecureMessage warning message.

See "Warning Messages": Security and passwords settings

Tools > Options > Security : Warning Message

[] "I submit information that is not encrypted"
You should be able to suppress that PostToInsecureFromInsecureMessage warning message. See "Warning Messages": [[Options window - Security panel]] Tools > Options > Security : Warning Message [] "I submit information that is not encrypted"
negativeions 0 solutions 5 answers

Like the poster, I'm using OSX, not windows. There is no tools > options > security: warning message. What do we do if we're on OSX? This is so annoying I can't believe I can't find an answer to this. On one particular site I'm getting 5 security warnings in a row I have to click OK 5 times. what the hell is gong on here? This is ridiculous.

Like the poster, I'm using OSX, not windows. There is no tools > options > security: warning message. What do we do if we're on OSX? This is so annoying I can't believe I can't find an answer to this. On one particular site I'm getting 5 security warnings in a row I have to click OK 5 times. what the hell is gong on here? This is ridiculous.
cor-el
  • Top 10 Contributor
  • Moderator
17334 solutions 156713 answers

Helpful Reply

The settings for the warning messages have been removed from the user interface (Bug 513166).

You need to change the related security.warn_* prefs directly on the about:config page.
Filter: security.warn


To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.

  • Use the Filter bar at to top of the about:config page to locate a preference more easily.
  • Preferences that have been modified show as bold (user set).
  • Preferences can be reset to the default via the right-click context menu if they are user set
  • Preferences can be changed via the right-click context menu: Modify (String or Integer) or Toggle (Boolean)
The settings for the warning messages have been removed from the user interface (Bug 513166). You need to change the related security.warn_* prefs directly on the <b>about:config</b> page.<br /> Filter: security.warn ----- To open the <i>about:config</i> page, type <b>about:config</b> in the location (address) bar and press the "<i>Enter</i>" key, just like you type the url of a website to open a website.<br /> If you see a warning then you can confirm that you want to access that page.<br /> *Use the Filter bar at to top of the about:config page to locate a preference more easily. *Preferences that have been modified show as bold (user set). *Preferences can be reset to the default via the right-click context menu if they are user set *Preferences can be changed via the right-click context menu: Modify (String or Integer) or Toggle (Boolean)