X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I disable "encrypted page/unencrypted connection" security warning?

Posted

I keep getting the message "Although this page is encrypted, the information you have entered is to be sent over an unencrypted connection and could easily be read by a third party". I have unchecked all the boxes in the Tools>Options>Security>Settings. They weren't checked to begin with. In fact, if I select the "I'm about to view an encrypted page that contains some unencrypted information" option I get a dialog box that looks completely different and is worded "You have requested an encrypted page that contains some unencrypted information. Information that you see or enter on this page could easily be read by a third party." When I click continue I get the the original message too! What is going on and how do I fix it?

Modified by freeang

Additional System Details

Installed Plug-ins

  • npsnapfish
  • Office Plugin for Netscape Navigator
  • Adobe PDF Plug-In For Firefox and Netscape
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • Shockwave Flash 10.1 r82
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_21 for Mozilla browsers
  • 4.0.50524.0
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Tools > Options > Security : Warning Message

[] "I'm about to view an encrypted page that contains some unencrypted information"

See "Warning Messages": Security and passwords settings

Question owner

Hi, thank you for responding so quickly. The first thing I did was follow the solution you provided. It doesn't work. My security settings are not set to notify me of mixed content. I still get a message. What else can I do?

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Sorry, I have confused the two warning messages.

You can't suppress the "Although this page is encrypted, the information you have entered is to be sent over an unencrypted connection and could easily be read by a third party" warning for security reasons.

That is the "PostToInsecureFromSecureMessage" warning and can't be suppressed. You will get that warning if you go from a secure https connection to an insecure http connection and POST data entered in a form on a secure site is send to an http server.

See http://mxr.mozilla.org/mozilla-central/source/security/manager/boot/src/nsSecurityWarningDialogs.cpp#262

No preference for this one - it's too important

Question owner

Okay, thanks for your time.

thepanther 0 solutions 1 answers

If the site you are having trouble with is http://my.msn.com

 try bookmarking 

https://my.msn.com instead (note the httpS, not HTTP)

Probably would work for other sites too, as long as the main url supports https and http.

Shodan816 0 solutions 1 answers

THANK YOU, thepanther ! ! I have been searching and searching for a fix for this issue and you are the only one who posted a suggestion that worked ! Much appreciated ! ! !

Question owner

Actually, the site I am having trouble with is the log in page for my kids' on-line school. I thought I would try your suggestion, but I noticed the address for the log-in screen is already an https, not an http. Once I have entered my log-in info I am automatically redirected to the school page which is not an https. I tried changing it, but it didn't work. At this point my kids know that for the purpose of logging in to school it is okay to bypass this security warning. For all others they stop everything and get mom.

whopants 0 solutions 1 answers

Help PLEASE i have the same problem and mine already says https and I'm not sure what you mean by bookmarking, msn is my homepage and this is driving me nuts.

sagibranch 0 solutions 1 answers

Personally I find this little feature extremely annoying since it only recently became an issue for a couple of games I play on Facebook. Firefox is my favorite browser but if I can't disable this warning or have an exception for these games I may end up switching to something else.

Note: changed my Facebook settings to allow secured browsing & so far so good.

Modified by sagibranch

fqJqp5jfBp 0 solutions 1 answers

Helpful Reply

Thank you for pointing to the developers' outrageous position. This will at least save us from the frustration of further fiddling with Firefox settings.

FWIW, I'll be filing a bug report (yes, I know it's a "feature") and posting to MacInTouch. Note, too, that this not just a Windows XP issue, as indicated by the System Details, but applies equally to Firefox 7.0.1 running under Mac OS 10.6.8.

If I needed a nanny, I'd have hired one.

U517vEvj 0 solutions 3 answers

That conclusion is completely stupid, and precisely the kind of thing I have long disliked about Microsoft -- it's as if users are believed to be smart enough to choose products from a company, but not smart enough to know, learn, or care about how to use those products intelligently and responsibly. I suppose it's no surprise that Mozilla has now fallen to that same level, and it now seems my only other option is to find some other browser.