X
Tap here to go to the mobile version of the site.

Support Forum

want & tried installing 3.6 on a OpenSuSE-11.2 : bad ElfClass64 /usr/lib64/libdbus-glib-1.so.2 - what to do? Thanks a lot

Posted

downloaded vers. 3.6 and tried installing ... linux-User251868:/usr/src/packages/SOURCES/firefox-3.6 # ls application.ini components dependentlibs.list greprefs libnspr4.so libnssutil3.so libsoftokn3.so LICENSE plugins searchplugins .autoreg crashreporter dictionaries icons libnss3.so libplc4.so libsqlite3.so modules README.txt Throbber-small.gif blocklist.xml crashreporter.ini extensions libfreebl3.chk libnssckbi.so libplds4.so libssl3.so mozilla-xremote-client removed-files update.locale browserconfig.properties crashreporter-override.ini firefox libfreebl3.so libnssdbm3.chk libsmime3.so libxpcom.so platform.ini res updater chrome defaults firefox-bin libmozjs.so libnssdbm3.so libsoftokn3.chk libxul.so plugin-container run-mozilla.sh updater.ini linux-User251868:/usr/src/packages/SOURCES/firefox-3.6 # ./firefox ./firefox-bin: error while loading shared libraries: libdbus-glib-1.so.2: cannot open shared object file: No such file or directory linux-User251868:/usr/src/packages/SOURCES/firefox-3.6 # mc linux-User251868:/usr/src/packages/SOURCES/firefox-3.6 # ln -s /usr/lib64/libdbus-glib-1.so.2 /usr/lib/libdbus-glib-1.so.2 linux-User251868:/usr/src/packages/SOURCES/firefox-3.6 # ./firefox ./firefox-bin: error while loading shared libraries: libdbus-glib-1.so.2: wrong ELF class: ELFCLASS64 linux-User251868:/usr/src/packages/SOURCES/firefox-3.6 # ./updater Usage: updater <dir-path> [parent-pid [working-dir callback args...]] linux-User251868:/usr/src/packages/SOURCES/firefox-3.6 #

i do not want depend on and if OpenSuSE update to 3.6 - In fact before using OpenSuSE 11.2 i had installed firefox 3.5 which updated automatically, sort of b-tester as i trully trust firefox for day to day browsing since years ago.

downloaded vers. 3.6 and tried installing ... linux-User251868:/usr/src/packages/SOURCES/firefox-3.6 # ls application.ini components dependentlibs.list greprefs libnspr4.so libnssutil3.so libsoftokn3.so LICENSE plugins searchplugins .autoreg crashreporter dictionaries icons libnss3.so libplc4.so libsqlite3.so modules README.txt Throbber-small.gif blocklist.xml crashreporter.ini extensions libfreebl3.chk libnssckbi.so libplds4.so libssl3.so mozilla-xremote-client removed-files update.locale browserconfig.properties crashreporter-override.ini firefox libfreebl3.so libnssdbm3.chk libsmime3.so libxpcom.so platform.ini res updater chrome defaults firefox-bin libmozjs.so libnssdbm3.so libsoftokn3.chk libxul.so plugin-container run-mozilla.sh updater.ini linux-User251868:/usr/src/packages/SOURCES/firefox-3.6 # ./firefox ./firefox-bin: error while loading shared libraries: libdbus-glib-1.so.2: cannot open shared object file: No such file or directory linux-User251868:/usr/src/packages/SOURCES/firefox-3.6 # mc linux-User251868:/usr/src/packages/SOURCES/firefox-3.6 # ln -s /usr/lib64/libdbus-glib-1.so.2 /usr/lib/libdbus-glib-1.so.2 linux-User251868:/usr/src/packages/SOURCES/firefox-3.6 # ./firefox ./firefox-bin: error while loading shared libraries: libdbus-glib-1.so.2: wrong ELF class: ELFCLASS64 linux-User251868:/usr/src/packages/SOURCES/firefox-3.6 # ./updater Usage: updater <dir-path> [parent-pid [working-dir callback args...]] linux-User251868:/usr/src/packages/SOURCES/firefox-3.6 # i do not want depend on and if OpenSuSE update to 3.6 - In fact before using OpenSuSE 11.2 i had installed firefox 3.5 which updated automatically, sort of b-tester as i trully trust firefox for day to day browsing since years ago.

Chosen solution

Firefox is a 32 bit application, so you need to create a symlink to the 32 bit version of that dbus library (libdbus-glib-1.so.2). If that library isn't installed then you need to install it via Install Software.

See also http://www.mozilla.com/firefox/system-requirements.html - Firefox 3.6 System Requirements

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 10.1 r53
  • The Adobe Reader plugin is used to enable viewing of PDF and FDF files from within the browser.
  • The IcedTea Java Web Browser Plugin 1.6.2 (suse-5.10.1-x86_64) executes Java applets.
  • Plugin for Installing Applications (new)
  • Mime Type x-skype for Skype Buttons
  • nspluginwrapper is a cross-platform NPAPI plugin viewer, in particular for linux/i386 plugins.This software is available under the terms of the GNU General Public License.
  • Shockwave Flash 9.0 r999. Gnash 0.8.5, the GNU SWF Player. Copyright © 2006, 2007, 2008 Free Software Foundation, Inc. Gnash comes with NO WARRANTY, to the extent permitted by law. You may redistribute copies of Gnash under the terms of the GNU General Public License. For more information about Gnash, see http://www.gnu.org/software/gnash. Compatible Shockwave Flash 9.0 r999.
  • Shockwave Flash 9.0 r999

Application

  • User Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.4) Gecko/20091016 SUSE/3.5.4-1.1.2 Firefox/3.5.4

More Information

DaveRo 18 solutions 175 answers

Helpful Reply

I don't know the reason for your problem but I take your final statement to mean that you do want the latest version: 3.6.8

See this - and in particular my draft on installing the latest version of Thunderbird on OpenSUSE. It's exactly the same with Firefox.

https://bugzilla.mozilla.org/show_bug.cgi?id=560635#c6
I don't know the reason for your problem but I take your final statement to mean that you do want the latest version: 3.6.8 See this - and in particular my draft on installing the latest version of Thunderbird on OpenSUSE. It's exactly the same with Firefox. https://bugzilla.mozilla.org/show_bug.cgi?id=560635#c6
cor-el
  • Top 10 Contributor
  • Moderator
17519 solutions 158412 answers

Chosen Solution

Firefox is a 32 bit application, so you need to create a symlink to the 32 bit version of that dbus library (libdbus-glib-1.so.2). If that library isn't installed then you need to install it via Install Software.

See also http://www.mozilla.com/firefox/system-requirements.html - Firefox 3.6 System Requirements

Firefox is a 32 bit application, so you need to create a symlink to the 32 bit version of that dbus library (libdbus-glib-1.so.2). If that library isn't installed then you need to install it via Install Software. See also http://www.mozilla.com/firefox/system-requirements.html - Firefox 3.6 System Requirements