X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why does text overlap with other text and graphics on my screen? This does not happen with IE.

Posted

When I view many sites I often have an overlap of text making content reading very difficult and at times impossible to decypher. At those times I find it necessary to view the site with IE for clarity. Overlap also interferes with graphics - it is like having too much information on the screen requiring it to overlap.

Additional System Details

This happened

Every time Firefox opened

This started when...

Ever since I got this computer, ab out 2 years ago

Installed Plug-ins

  • Office Plugin for Netscape Navigator
  • np-mswmp
  • 1.6.0028.1
  • BitTorrent Plugin 1
  • 1.9.0009.1
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 8.2.3
  • Default Plug-in
  • Shockwave Flash 10.1 r53
  • iTunes Detector Plug-in
  • Delivery Network Acceleration by BitTorrent™
  • GEPlugin
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Update
  • Next Generation Java Plug-in 1.6.0_20 for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8 ( .NET CLR 3.5.30729; .NET4.0C)

More Information

TonyE
  • Moderator
1041 solutions 8840 answers

See Web sites look wrong, start with the section about minimum font size.

cor-el
  • Top 10 Contributor
  • Moderator
10752 solutions 96760 answers

Specifying your own fonts can also cause such issues.

Tools > Options > Content : Fonts & Colors: Advanced > [X]"Allow pages to choose their own fonts, instead of my selections above"


If you can't solve it then please post a link and attach a screenshot, so we can check what is happening.

Use a compressed image type like PNG or JPG to save the screenshot and make sure that you do not exceed the maximum file size (1 MB) and do not click Preview after you have attached the image.

rorigiles 0 solutions 2 answers

I have this problem too. It only seems to occur when I open my dedicated homepage. IE does not have the same problem.

cor-el
  • Top 10 Contributor
  • Moderator
10752 solutions 96760 answers

Reset the page zoom on pages that cause problems: View > Zoom > Reset (Ctrl+0 (zero); Cmd+0 on Mac)

raalex1949 0 solutions 1 answers

I also have this problem with my email. Also on other sites the text will overlap.

cor-el
  • Top 10 Contributor
  • Moderator
10752 solutions 96760 answers

If you have increased the minimum font size then try the default setting "none" as a high value can cause issues like you described.

  • Tools > Options > Content : Fonts & Colors > Advanced > Minimum Font Size (none)
  • Tools > Options > Content : Fonts & Colors > Advanced > [X] "Allow pages to choose their own fonts, instead of my selections above"

  • Windows: Firefox (Tools) > Options
  • Mac: Firefox > Preferences
  • Linux: Edit > Preferences
jedics 0 solutions 2 answers

indeed increasing the 'minimum font size' option to above 13 creates this problem for me, trouble is reading text Is a HUGE pain at that size, FF need to fix this asap.

cor-el
  • Top 10 Contributor
  • Moderator
10752 solutions 96760 answers

You can use one of these extensions to set a default font size and page zoom on web pages: