Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I currently have Firefox 3.6.8 but need Firefox 3.0 to work with a certain website. How can I download version 3.0 and not loose 3.6.8?

more options

A company I want to order from has security access to only Firefox 3.0 and cannot process orders using 3.6.8.We have been instructed to download version 3.0 for such purchases only.

All Replies (1)

more options

Install the 3.0.19 version of Portable Firefox, it won't affect your 3.6.8 installation. http://portableapps.com/apps/internet/firefox_portable/localization#legacy

Modified by the-edmeister