Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot upgrade from 3.6.3 ,get XUL Runner error, about incompatible platforms

  • 1 reply
  • 6 have this problem
  • Last reply by cor-el

more options

I am trying to update from 3.6.3 to 3.6.8, I have been needing to update for months, but everytime, after the install when I try to open FF, it gives me an XUL Runner error that says, Platform version 1.9.2.3 is not compatible with Minversion 1.9.2.8, maxversion 1.9.2.8

Please help. I have closed zone alarm, and spysweeper on windows xp, and uninstalled 3.6.3, and rebooted, and closed everything before installing, again, it still does not help.

All Replies (1)

more options

Do a clean reinstall and download a fresh Firefox copy from http://www.mozilla.com/firefox/all.html and save the file to the desktop.
Uninstall your current Firefox version and remove the Firefox program folder before installing that copy of the Firefox installer.
It is important to delete the Firefox program folder to remove all the files and make sure that there are no problems with files that were leftover after uninstalling.
You can initially skip the step to create a new profile, that may not necessary for this issue.