X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do i fix a flash "plug-in container" issue (ff indicates most recent version is installed)

Posted

Hello. to start with im not really up on the ins and outs of ff, ive used it for a while but not really tinkered with till this problem

Im running Vista (no comments on that please :p) and the latest version of as downloaded from the mozilla website (3.6 something)

my plug-ins are (version number): 2007 MS Office system (12.0.4518.1014), Bio3D (12.0.0.733) - this comes with ChemDraw i think, ChemDraw (12.0.0.733), getPlusPlus for Adobe 16287 (1.6.2.87), Java Deployment Toolkit (6.0.210.6), Java(TM) Platform SE 6 U21 (6.0.210.6), MS Office Live Plug-in for FF (2.0.4024.1), MS (R) WMP FF plug-in (1.0.0.8), Mozilla Default Plug-in (1.0.0.15), Novell iPrint Plug-in (5.3.0.0), Novell iPrint Scriptable Plug-in 1.0 (5.3.0.0), Quicktime P-in (7.6.6.0), Shockwave Flash (10.1.53.64), Silverlight P-in (4.0.50524.0), Windows Presentation Foundation (3.5.30729.1). Ive been on numerous fix-it sites but cant find a solution i understand or can get to work. the problem still occurs in safe mode and with only shockwave flash enabled (this seems to be the issue) and after numerous reinstalls, i have also deleted all i can find of adobe and shockwave then reinstalled to no avail :(

Whats chrome like? Thank you muchly

URL of affected sites

http://www.youtube.com

Chosen solution

In Firefox 3.6.4 and newer, plugins are run in a separate process called plugin container. When you see that plugin container is using lots of processor or ram it's because it's busy running a plugin like Flash. This may be slowing your computer down but that's expected. Before Firefox 3.6.4 the plugins like Flash were just run by Firefox itself (taking up lots of cpu and ram). The advantage of running them in plugin container is that if Flash crashes then you just have to reload the tab (or quit plugin container from the task manager) instead of having Firefox and all of your tabs crash.

You can read more about plugin container here: What is plugin-container

If you want to disable this feature, read this: Disable hang protection

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • -getplusplusadobe16287
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 10.1 r53
  • Next Generation Java Plug-in 1.6.0_21 for Mozilla browsers
  • iPrint Plug-in 1.0.0 - Provides iPrint client services for Windows
  • Novell iPrint Scriptable Plug-in provides functions for the iPrint Map Designer

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8 (.NET CLR 3.5.30729)

More Information

Question owner

Youtube screen failed this morning and followed onscreen inst updated flash player. Even though successful installation, Youtube flash player will not work. Clicked Firefox Addons and the links found that flash player was installed on my computer but Youtube will still not show videos. I think there is a quick flash that plugins have been disabled and always the need to upgrade my player. Yesterday JV16 deleted Ask.com from my computer and I am wondering if there is any connection.....Seamus

Question owner

Error happening while opening youtube.com .. in the task manager. Plugin container showing of usage in memory usage. Suddenly forefox hang... restart without plugin ok surfing but without youtube viewing...

Question owner

You must enable all plugins from the Add-ons Window. I made a brief tutorial on to do this.

Question owner

thank you for the extra post

i left a another post earlier on this thread but i cant see it, so this may be a repeat. (apologies)

The detail of the problem i missed out in the original part: on Youtube when watching a video one of a number of things may happen:- the video will crash ff instantly, play for ~20 then freeze, play fine but freeze if i skip to another part of the (loaded) video) or click around the timer bar or b finally the first video will play fine and a second video will do the above.

this happens independantly of safemode or enabled/disabled plug-ins (appart from flash to view the videos)

Question owner

No commen,,my computer

Morbus 134 solutions 2338 answers

Hello everyone.

It's possible that you are having a problem with some Firefox add-on that is hindering your Firefox's normal behavior. Have you tried disabling all add-ons (just to check), to see if Firefox goes back to normal?

Whenever you have a problem with Firefox, whatever it is, you should make sure it's not caused by one (or more than one) of your installed add-ons, be it an extension, a theme or a plugin. To do that easily and cleanly, run Firefox in safe mode (don't forget to select Disable all add-ons when you start safe mode). If the problem disappears, you know it's from an add-on. Disable them all in normal mode, and enable them one at a time until you find the source of the problem. See this article for information about troubleshooting extensions and themes and this one for plugins.

If you need support for one of your add-ons, you'll have to contact its author.

If the problem does not disappear when all add-ons are disabled, please tell me, so we can work from there. Please have no fear of following my instructions to the line, as all can be easily undone.

ryland13 0 solutions 2 answers

Helpful Reply

hi all - I have a similar problem with flash - basically the plugin crashes pretty much every time I am not looking at it directly (playing online games in tabs for example) I have tried disabling the "memory-safe-away-time-out thingee" in config:about - to no avail. I have also tried disabling all other plugins (not that I actually have many - Java, VLC, quicktime, some windows stuff), have set themes to default, have made sure all plugins are latest version. currently running the 4.0.b2 Firefox version cause of the plug in crashes in the 3.6.8 version - same problem though. and where it gets really strange is that a friendly help person on the adobe site suggested I upgrade my firefox to version 3.8 (while I was on the 3.6.8 version) and that would fix it. which I thought was.. interesting as 3.6.8 is the latest version as Firefox upgrade check insisted. by now i have invested at least 4 days trying to fix this issue and I gotta say... I am tempted to actually try other browsers, though firefox is my default browser since years.

ryland13 0 solutions 2 answers

oh and i should probably add that I am on windows XP pro - so I doubt it is vista or XP causing the issues as it seems to persist across plattforms

JPC2000 0 solutions 3 answers

Helpful Reply

I am having the same problem and all since i upgraded to the latest version of FF. My default browser for years and i have never had any problems before. It happens every time I try and load a page. Even BBC Iplayer won't work! It seems to be something wrong with the coding for the Plugin-container.exe! I have isolated the cause of the problem as this because Adobe Flash player works fine in IE 8. and that is the same coding plugin. I still haven't come across a solution yet but am looking and the only on ei can see as temporary is to try and block Plugin-container.exe from opening up in the computer process'.

Michael Verdi
  • Administrator
  • Moderator
107 solutions 739 answers

Chosen Solution

In Firefox 3.6.4 and newer, plugins are run in a separate process called plugin container. When you see that plugin container is using lots of processor or ram it's because it's busy running a plugin like Flash. This may be slowing your computer down but that's expected. Before Firefox 3.6.4 the plugins like Flash were just run by Firefox itself (taking up lots of cpu and ram). The advantage of running them in plugin container is that if Flash crashes then you just have to reload the tab (or quit plugin container from the task manager) instead of having Firefox and all of your tabs crash.

You can read more about plugin container here: What is plugin-container

If you want to disable this feature, read this: Disable hang protection

Modified by Michael Verdi

AGL10 0 solutions 1 answers

I'm running Firefox 3.6.8 and I'm having trouble with the plugin container using far too much ram when running Silverlight 4.0.50524.0 (latest version of both). I'm on Windows Vista Home Premium Service Pack 1.

However, the problem *just* started since I switched from DSL to cable (from AT&T to Comcast -- the Comcast guys also put viruses on my husband's computer, he got a trojan right after they installed their software and had to reformat because his computer kept restarting and wouldn't get past loading Windows XP). I haven't upgraded either Firefox or Silverlight, yet I'm suddenly *now* having an issue with the plugin container (presumably from Silverlight) after a couple of minutes of streaming on Netflix.

silkphoenix 92 solutions 1250 answers

Please read this thread and go down to the solutions posted by AliceWyman:


http://support.mozilla.com/en-US/questions/713600#answer-8632

ryelving 0 solutions 1 answers

Although I understand what the possible advantages are to having plug-ins within your browser, I have found that this addition has been less than beneficial to my Firefox experiance. The major problem being the multiple crashes associated with the plug-in container.exe. This problem occurs most when linking from one site to another, and when on high content/flash player content sites (i.e. Blackboard, Hulu, game sites).

The more elegant the site/action, the more likely the crash. I have had this problem constantly at work, home, and school-on Mac OSX and on Windows (XP, Vista, 7). I just had Firefox crash seven times within one minute!

I am now using Internet Explorer to leave this message, as Firefox won't stop crashing. This may be a case in which the ease of a plug-in is not yet more valuable to your users than being able to run the browser for more than a few minutes.

WTFmozilla 0 solutions 1 answers

Arrghh this plugin-container.exe is appalling rubbish, it makes FF unusable and slows my whole system to a crawl! This should've been tested before releasing it. Please go back to whatever system you had before, it worked perfectly. All I see from FF is denial and trying to blame the plugins. This is nonsense, they worked perfectly before plug-in container, and people who've managed to disable plugin-container find their plugins work perfectly again. Mozilla should to admit the problem is theirs and reverse this "upgrade".

arowdy1 0 solutions 1 answers

I spend numerous hours looking for the fixes and doing them. right after ff updates.Just to have an update find its way back on my computer(via family or ?).As soon as I get FF going again with minimal crashes, you come out with another update and the cycle repeats itself. The plug in container is my worst enemy, my biggest nightmare,FF spends more time reloading pages because everything crashes, or the Plug in container is using excessive memory and cpu and FF always uses excessive memory and cpu or nothing loads at all or it is frozen,sometimes the page is just text and not positioned correctly.Yes I have done safe mode to con fig the plug in and updated etc. I have read more pages on your site about the problem and have followed the directions to maybe get it not to crash everyday but every other day.Just to have an update mess everything up. My hair is turning gray. My family and I used to love FF. Now we are all opening different browsers to go online and learning to like them.I really wish you guys have fixed this problem . I no longer have the desire to chase down the cure.I have submitted crash reports and still the problem remains for a while now.I am really going to miss FF. I need to reduce some stress from my life and FF is one of the first things to go.

icy112 0 solutions 5 answers

try this it's working perfectly with me

http://www.technogadge.com/how-to-stop-firefox-plugin-container-exe-process/

celsosan 0 solutions 3 answers

Please answer me this question : Can I use Firefox on a 64 -bit?

Modified by celsosan