X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 4b2 and Windows 7, multiple tabs shows up as windows in OS-taskbar

Posted

I have been using Firefox on my Windows 7 based computer (Ultimate x64) and I didn't experience this when using v3.6 and earlier versions. But ever since I updated to v4 (beta 1 and now beta 2), I have noticed that when I have multiple tabs open in Firefox, it shows up as Windows in Windows 7-taskbar... If I hover the pointer over to, and place it above the Firefox Icon (or click it), a LOOOOOooonng list shows up with each tab.. But that wasn't the case when using v3.6 for example, instead, each window showed up, but the tabs didn't show until I opened the actual Firefox-window, and this is exactly how I would like it to be.. I have been searching with lights and without finding any answer/s, search the settings-tab and other locations where this feature might show up, but I can't seem to find it, Im completely out of ideas and I need your help.

Best regards // Martin Johansson, Sweden

This happened

Every time Firefox opened

== When I updated from v3.6 to v4 Beta 1, and now also with beta 2

Chosen solution

You're welcome

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • -Google Update
  • Shockwave Flash 10.1 r53
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • Next Generation Java Plug-in 1.6.0_21 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 4.0.50524.0
  • NPWLPG
  • Nexus Personal Plug-Ins
  • Voddler Web Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; rv:2.0b2) Gecko/20100720 Firefox/4.0b2

More Information

TonyE
  • Moderator
1041 solutions 8840 answers

Helpful Reply

You need to change a hidden setting.

Type about:config into the location bar and press enter. Accept the warning dialog that appears. This brings up a list of preferences, in the filter box type taskbar Double-click on the preference called browser.taskbar.previews.enable to change its value to false

Question owner

Awesome!

That's exactly what I have been looking for, I was thinking about "about:config" but I didn't think it would be a hidden setting, this should be easy to change since not everyone likes it.

Thanks a million for a smoking fast answer! Case closed but you can keep it alive (if you want) for further users searching for the same solution.

Thanks again! // Martin

TonyE
  • Moderator
1041 solutions 8840 answers

Chosen Solution

You're welcome

tossican 0 solutions 1 answers

Thank you so much for this answer! .. But let's take it one step further...

I have started playing with the new panorama thing... As far as FF is concerned all groups (containing 9 tabs in all) are now in a single window. As such with the above solution I only get a single preview over the taskbar button..

Is there any way to get FF to show a preview for each of my three panorama groups without moving the tabs back to three separate windows?

rohitmittal16 0 solutions 5 answers

Hi,

i would like to thank you for giving such a beautful soultion to above problem which even i faced.

I ran into another issue as whenever i minimize firefox windo completely and then try to open from the tabbed view, it automatically resizes window to Rectangular size.

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Window sizes and positions are stored in localstore.rdf in the Profile Folder.

Delete localstore.rdf or rename the file to localstore.rdf.sav in the Profile Folder to test if the file is corrupted.
See http://kb.mozillazine.org/Corrupt_localstore.rdf
(caution: do not delete the localstore.rdf file in the Firefox program installation folder)

Note:
Deleting the file localstore.rdf will reset the customizations of the toolbars to the defaults.
You can rename "localstore.rdf" to "localstore.rdf.sav" to test if that solves it.
Then you can restore the customization by copying "localstore.rdf.sav" to "localstore.rdf" if it didn't work.