Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

i get an error message when i try to start firefox

more options

This is the error message

Error: Platform version ' ' is not compatible with minVersion >= 1.9.2.8 maxVersion

All Replies (1)

more options

To fix this issue, simply update Firefox if you don't have latest version and update java and adobe flash player or downlaod them if you don't have them.