X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

My default search engine has been set to something other than Google. How do I switch it back?

Posted

Somehow my default search engine has been changed from Google to something called "My Web Search". I want to switch it back to Google, but I can't figure out how. I disabled the plugin and removed it from my search engine options in the upper right corner, but nothing has changed.

Modified by Noah_SUMO

Chosen solution

You have My Web Search installed; look under Tools > Add-ons > Plugins. It could have piggy-backed in on something you installed. Always look for and opt-out during installation of other programs and add-ons that you install from sites other than the Mozilla add-ons site. My Web Search is considered malware/adware/spyware by many. You should remove it.

Step 1. You can check if you have any of these from "Fun Web Products" installed: Control Panel > Add or Remove Programs: Ask.com Bar,My Search Bar,MyWay Speed Bar,My Web Search Bar,Fun Web Products Easy Installer See: http://www.safer-networking.com/removemywebsearch.php PC Hell: My Web Search Removal Instructions http://helpint.mywebsearch.com/intlinfo/help/toolhelp.jhtml#q3 http://support.mozilla.com/en-US/kb/Troubleshooting+plugins#Manually_uninstalling_a_plugin

Step 2. You may need to change a preference to reset your default URL/location bar search provider: -Enter about:config in the address/URL bar and press the Enter key -If you see a warning, accept it (Promise that you will be careful) -Filter = keyword.url -Below the Filter, right-click on keyword.URL and choose "Reset" -Restart Firefox (File > Restart Firefox) See: http://kb.mozillazine.org/Keyword.url

Step 3. You may need to reset your homepage. Firefox can open multiple home pages. Home pages are separated by the "|" symbol. See: http://support.mozilla.com/en-US/kb/How+to+set+the+home+page


Other Issues: ~~red:You have installed plug-ins with known security issues. You should update them immediately.~~

You ~~red:MAY~~ need to Update Adobe Reader for Firefox (aka Adobe PDF Plug-In For Firefox): your ver. N/A; current ver. 9.3.3 (important security update release 06-29-2010; see: http://www.adobe.com/support/security/bulletins/apsb10-15.html) ~~red:Check your version here~~: http://www.mozilla.com/en-US/plugincheck/ See: http://support.mozilla.com/en-US/kb/Using+the+Adobe+Reader+plugin+with+Firefox#Installing_and_updating_Adobe_Reader ~~blue:You may be able to update from the Adobe Reader installed on your system~~ instead of going to the Adobe site and downloading. Open the Adobe Reader installed on your system (in Windows, Start > Program Files, find and click Adobe Reader to open), click Help, click Check for Updates. Allow the download/update to occur. If you use this method, no need to proceed with the instructions below, but do look at the two bulleted items at the bottom "NOTE for IE:" and "Also see:". Restart Firefox and check your new version here: http://www.mozilla.com/en-US/plugincheck/ ~~blue:If you go to the Adobe site to download the current Adobe Reader:~~ -use Firefox to download and SAVE to your hard drive (save to Desktop for easy access) ~~red:-See the images at the bottom left of this post to see the steps to take on the Adobe site~~ -exit Firefox (File > Exit) -In Windows: check to see that Firefox is completely closed (Ctrl+Alt+Del, choose Task Manager, click Processes tab, if "firefox.exe" is on the list, right-click "firefox.exe" and choose End process, close the Task Manager window) -In Windows: double-click on the Adobe Reader installer you just downloaded to install/update Adobe Reader

Read this answer in context 22

Additional System Details

Installed Plug-ins

  • -NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • Provides additional functionality on Facebook. See our web site for details.
  • The Hulu Desktop Plugin allows Hulu.com to integrate with the Hulu Desktop application.
  • Shockwave Flash 10.1 r53
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • DivX Web Player version 2.0.2.40
  • 4.0.50524.0
  • NPWLPG
  • My Web Search Plugin Stub for 32-bit Windows
  • Google Update
  • Next Generation Java Plug-in 1.6.0_20 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.7) Gecko/20100713 Firefox/3.6.7

More Information

TXGuy 87 solutions 861 answers

Chosen Solution

You have My Web Search installed; look under Tools > Add-ons > Plugins. It could have piggy-backed in on something you installed. Always look for and opt-out during installation of other programs and add-ons that you install from sites other than the Mozilla add-ons site. My Web Search is considered malware/adware/spyware by many. You should remove it.

Step 1. You can check if you have any of these from "Fun Web Products" installed: Control Panel > Add or Remove Programs: Ask.com Bar,My Search Bar,MyWay Speed Bar,My Web Search Bar,Fun Web Products Easy Installer See: http://www.safer-networking.com/removemywebsearch.php PC Hell: My Web Search Removal Instructions http://helpint.mywebsearch.com/intlinfo/help/toolhelp.jhtml#q3 http://support.mozilla.com/en-US/kb/Troubleshooting+plugins#Manually_uninstalling_a_plugin

Step 2. You may need to change a preference to reset your default URL/location bar search provider: -Enter about:config in the address/URL bar and press the Enter key -If you see a warning, accept it (Promise that you will be careful) -Filter = keyword.url -Below the Filter, right-click on keyword.URL and choose "Reset" -Restart Firefox (File > Restart Firefox) See: http://kb.mozillazine.org/Keyword.url

Step 3. You may need to reset your homepage. Firefox can open multiple home pages. Home pages are separated by the "|" symbol. See: http://support.mozilla.com/en-US/kb/How+to+set+the+home+page


Other Issues: ~~red:You have installed plug-ins with known security issues. You should update them immediately.~~

You ~~red:MAY~~ need to Update Adobe Reader for Firefox (aka Adobe PDF Plug-In For Firefox): your ver. N/A; current ver. 9.3.3 (important security update release 06-29-2010; see: http://www.adobe.com/support/security/bulletins/apsb10-15.html) ~~red:Check your version here~~: http://www.mozilla.com/en-US/plugincheck/ See: http://support.mozilla.com/en-US/kb/Using+the+Adobe+Reader+plugin+with+Firefox#Installing_and_updating_Adobe_Reader ~~blue:You may be able to update from the Adobe Reader installed on your system~~ instead of going to the Adobe site and downloading. Open the Adobe Reader installed on your system (in Windows, Start > Program Files, find and click Adobe Reader to open), click Help, click Check for Updates. Allow the download/update to occur. If you use this method, no need to proceed with the instructions below, but do look at the two bulleted items at the bottom "NOTE for IE:" and "Also see:". Restart Firefox and check your new version here: http://www.mozilla.com/en-US/plugincheck/ ~~blue:If you go to the Adobe site to download the current Adobe Reader:~~ -use Firefox to download and SAVE to your hard drive (save to Desktop for easy access) ~~red:-See the images at the bottom left of this post to see the steps to take on the Adobe site~~ -exit Firefox (File > Exit) -In Windows: check to see that Firefox is completely closed (Ctrl+Alt+Del, choose Task Manager, click Processes tab, if "firefox.exe" is on the list, right-click "firefox.exe" and choose End process, close the Task Manager window) -In Windows: double-click on the Adobe Reader installer you just downloaded to install/update Adobe Reader

Helpful Reply

Hi

follow the instructions given at Reset default search engine in firefox

prhone 0 solutions 3 answers

just google it. a kind of password recovery tool namedd Password Genius supports Windows OS.

blondon 0 solutions 2 answers

I looked all over. I had the same problem. No option to substitute Google back as my search engine. One of my options was Amazon.com. One was ebay. All very famous search engines. The answer for me turned out to be excrutiatingly simple but near impossible to find. I found the following site. http://www.google.com/homepage/search/#utm_source=en-goog-sem-na-us-dse When I checked that I wanted to make Google an option, I looked up and Google was an option. That wasted about 2 hours of my time.

blondon 0 solutions 2 answers

Helpful Reply

I looked all over. I had the same problem. No option to substitute Google back as my search engine. One of my options was Amazon.com. One was ebay. All very famous search engines. The answer for me turned out to be excruciatingly simple but near impossible to find. I found the following site. http://www.google.com/homepage/search/#utm_source=en-goog-sem-na-us-dse When I checked that I wanted to make Google an option, I looked up and Google was an option. That wasted about 2 hours of my time.

annicat 0 solutions 1 answers

It won't stay rest it keeps reverting back to fast browser searcha nd I have no idea where that is coming from!

creamerlover123 0 solutions 1 answers

Thanks, I was having a hard time getting ebay to be my home page... So i looked up "How do u make ebay ur home page?" and Blondon had exactly what I needed... Thanks Blondon!

Rajesh Magar 0 solutions 1 answers

Thanks...Problem has solved.