Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox has arbitrarily disabled IDM cc which was working fine for months, how can I reinstall it as I will cease using Firfox if I can't use IDM.

  • 54 replies
  • 2053 have this problem
  • 105 views
  • Last reply by bintang7

more options

Firefox has arbitrarily disabled IDMcc even though I have been using it multiple times a day for months with no problems. I wish to reinstall IDM and use it. If I can't I will stop using Firefox and go back to IE. I would prefer to stay with Firefox but I will not use a browser that won't let me use IDM which was working just fine.

== I reloaded Firefox I told IDM had been disabled

Chosen solution

This was a typo in our blocklisting. IDM causes Firefox 4 and up to crash, we accidentally blocklisted it for 3.6+ instead. This has already been fixed, you should be able to re-enable it via Tools > Addons now.

Read this answer in context 👍 5

All Replies (20)

more options

Update/Fix-

The block was in error, and should have only applied to beta versions of Firefox 4.0 due to the large number of crashes it caused on that version. However, a programming error resulted in the extension being blocked on all Firefox versions.

The change has already been rolled back according to Bug 578433 listed here.

https://bugzilla.mozilla.org/show_bug.cgi?id=578443

However, browsers that have already blocked the extension may not immediately register the change. All Firefox browsers connected to the internet should have unblocked the extension within 24 hours, to my understanding.

"I need a fix for this right away though!"

First, restart your browser and see if the block persists.

Then, those in desperate need of the extension may wish to attempt the following fix listed in comment 34 of the above bug.

I would urge caution if you attempt this however. I am not a Mozilla employee, and so this workaround should not be taken as official advice. If you do not completely understand the instructions in comment 34, do not attempt the fix as you risk causing further problems with your browser. Please try to be patient, and Firefox should resolve the situation itself within 24 hours, as stated.

https://bugzilla.mozilla.org/show_bug.cgi?id=578443#c34

I hope that a workaround of this nature is permitted for posting on this support forum...

more options

ok ill wait for them to fix it

more options

Tengo el derecho a decidir si usar el complement o no. Es mi ordenador asi que si quisiera ejecutar el más mortal de los virus estoy en mi derecho. Mi ordenador no les pertenece asi que vuelvan a activar la compatibilidad con el complemento, mientras tanto regreso a IE.

more options

quick fix:

go to about:config

search for extensions.blocklist.enabled and change it to false.

restart firefox.

more options

i was thinking of going back to IE cuz of this fireCrap is getting slower but i still had someful addons here...


BUT THANX for the Gentle push BY crossing the line.


UNINSTALLing MOZILLA FIREfox

Removed profanity. Please read the rules and guidelines at https://support.mozilla.com/en-US/kb/Forum+and+Chat+Rules+and+Guidelines - FF4L
more options

totally agree have tried other dwnld mangers and nothing compares never had an issue with startup suspect idm is too good for bypassing internet protocol so their blocking it oh well if they stop idm i'm getting a new browser to work with.Hope it works for firefox but it is gonna cost them alot of users!!!!!!!!!!!!

more options

at Gustavo

hey thanks.. it works!..

Firefox is the most popular and trusted browser right now and that what leads them to other competing browsers in terms of users. But hey, Firefox is not irreplaceable.

more options

Firefox is gonna loose all their users

more options

gustavo what is about:config ? i cant find it in my firefox anywhere.

more options

Gustavo where is this about:config ? i have searched my entire browser its not there.

more options

More detailed instructions on reaching about:config and disabling the extension blocklist feature are available here.

http://support.mozilla.com/en-US/kb/Firefox+makes+unrequested+connections#Extension_blocklist_updating

more options

To try Gustavo's fix: - Type about:config in the address bar - Scroll down until you find extensions.blocklist.enabled - Look across to the value column - If the value is true double click or right click and click on toggle - This will change the value to false - Restart Firefox and all the addons that Firefox has disabled will be back - If you are smart you will have made note of any other addons which Firefox has disabled before this. You can then disable them again - If you are dumb like me you will forget to do this and you will try in vain to remember which other addons had been disabled

more options

type about:config in ur address bar n hit go.. then press yes i'll be so called carefull.. good day..

thnx Gustavo Conde

Regards from Msia...

more options

Thank you Gustavo and Zale, my IDM is now back to normal wooohoooooo!!!! :D

more options

i am so frustrated with Firefox. i have been working with IDM CC for long time ago. it never caused any harm to me. why disable it?

more options

Mozilla team please resolve this matter as quickly as possible... can't imagine browsing without IDM CC plugin.

more options

i think IDM add-one doesnot support the new Firefox 3.6.7 :( So for the solution wait for the IDM next update........ :) because, i`ve checked today but there was no update available.....

more options

i think IDM add-one doesnot support the new Firefox 3.6.7 :( So for the solution wait for the IDM next update........ :) because, i`ve checked today but there was no update available.....

Another Solution :

Goto Add/Remove

Remove Firewfox 3.6.6 then download & install the old version from filehippo (3.6.6) IDMcc will work fine..... and when IDM will release its new update then update your firefox :)

more options

Here is an effective solution:

in the address bar type about:config . Click the button "I'll be careful I promise" . Find extensions.blocklist.enabled . Change it to false zith a double clic. Close out and restart firefox. IDM will be back enabled. I tried it and it succeeded.

more options

please unblock IDM CC i have used it for years with firefox and no errors and carshes at all.

  1. 1
  2. 2
  3. 3