Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I cannot get Adobe Reader to work with Firefox - i get the message "the following applications(s) could not be installed: adobe reader" when I try to download it

  • 1 reply
  • 0 have this problem
  • Last reply by Morbus

more options

I cannot download Adobe Reader when I try to do so I get the message: "the following application(s) could not be installed: adobe reader"

All Replies (1)

more options

Hello Peter.

Please contact Adobe for support on their product. That's Adobe Reader. They are the ones who develop it.