X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I prevent auto-login? I never EVER save passwords, yet FF logs me into gmail without prompting for login.

Posted

I never save passwords - never have, never will. Using evil IE, Gmail works correctly in that it prompts me for ID and password for each new browser instance. Yet when I open gmail with FF, it goes straight to my inbox without prompting for ID or password. I use gmail in "always secure" mode. Cookies are enabled, of course, just did not expect my password to be saved and loaded from a cookie. How can I rectify this problem?

This happened

Every time Firefox opened

Chosen solution

Hello Shrek.

First, let's clear things up: when you save a password in Firefox, it's stored in your computer, and isn't shared or uploaded to anywhere. It's also encrypted so only Firefox can read it (i.e. use it to auto complete passwords), and keep it away from the prying eyes of malware, viruses and whatnot. Saving your password to Firefox is completely safe and that password will only be available to someone who users your Firefox profile. If you want to have different Firefox profiles for different users, please read this article.

On the other hand, when you ask a site to "log you in automatically", it has absolutely nothing to do with Firefox's password manager. When you ask a site to always log you in, the sites stores a cookie in your browser (in this case, Firefox, and not other browsers you may have installed or Firefox in other computers - unless you have them synced with Firefox Sync) that the site will use each time you visit it to know whether your logged in or not. This cookie is exactly the same kind of technology a site uses to know if you're logged in at all. Without cookies (i.e., if you have cookies disabled), you'll need to be constantly logging in, because the site won't be able to remember that you already did log in. This renders most, if not all, sites that require you to log in completely useless.

If you don't want to be always logged in in a given site, simply don't ask it to always log you in. You may need to log out and log in again to tell him that, but that's an usability issue with the site, not with Firefox.

Read this answer in context 9

Additional System Details

Installed Plug-ins

  • -Default Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.2"
  • Shockwave Flash 10.1 r53
  • GEPlugin
  • 2.0.40115.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Update
  • Next Generation Java Plug-in 1.6.0_18 for Mozilla browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

More Information

accessibility.typeaheadfind.flashBar 0
browser.history_expire_days 3
browser.history_expire_days.mirror 3
browser.history_expire_days_min 3
browser.places.importBookmarksHTML false
browser.places.smartBookmarksVersion 2
browser.startup.homepage http://www.google.com/
browser.startup.homepage_override.mstone rv:1.9.2.3
browser.tabs.warnOnClose false
extensions.lastAppVersion 3.6.3
network.cookie.prefsMigrated true
network.http.proxy.version 1.0
network.image.imageBehavior 0
places.last_vacuum 1274813617
print.print_printer \\WCHPS45.qvcdev.qvc.net\MIS-FUFILL04
print.printer_\\WCHPS45.qvcdev.qvc.net\MIS-FUFILL04.print_bgcolor false
print.printer_\\WCHPS45.qvcdev.qvc.net\MIS-FUFILL04.print_bgimages false
print.printer_\\WCHPS45.qvcdev.qvc.net\MIS-FUFILL04.print_command
print.printer_\\WCHPS45.qvcdev.qvc.net\MIS-FUFILL04.print_downloadfonts false
print.printer_\\WCHPS45.qvcdev.qvc.net\MIS-FUFILL04.print_edge_bottom 0
print.printer_\\WCHPS45.qvcdev.qvc.net\MIS-FUFILL04.print_edge_left 0
print.printer_\\WCHPS45.qvcdev.qvc.net\MIS-FUFILL04.print_edge_right 0
print.printer_\\WCHPS45.qvcdev.qvc.net\MIS-FUFILL04.print_edge_top 0
print.printer_\\WCHPS45.qvcdev.qvc.net\MIS-FUFILL04.print_evenpages true
print.printer_\\WCHPS45.qvcdev.qvc.net\MIS-FUFILL04.print_footercenter
print.printer_\\WCHPS45.qvcdev.qvc.net\MIS-FUFILL04.print_footerleft &PT
print.printer_\\WCHPS45.qvcdev.qvc.net\MIS-FUFILL04.print_footerright &D
print.printer_\\WCHPS45.qvcdev.qvc.net\MIS-FUFILL04.print_headercenter
print.printer_\\WCHPS45.qvcdev.qvc.net\MIS-FUFILL04.print_headerleft &T
print.printer_\\WCHPS45.qvcdev.qvc.net\MIS-FUFILL04.print_headerright &U
print.printer_\\WCHPS45.qvcdev.qvc.net\MIS-FUFILL04.print_in_color true
print.printer_\\WCHPS45.qvcdev.qvc.net\MIS-FUFILL04.print_margin_bottom 0.5
print.printer_\\WCHPS45.qvcdev.qvc.net\MIS-FUFILL04.print_margin_left 0.5
print.printer_\\WCHPS45.qvcdev.qvc.net\MIS-FUFILL04.print_margin_right 0.5
print.printer_\\WCHPS45.qvcdev.qvc.net\MIS-FUFILL04.print_margin_top 0.5
print.printer_\\WCHPS45.qvcdev.qvc.net\MIS-FUFILL04.print_oddpages true
print.printer_\\WCHPS45.qvcdev.qvc.net\MIS-FUFILL04.print_orientation 0
print.printer_\\WCHPS45.qvcdev.qvc.net\MIS-FUFILL04.print_pagedelay 500
print.printer_\\WCHPS45.qvcdev.qvc.net\MIS-FUFILL04.print_paper_data 1
print.printer_\\WCHPS45.qvcdev.qvc.net\MIS-FUFILL04.print_paper_height 11.00
print.printer_\\WCHPS45.qvcdev.qvc.net\MIS-FUFILL04.print_paper_size_type 0
print.printer_\\WCHPS45.qvcdev.qvc.net\MIS-FUFILL04.print_paper_size_unit 0
print.printer_\\WCHPS45.qvcdev.qvc.net\MIS-FUFILL04.print_paper_width 8.50
print.printer_\\WCHPS45.qvcdev.qvc.net\MIS-FUFILL04.print_reversed false
print.printer_\\WCHPS45.qvcdev.qvc.net\MIS-FUFILL04.print_scaling 1.00
print.printer_\\WCHPS45.qvcdev.qvc.net\MIS-FUFILL04.print_shrink_to_fit true
print.printer_\\WCHPS45.qvcdev.qvc.net\MIS-FUFILL04.print_to_file false
print.printer_\\WCHPS45.qvcdev.qvc.net\MIS-FUFILL04.print_unwriteable_margin_bottom 0
print.printer_\\WCHPS45.qvcdev.qvc.net\MIS-FUFILL04.print_unwriteable_margin_left 0
print.printer_\\WCHPS45.qvcdev.qvc.net\MIS-FUFILL04.print_unwriteable_margin_right 0
print.printer_\\WCHPS45.qvcdev.qvc.net\MIS-FUFILL04.print_unwriteable_margin_top 0
privacy.sanitize.migrateFx3Prefs true
security.disable_button.openCertManager false
security.disable_button.openDeviceManager false
security.enable_tls false
security.warn_viewing_mixed false

Morbus 134 solutions 2338 answers

Chosen Solution

Hello Shrek.

First, let's clear things up: when you save a password in Firefox, it's stored in your computer, and isn't shared or uploaded to anywhere. It's also encrypted so only Firefox can read it (i.e. use it to auto complete passwords), and keep it away from the prying eyes of malware, viruses and whatnot. Saving your password to Firefox is completely safe and that password will only be available to someone who users your Firefox profile. If you want to have different Firefox profiles for different users, please read this article.

On the other hand, when you ask a site to "log you in automatically", it has absolutely nothing to do with Firefox's password manager. When you ask a site to always log you in, the sites stores a cookie in your browser (in this case, Firefox, and not other browsers you may have installed or Firefox in other computers - unless you have them synced with Firefox Sync) that the site will use each time you visit it to know whether your logged in or not. This cookie is exactly the same kind of technology a site uses to know if you're logged in at all. Without cookies (i.e., if you have cookies disabled), you'll need to be constantly logging in, because the site won't be able to remember that you already did log in. This renders most, if not all, sites that require you to log in completely useless.

If you don't want to be always logged in in a given site, simply don't ask it to always log you in. You may need to log out and log in again to tell him that, but that's an usability issue with the site, not with Firefox.

prhone 0 solutions 3 answers

just google it. a lot of password recovery tool support Windows OS. http://password-genius.com

kurlikew 0 solutions 1 answers

Helpful Reply

I have this issue too. I have never asked to be "always signed in" with gmail, yet sometimes it will sign me in automatically when I open my Firefox browser. I try clearing everything I can clear ( even though I've said NOT to save my password or sign in automatically), but it still happens. It's not even consistent - sometimes it will happen and sometimes not. This is very frustrating. I share my computer and I do not want automatic sign in anytime! >:o(

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96793 answers

Helpful Reply

The Gmail login page has a check box to remember you.

Websites remembering you and automatically log you in is stored in a cookie.

Clearing the cookies from those websites should log you out and prevent further automatic login.

Tools > Options > Privacy > Cookies: "Show Cookies"


A way to see which cookies a website has stored is to click the favicon (Site Identification icon) on the left end of the location bar.

  • Click the "More Information" button to go to the Security tab in the "Tools > Page Info" window.
  • Click the "View Cookies" button to open the Cookie Manager and see which cookies that domain has stored.

Modified by cor-el

welch6980 0 solutions 1 answers

Hello Morbus,

I have just the opposite problem. I want to automatically taken into Gmail when I turn on my PC and click Gmail. I don't want to have to sign in. Right or wrong, I want to make my wife happy. So, how do I do this?

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96793 answers
  • Websites remembering you and automatically log you in is stored in a cookie.
  • You need an allow cookie exception (Tools > Options > Privacy > Cookies: Exceptions) to keep that cookie, especially for secure websites and if you let cookies expire when Firefox closes
  • Make sure that you do not use Remove recent browsing, search and download history to clear the "Cookies" and the "Site Preferences"

See also http://kb.mozillazine.org/Cookies

daddyray 0 solutions 3 answers

I have a different problem. I have a facebook account. so does my wife and two sons. Every time I go to facebook it will log me in automatically. When my wife or sons go to facebook it will log them onto my account automatically. They log out of my account and before they can log into their account it has logged back into my account again. This goes on until they can type fast enough to beat the auto login for my account, which is about 4 seconds. This is annoying. How can I correct this problem?

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96793 answers

Did you try to clear the Facebook cookies?
See also http://kb.mozillazine.org/Websites_report_cookies_are_disabled (Other Solutions)

You should create separate Firefox profiles for each of you to prevent such problems.

Create a new profile for each of you and create a desktop shortcut with -P "profile" appended to the target to launch each profile.

daddyray 0 solutions 3 answers

Unable to create multiple profiles, firefox keeps crashing when I run "firefox -P". (image below) using firefox 3.6.13 Windows 7, 64 bit

daddyray 0 solutions 3 answers

Got it. Had to uninstall and reinstall Firefox. Set up the profiles with no problem. Used FEBE to install all of my goodies.

DonMizzi 0 solutions 1 answers

hallo, i have the same problem and i have found a possible cause.

it happens with firefox 5 in Windows 7 and Mac Os 10.6.7 NOT happens with Chrome, Safari and IE9

it happens when the option "show tab and windows of the last session" (i'm italian i don't know the right text) is set in start page.

i have done various test (always closing firefox with gmail logged in):

- if i set start page blank (or empty) when i run firefox then i go in gmail.com i have to insert password

- if i set start page gmail.com when i run firefox i have to insert password

- if i set start page blank when i run firefox then i choose history -> open last session i have to insert password

- if i set start page "open last tab and windows" and i delete cookies before exit firefox when i run firefox i have to insert password

- if i set start page "open last tab and windows" and simply re-run firefox happens auto login!!!

do you confirm???

thanks Domenico

cncb 0 solutions 1 answers

Domenico,

I see the same thing and this must be incorrect and insecure behavior? Worse, if I close the GMail tab before I close Firefox and restart Firefox (set to open the previous tabs), I can open a new, blank tab and navigate to GMail and it still logs me in automatically! I hope this serious security issue can be fixed.

mango 0 solutions 2 answers

Okay. I still have no clue after reading the above. I want to erase the auto fill in of the log in name on several websites, like my Netflix account. It's filling in not only my log in name but also my password on the log-in user line (not the password box). I mad a mistake and I typed too fast and entered both login name and password all on the same line and now it just pops all the time. I want to remove this. Is this a firefox issue or do I have to go to each specific website to fix this. I removed all the cookies and it's still doing it. HELP!

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96793 answers

If you need to remove saved data then use these steps:

  1. Click the (empty) input field on the web page to open the drop down list
  2. Highlight an entry in the drop down list
  3. Press the Delete key (on Mac: Shift+Delete) to remove it.
  • Tools > Options > Security: Passwords: "Saved Passwords" > "Show Passwords"

RareFrog 0 solutions 1 answers

Thank you Cor-el! Easy answer and easy fix...so glad I now know how to do this cuz I had the exact same problem as mango...Again Thanks! Oh and I am on a Mac and I'm a PC user so I definitely had no idea how to do this...lol

Modified by RareFrog