Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why is Firefox suddenly always asking me if I want to translate my pages?

  • 6 replies
  • 85 have this problem
  • 2748 views
  • Last reply by lost.time

more options

For the past week or so Firefox has suddenly started asking me if I want to translate my pages from English. Even if I say NEVER translate english pages it continues to ask. This is happening on both my work PC and home PC. All the pages I read are in English and this has only recently started to happen (around beginning of July 2010). Not all pages just some.

URL of affected sites

http://

Chosen solution

I don't have the GTB installed, but after i updated firefox to 3.6.6 this annoying toolbar pops up asking me if i want to translate the page. I tried clicking disable for english, but it still pops up. Looking for a solution on the GTB site does not work since I have never had this piece of software installed. Disabling plugins will not work either because of the same reason.

Read this answer in context 👍 0

All Replies (6)

more options

Firefox doesn't have a translation feature. That is a feature added to Firefox by the Google Toolbar extension. If you can't figure out how to disable that in the GTB options, seek help from here. http://www.google.com/support/toolbar/?hl=en

Or visit the Google Toolbar forum. http://www.google.com/support/forum/p/Toolbar?hl=en

more options

I have followed the drop down to disable. Does not work

more options

If you can't figure out how to disable that in the GTB options, seek help from here. http://www.google.com/support/toolbar/?hl=en

more options

Chosen Solution

I don't have the GTB installed, but after i updated firefox to 3.6.6 this annoying toolbar pops up asking me if i want to translate the page. I tried clicking disable for english, but it still pops up. Looking for a solution on the GTB site does not work since I have never had this piece of software installed. Disabling plugins will not work either because of the same reason.

more options

I experienced this problem on Firefox 3.1.6 and Windows IE 8 on both Vista and XP. I took the advice I found on the Google Toolbar forum and updated all of my add-ons and plug-ins. I have the automatic update option on, but I had a couple of plug-ins that required updates- namely. Quicktime and Acrobat. After downloading and installing these updates then restarting Firefox, the problem went away. I real bother, but it worked in my case. THE SECOND POST - March 6 The problem came back with the automatic upgrade to Firefox 3.6.15. I think this all a conspiracy by Google to get you try Chrome. I am going back to IE.

Modified by efells

more options

I found that firefox had nothing to do with that. The problem was on a webpage that I was visiting. This is what I found on that webpage:

<script> function googleTranslateElementInit() {

new google.translate.TranslateElement({
  pageLanguage: "ro"
}, "google_translate_element");

} </script> <script src="//translate.google.com/translate_a/element.js?cb=googleTranslateElementInit"> </script> ---