Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I can't get firefox (Linux) to use flashplayer. I've installed a dozen times but it doesn't show up in tools/add-ons.

  • 11 replies
  • 107 have this problem
  • Last reply by vallee

more options

I've tried installing flash player a dozen times, with both the instructions on the adobe page and the mozilla page. I'm running Fedora Core 11 with Mozilla 3.5.9. I've gotten "" and copied it to every "mozilla/plugins" directory on the drive. It does not work and is not listed when I bring up "tools/add-ons." One instruction said to copy "flashplayer.xpt" to the "mozilla/commponents" directory, but the download included no such file and I have no such directory. (Probably pertains to an older version.) I've tried downloading it with the .tar, .gzip, and yum; all with the same result. It doesn't work online and doesn't show up in my plug-ins.

This happened

Every time Firefox opened

== Only time I've tried to install it.

All Replies (11)

more options

flash-plugin installed with yum as instructed by adobe website is in /usr/lib/flash-player

/usr/lib/mozilla/plugins contains a link to /usr/lib/flash-player/

about:plugins says NPAPI Plugins Wrapper 1.3.0

   nspluginwrapper is a cross-platform NPAPI plugin viewer, in particular for linux/i386 plugins.

uname says #1 SMP Tue Jul 6 22:32:17 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux

firefox --version

Mozilla Firefox 3.6.4, Copyright (c) 1998 - 2010

more options

I still have the problem, but I must have clicked on the wrong link to get here.

Okay, I'm good on the first part, except my directory is named "flash-plugin," not "flash-player," and under "tools/add-ons" I see that "NPAPI Plugins wrapper" is installed, but I don't know what to do with it.

That's as far as I'm getting. I remember one set of installation instructions (the one on the firefox site, I think) said that I should execute:

"nspluginwrapper -i"

That's from memory--I don't have it in front of me now. There's no such executable in my path, and "find" only came up with a directory named "nspluginwrapper."

more options

I've tried the "new" 32-bit plugin by adobe as well as tried using the "older" and no longer supported "64-bit plugin that adobe had released. I've tried using both nspluginwrapper as well as without and in both instances the browser hangs:

firefox 3.5.4 rhel 5.5

more options

You can place a symlink to the Flash plugin (/usr/lib/flash-plugin/ in a directory that Firefox scans for plugins (e.g. plugins directory of the Firefox installation directory). ln -s /usr/lib/flash-plugin/

If you set the pref plugin.expose_full_path to true on the about:config page then you see the full path of plugins on the about:plugins page. It is best not to leave that pref set to true as it exposes that full path to web servers, so reset that pref to false after you are done with the about:plugins page. You can access about: pages via the location bar, just like you open a website (about: is a protocol like http: and used for internal purposes).

more options

For cor-el:

Thanks for the reply, but that already is the situation on my system.

There *is* a symbolic link from the mozilla directory to the /usr/lib/flash-player/

Apparently that link is put there by the install process of the rpm downloaded from adobe. The "setup" script that comes with the rpm installs the link.

more options

Here's a clue: I just installed it on another, similar, computer and it works fine "out-of-the_box." (except for the *sound.)

This one works: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20100216 Fedora/3.5.8-1.fc11 Firefox/3.5.8

This one doesn't: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20100330 Fedora/3.5.9-1.fc11 Firefox/3.5.9

I did a diff on the plugin and they're identical, so, the problem must be either with the kernel or the Firefox version.

  • I've found the sound drivers to be an issue in FC11.
more options

Do you see the Flash plugin in Tools > Add-ons > Plugins and on the about:plugins page?

more options

No, it doesn't.

On the machine that works it shows up as "Shockwave Flash."

more options

On my machine, about:plugins only shows the NAPI wrapper plugin.

Even though the is linked to properly, firefox does not see it.

more options

I have that one, too, and several others. Out of curiosity, do a "help/about Mozilla Firefox" and see what issues you're running. I've got mine posted above.

At the moment I'm downloading Fedora 13. That will probably fix it. (But experience says it will probably break something else.)

more options

I had a problem with Fedora 15-64bit + Firefox 64bit + flash player plugins. I finally found that the plugins must be put in: /usr/lib64/mozilla/plugins. I downloaded the 64-bit version of the flash plugins at  : Decompressed it and move the file to /usr/lib64/mozilla/plugins (you need to be super user to do that). Restarted Firefox and it worked ! My guess is that if you use 32-bit plugins then you must put them in /usr/lib64/mozilla/plugins-wrapped but I didn't try. Arg ! It took me the whole evening to find that !