X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Windows cannot find 'C:\Program files\Mozilla Firefox\Firefox.exe'

Posted

Windows cannot find 'C:\Program files\Mozilla Firefox\Firefox.exe'

This happened

Every time Firefox opened

User Agent

Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)

Additional System Details

Application

  • User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)

More Information

Morbus 134 solutions 2338 answers

Hello Ben.

Have you manually checked if that file exists?

This may be a problem with Windows, but not with Firefox.

If that file doesn't exist, though, you may need to reinstall Firefox (no data will be lost). You can get it (for free, as always) at http://getfirefox.com/

Question owner

I found this post through google.

Since yesterday one of my clients machines (Windows XP SP3, FF 3.6.6) has been doing the same thing, the exe exists and the error even occurs if you manually run firefox.exe rather than a shortcut.

A re-install did nothing. It's as if something is stopping firefox.exe from executing, resulting in a not found error by the OS.

Question owner

I have been having the exact same problem and it is becoming ridiculous; even clicking directly on the application within the Program Files folder will not open it.

Question owner

I have had this problem since yesterday.

I tried scanning using my normal anti-virus software and no joy.

Downloaded and installed Malwarebytes and it found altered reg keys that were preventing firefox, chrome and safari running.

Once the scan was run and the threats removed firefox started no problem.

Hope this helps?

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

Do a malware check with a few malware scan programs. You need to use all programs because each detects different malware. Make sure that you update each program to get the latest version of the database.

http://www.malwarebytes.org/mbam.php - Malwarebytes' Anti-Malware http://www.superantispyware.com/ - SuperAntispyware http://www.safer-networking.org/en/index.html - Spybot Search & Destroy http://www.lavasoft.com/products/ad_aware_free.php - Ad-Aware Free http://www.microsoft.com/windows/products/winfamily/defender/default.mspx - Windows Defender: Home Page .......... See also "Spyware on Windows": http://kb.mozillazine.org/Popups_not_blocked and What to do when searches take you to the wrong search website --- Do a clean reinstall and download a fresh Firefox copy from http://www.mozilla.com/firefox/all.html and save the file to the desktop. Uninstall your current Firefox version and remove the Firefox program folder before installing that copy of the Firefox installer. It is important to delete the Firefox program folder to remove all the files and make sure that there are no problems with files that were leftover after uninstalling.

You can skip the step to create a new profile, that is not necessary for this issue.

You can also try a custom install in a different directory.

Question owner

I had the same problem but Malwarebytes' Anti-Malware couldnt find it.

Search the registry for zasrakomondohui - you should find a few apps which use something like the above as a debugger.

Remove those keys and should be ok

Question owner

i have the exact same problem, and even if i manually try to open firefox (from the program files) i still get the same error message, i uninstalled it and reinstalled it and its still the same. please help!

Question owner

I had this problem until this morning, this is how I fixed it (using xp, don't know how different this is for newer OSs):

Start > Run > regedit.exe

Expand: My Computer > HKEY_LOCAL_MACHINE > SOFTWARE > Microsoft > Windows NT > CurrentVersion > Image File Execution Options > firefox.exe

Then deleted the entry that resembled 'zasrakomondohui' as mentioned above. Hope that helps!

Question owner

Thanks sam. I had the same problem this morning.

Deleting the 'zasrakomondohui' entry from the registry worked.

Thanks again.

Question owner

Thanks Sam, same problem here, your info worked :)

Helloello 0 solutions 1 answers

Helpful Reply

Hello i got the same problem and i checked the regedit and did the steps that u posted here and on the firefox.exe folder i only found 2 items (default and debugger) so i didnt find "zasrakomondohui" word. Please help me with this matter. I cant download those malwarebytes or any antivirus coz i cant open all my browsers i think all of them are infected thay im getting the same message.

jiantjay 0 solutions 2 answers

I'm having the same results as helloello

jiantjay 0 solutions 2 answers

I tried what cor-el mention again. It worked. Thank you :)

nab321 0 solutions 1 answers

Helpful Reply

When you look in registry in this location - My Computer > HKEY_LOCAL_MACHINE > SOFTWARE > Microsoft > Windows NT > CurrentVersion > Image File Execution Options > firefox.exe

for debugger, you may see something like this - iexploresafemode -sb

It will also do the same thing in your iexplore.exe. It will also write one for chrome.exe as well. I have seen this even though chrome is not installed on the machine. This is caused by a hacked website that "dupes" you into installing something posing as antivirus saying that it detected a threat. In the case of my fathers machine, it was posing as AVG 2011 and they try to get you to buy the full copy to remove it with a credit card.

Delete the key debugger iexploresafemode -sb under iexplore.exe and under firefox.exe in that location and all should be fixed.

rigo 0 solutions 1 answers

YES!! deleting the key worked for me too, both for Firefox and Iexplorer--thanks for posting, this one was a hard one to crack, thought of formating laptop 2 or 3 times but kept at it.

TKZ, Rigo

macartur66 0 solutions 1 answers

YES!! Deleting the key debugger msi****** worked for me too, both for Firefox and Iexplorer. Just leave the "(Default)" key Thank you so much for posting

jonah.elliott@hotmail.com 0 solutions 1 answers

"C:\Program Files\Mozilla Firefox\firefox.exe" -safe-mode isnt working because your computer or your IP address is being brought through another country. it's very simple search this instead. try these.

                                                                Fire Fox

/watch?v= part with /v so your new URL becomes http://www.youtube.com/v/yEwD36Dk1jw


"C:\Program Files\Mozilla Firefox\firefox.exe" -safe-mode

"C:\Program Files (x86)\Mozilla Firefox\firefox.exe" -safe-mode


                                                   Thunderbird

"C:\Program Files\Mozilla Thunderbird\thunderbird.exe" -safe-mode

"C:\Program Files (x86)\Mozilla Thunderbird\thunderbird.exe" -safe-mode

                                                Sea Monkey
       

"C:\Program Files\SeaMonkey\seamonkey.exe" -safe-mode

"C:\Program Files (x86)\SeaMonkey\seamonkey.exe" -safe-mode

hommedespoir 0 solutions 11 answers

You say "no data will be lost" but that's on your PC.

We lesser mortals ALWAYS lose bookmarks and history every damn time we update FF