X
Tap here to go to the mobile version of the site.

Support Forum

Firefox command line option "-no-remote" doesn't work with profile.

Posted

I want to run the stripped version of firefox in background with one application and another full version of firefox for normal browsing. I have created the profile for the stripped version of firefox and loading the same using command firefox -P "stripped" -no-remote/firefox -no-remote -P "stripped". But when I start the full version of firefox by launcher "firefox" than it directly loads the stripped version even used the -no-remote option with profile. So I have created launcher for firefox and used the -no-remote with default profile like "firefox -no-remote". It works when first time I click on launcher but for second click it shows the message "Firefox instance is running, or not responding. close the firefox and restart the system". I have gone through the online available documents that suggests that use the -no-remote option with profile so the default profiles works correctly. But -no-remote option doesn't work with the profile. So is there any way to launch the full version of firefox by launcher on second click on launcher?

I want to run the stripped version of firefox in background with one application and another full version of firefox for normal browsing. I have created the profile for the stripped version of firefox and loading the same using command firefox -P "stripped" -no-remote/firefox -no-remote -P "stripped". But when I start the full version of firefox by launcher "firefox" than it directly loads the stripped version even used the -no-remote option with profile. So I have created launcher for firefox and used the -no-remote with default profile like "firefox -no-remote". It works when first time I click on launcher but for second click it shows the message "Firefox instance is running, or not responding. close the firefox and restart the system". I have gone through the online available documents that suggests that use the -no-remote option with profile so the default profiles works correctly. But -no-remote option doesn't work with the profile. So is there any way to launch the full version of firefox by launcher on second click on launcher?

Additional System Details

Installed Plug-ins

  • -Shockwave Flash 10.0 r45
  • The Totem 2.28.2 plugin handles video and audio streams.
  • DivX Web Player version 1.4.0.233

Application

  • User Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.9) Gecko/20100401 Ubuntu/9.10 (karmic) Firefox/3.5.9

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17469 solutions 157871 answers

You can't launch two instances of Firefox that use the same profile folder. If you want to run them at the same time then each instance need a separate profile.

See http://kb.mozillazine.org/Opening_a_new_instance_of_Firefox_with_another_profile

You can't launch two instances of Firefox that use the same profile folder. If you want to run them at the same time then each instance need a separate profile. See http://kb.mozillazine.org/Opening_a_new_instance_of_Firefox_with_another_profile

Question owner

Yes, I used separate profiles only. But the -no-remote option doesn't work as mentioned http://kb.mozillazine.org/Opening_a_new_instance_of_Firefox_with_another_profile.

Please find below the command what I am using

firefox -P "stripped" -no-remote firefox

If I use the above command than the new firefox window get the configuration from the stripped even if I have used the -no-remote.

I use the -no-remote with firefox default than it works for the first time. I have created the launcher for firefox default. So if I click second time on launcher than it doesn't work.


firefox -P "stripped" firefox -no-remote (But doc on link -> http://kb.mozillazine.org/Opening_a_new_instance_of_Firefox_with_another_profile) says do not use the -no-remote with default.

Do you have any idea why this is happening?

Yes, I used separate profiles only. But the -no-remote option doesn't work as mentioned http://kb.mozillazine.org/Opening_a_new_instance_of_Firefox_with_another_profile. Please find below the command what I am using firefox -P "stripped" -no-remote firefox If I use the above command than the new firefox window get the configuration from the stripped even if I have used the -no-remote. I use the -no-remote with firefox default than it works for the first time. I have created the launcher for firefox default. So if I click second time on launcher than it doesn't work. firefox -P "stripped" firefox -no-remote (But doc on link -> http://kb.mozillazine.org/Opening_a_new_instance_of_Firefox_with_another_profile) says do not use the -no-remote with default. Do you have any idea why this is happening?
cor-el
  • Top 10 Contributor
  • Moderator
17469 solutions 157871 answers

If you do not specify a profile then Firefox will use the profile that is marked as Default=1 in the file profiles.ini If that is that same "stripped" profile then you will have a problem. What is meant with the default profile is what is selected in profiles.ini as default and also which profile is started without the -no-remote switch. Both need to be the same and the profile that you use for the -no-remote instance should not be set as the default in profiles.ini

If you do not specify a profile then Firefox will use the profile that is marked as Default=1 in the file profiles.ini If that is that same "stripped" profile then you will have a problem. What is meant with the default profile is what is selected in profiles.ini as default and also which profile is started without the -no-remote switch. Both need to be the same and the profile that you use for the -no-remote instance should not be set as the default in profiles.ini
kb02gt 0 solutions 3 answers
Moved to: https://support.mozilla.com/en-US/questions/796743#answer-202994

Modified by kb02gt