Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox adds .JPEG extension onto JPG's. Example - "book.jpg.jpeg" when saving jpg files

  • 4 replies
  • 14 have this problem
  • 362 views
  • Last reply by cor-el

more options

I'm using: Windows XP Professional Service Pack 3. duel core Intel Processor 2.6 mHz 4 gig's RAM 500 G HD.

Earlier in June, my PC crashed; random glitch. Ever since, I've noticed that Mozilla is no longer able to save a JPG file without adding an additional .JPEG file extension or suffix onto the file name.

Example: book.jpg

saves as....

book.jpg.jpeg

When you go right click: save file - it sees the "save type as" JPEG Image. You can't pick to save as JPEG (*.jpg) and there's also no content type anymore for JPG or JPEG listed inside Firefox's applications.

Is the solution to uninstall and re-install Firefox?

When I save a jpg, I always have to delete the added extension/suffix OFF the file's name. It's very annoying and I never had to do that.

Thanks

All Replies (4)

more options

Do you have that problem when running in the Firefox SafeMode? http://support.mozilla.com/en-US/kb/Safe+Mode Don't select anything right now, just use "Continue in SafeMode."

If not, see this: http://support.mozilla.com/en-US/kb/troubleshooting+extensions+and+theme...

more options

I have exactly the same problem and it is not irritating. . . it’s infuriating.

I have WinXP Pro 2002 SP 3 running on a 1.8 GHz dual-core Pentium, 1GB RAM, 240 GB HDD space. I also have WinXP HE SP3 in a different partition. (where this problem doen’t occur.)

FF worked fine for a few days after re-installing windows, then began this “feature.”

I have disabled all plug-ins. I have UNINSTALLED all extensions. Default is the only theme installed.

I have even removed DivX and Real Player 10, as these were the last software I loaded after my disk crash.

AND I have uninstalled FF, then reinstalled it, importing my old (working) profile (prob. didn’t go away). Then I cleanly reinstalled (after uninstalling ALL extensions, disabling all plug-ins). And FFFF versions 3.6.2, 3.6.4 and 3.6.6 all exhibit the same behavior: filename.jpg.jpeg.

AND it happens in SeaMonkey 1.1.7, which I just installed to test!

But it DOESN’T HAPPEN in Win XP HE or Opera. When I run the old 3.6.2 from this partition, I get the problem, wo the problem must exist somewhere n my current system. But where?

I’ve also run Aargente Regestry Cleaner several times (after each SW reload) and CCleaner to remove unwanted files.

My anti-virus AVG is up to date. I ran a full system scan just this morning with no problems detected.

I tried not renaming, but actually deleting the npxxxxx.dll files in the FF plug-ins directory and other application directories. Still, the plug-ins show up as being installed... The business about renaming the dlls in your help file is bunk On next run, FF showed the RENAMED dll as the plugin!

I’m running out of ideas, fellas.

Is the only recourse to run a global file-rename application periodically?

more options

I had the same darn problem, and all the advice I got led me nowhere.

I got tired or renaming files (filename.jpg.jpeg --> filename.jpg) on my hdd, even though I had written some dos batch files to accomplish it.

I tried this today, and it worked: (!)

1.) point Firefox to about:config

2) find the entry for dwhelper.medialink-extensions

3.) double-click the entry, then edit (remove) “|jpeg” from the list. Remove one of the “|” also, so you don’ t end up with “||” in the list.

---

I also deleted “jpeg” from the list of registered file extensions, but I’m not sure that had anything to do with the problem or its solution. (In Win Explorer, with a directory open, click tools > Folder Options, then select the File Types tag. Scroll down to .JPEG and delete it. —Or, from a command prompt, enter “assoc .jpeg=” without the quotes.)

Anyway, after deleting jpeg from the list of registered file extensions, and after editing the line in the about:config file, FF no longer appends .jpeg to .jpg files when right-clicking an image, and selecting save as...

Why this fix should work is a mystery to me. I mean, I uninstalled dwhelper and the problem persisted. (Or when dwhelper is uninstalled, does it leave the dwhelper.medialink-extensions entry in about:config? –who knows?)

Anyway, good luck!

more options