X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox stopped working this morning: Windows Vista & Windows 7.

Posted

The exact scenario of the problem seems to depend on the web page being opened and maybe the OS. On Windows 7, it's in a Firefox default config with no add-ons and is trying to load my home page, which is just a collection of URLs. I wrote it myself, and it's strictly classic HTML -- no Java or anything else. There, I get the web page "(untitled)" when it tries to load the home page, and then the same behavior when I try to load anything else.

On Vista, my home page is my email provider's page and I'm running Noscript with everything on the home page enabled. However, it looks similar to the way a page looks when Java is only partially enabled by Noscript. It's not the way this particular page looks when Java is not enabled, so that's not the problem. The actual error from the log for this page is below. Here, I can partially load a lot of pages, generating different errors depending on which page I try to load.

Both these machines run Secunia and it reported everything up to date when I scanned it yesterday. I'm running Mozilla 3.6.6 both places and neither ID has administrator privileges -- I'm afraid to try Firefox on my administrator ID.

I think this started after Norton Internet Security had me reboot because of an unidentified security problem, but Firefox is the only thing that appears to be impacted. I've had to switch to Internet Explorer to write this, or to get anything else done.

This happened

Every time Firefox opened

== After Norton Internet Security had me reboot because of Security Problem

Chosen solution

After working a bit on an XP machine, I discovered that uninstall/ reinstall cleared the problem on all machines. I guess something must have been corrupted.

Read this answer in context 0

Additional System Details

Installed Plug-ins

2007 Microsoft Office Plugin Adobe Acrobat 9.3.2.163 Java Deployment Toolkit 6.0.200.2 (Disabled) Java Deployment Platform SE6 U20 6.0.200.2 Microsoft Media Player Plugin 1.0.0.8 Mozilla Default 1.0.0.15 NPCIG.dll 1.0.0.5 RealJukeBox NS 1.0.3.709 RealPlayer G2 LiveConnect-Enabled (32 bit) 6.0.12.709 Shockwave Flash 10.1.53.64 Silverlight 4.0.50524.0 Windows Presentation Foundation 3.5.30729.0



Application

  • User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.5.30729; .NET CLR 3.0.30729; .NET4.0C)

More Information

From Vista machine on loading home page: Error: uncaught exception: [Exception... "Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]" nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)" location: "JS frame :: file:///C:/Program%20Files/Mozilla%20Firefox/components/nsUrlClassifierListManager.js :: PROT_ListManager :: line 79" data: no]
Can't copy & paste from Windows 7 because I'm not on that machine.

Question owner

Hello Carol, I just did a restart because of a Norton update and now have the same problem.

I'll do some poking and see if I can't find anything else.

Chosen Solution

After working a bit on an XP machine, I discovered that uninstall/ reinstall cleared the problem on all machines. I guess something must have been corrupted.

Firefoxnotworking_2011_Me 0 solutions 1 answers

This problem started for me immediately upon installing AVG Internet Security

I have even restored to a date Before installing AVG Internet security, Uninstalled Firefox AND AVG, and I am getting all updates to Firefox and continue to have this problem. Every web page is effected and browsing will hang wihtin minutes, regardless of website visited or simplicity of the webpage I am attempting to load. Web traffic apparently hangs even when directing Firefox to search for an update.. I had to use my 2nd PC just to login HERE to write this. Windows 7 Ultimate is installed on the pc in question. No Proxy.. system is completely up to date and is a registered install of Windows 7 Ultimate. Please advise of a solution

bduerr1 0 solutions 2 answers

This has also happened to me. Norton is reporting that it removed WS.Reputation.1 from xul.dll. It then asked to restart the computer and now Firefox does not work.

bduerr1 0 solutions 2 answers

Reinstalled Firefox and it worked

SuburbanHomeboy 0 solutions 1 answers

I had the same problem yesterday - a new update for Firefox arrived, and Norton put a bunch of dll files into quarantine - including some with "moz" in the file name. I restarted my computer as Norton instructed - and Firefox stopped working. I uninstalled it and then downloaded FF 4 - it worked, but today Norton did an idle-time scan and re-quarantined the same set of dll files. I have yet to restart my computer, but I know that once I do, FireFox will not be working. I don't want to have to uninstall and reinstall FireFox every time I use Norton to do a virus scan - any solutions out there?

Modified by SuburbanHomeboy