X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

XP 64 users what version of firefox works best for you

Posted

xp64 is not supported and never has been, outside of that some versions of firefox work quite well with this OS, looking to find which version has proved to be most successful with minimal operational problems.

Additional System Details

Installed Plug-ins

  • -Default Plug-in
  • Shockwave Flash 10.0 r32
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • 4.0.50524.0
  • Virtual Earth 3D 4.00090316005 plugin for Mozilla
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Next Generation Java Plug-in 1.6.0_17 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.1.10) Gecko/20100504 Firefox/3.5.10 ( .NET CLR 3.5.30729)

More Information

AnonymousUser 406 solutions 14878 answers

Helpful Reply

Firefox is not compatible with XP-64. Use Opera, you should be fine. I don't think Opera runs as 64-but native though, but at least it works.

AnonymousUser 406 solutions 14878 answers

Firefox will not run at all on a clean, fresh XP 64 install. I didn't expect native 64-bit operation, but at least that it would run. Tried 3.6.8 and 3.5.11

Rachelsdad 0 solutions 1 answers

I just downloaded and unzipped Firefox 4.0 b8 pre on xp64 SP2. I unzipped it to \Program Files\Mozilla Firefox (the 32-bit version lives in \Program Files (x86)\Mozilla Firefox). I am posting this from 4.0 b8 pre.

It automatically imported my 3.6.12 profile, and checked for incompatible extensions; there were a few. I had previously downloaded and installed Java 6.0.22 64-bit, and this was listed in the plugins page.

So far, it seems to work just fine.

Cheers.

okay_awright 0 solutions 1 answers

Sorry for reviving such an old thread but since I've recently built those installers for myself I can share them with anyone still supporting this OS as well:

-Firefox 6 for XP x64 and 2003 x64

-Thunderbird 6 for XP x64 and 2003 x64

http://host.ddcr.biz/okay_awright/Mozilla

Modified by okay_awright