X
Tap here to go to the mobile version of the site.

Support Forum

plugin container is eating 90 percent of cpu

Posted

plugin-container is eating 90 percent of cpu when we usually look videos in youtube. Earlier this was not happening. It started in last two days. Kindly request you to solve this problem

This happened

Not sure how often

== running flash movies

plugin-container is eating 90 percent of cpu when we usually look videos in youtube. Earlier this was not happening. It started in last two days. Kindly request you to solve this problem == This happened == Not sure how often == running flash movies

Additional System Details

Installed Plug-ins

  • -np-mswmp
  • Adobe PDF Plug-In For Firefox and Netscape
  • Default Plug-in
  • Shockwave Flash 10.1 r53

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.4) Gecko/20100611 Firefox/3.6.4

More Information

Question owner

Same with firefox 3.6.6 under ubuntu 10.4. It does it with every flash content.

Same with firefox 3.6.6 under ubuntu 10.4. It does it with every flash content.

Question owner

Have same problem on ubuntu 10.04 and firefox 3.6.6 to solve it - try to renice priority of process plugin-containe, but its unnormal...

Have same problem on ubuntu 10.04 and firefox 3.6.6 to solve it - try to renice priority of process plugin-containe, but its unnormal...

Question owner

Same problem, Firefox 3.6.6, Windows XP. Just started since the latest Firefox update. After the update I got a screen asking me to update to the latest Flash player. When I followed the link the update didn't work despite following the Firefox specific instructions.

Interestingly I don't get the problem when viewing Flash video such as Youtube but PC grinds to a halt when there is other Flash content (like ads) on the page.

Same problem, Firefox 3.6.6, Windows XP. Just started since the latest Firefox update. After the update I got a screen asking me to update to the latest Flash player. When I followed the link the update didn't work despite following the Firefox specific instructions. Interestingly I don't get the problem when viewing Flash video such as Youtube but PC grinds to a halt when there is other Flash content (like ads) on the page.

Question owner

Same issue Ubuntu 10.04 while youtubing

Same issue Ubuntu 10.04 while youtubing

Question owner

Same problem is happening to me CONSTANTLY while viewing shows on netflix streaming. So much so that I can't make it through a 40 minute show without it crashing twice, with plugin-container.exe taking up the same amount of memory as firefox and will randomly ratchet up to a high enough CPU eating level that it'll freeze my computer for a good several minutes or longer until I can finally force kill it.

I've heard suggestions on other forums to just uninstall and install a earlier version of firefox, which I'm about to do. This is certainly annoying.

Same problem is happening to me CONSTANTLY while viewing shows on netflix streaming. So much so that I can't make it through a 40 minute show without it crashing twice, with plugin-container.exe taking up the same amount of memory as firefox and will randomly ratchet up to a high enough CPU eating level that it'll freeze my computer for a good several minutes or longer until I can finally force kill it. I've heard suggestions on other forums to just uninstall and install a earlier version of firefox, which I'm about to do. This is certainly annoying.

Question owner

this is roasting my computer!

this is roasting my computer!

Question owner

This is truly embarrassing. Is anyone at Mozilla listening? Why should plugin-container take 94% of my CPU? I'm not even using Flash right now...

This is truly embarrassing. Is anyone at Mozilla listening? Why should plugin-container take 94% of my CPU? I'm not even using Flash right now...

Question owner

should i really uninstall and install again the firefox?

should i really uninstall and install again the firefox?

Helpful Reply

My computer nearly stops since updating Firefox (and gaining this Plugin-container.exe abomination). Come on Firefox, I have changed from IE because it is rubbish don't make me think the same about you.

My computer nearly stops since updating Firefox (and gaining this Plugin-container.exe abomination). Come on Firefox, I have changed from IE because it is rubbish don't make me think the same about you.

Question owner

Me again, after installing a previous version of Firefox and getting rid of the plugin-container.exe everything have been working fine.

If you wish to downgrade you can find a walkthrough here http://support.mozilla.com/en-US/kb/Installing%20a%20previous%20version%20of%20Firefox

Here is a step by step to download version 3.5.9 which does not have plugin-container.exe and works just fine currently.


Go here: ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/ --- Click on the folder named 3.5.9 --- Click on the folder named win32 --- This is the language selection, for English click on the folder en-US --- Click on and download Firefox Setup 3.5.9.exe --- After you download this but before you install, be sure to disable the automatic updates, to do this do the following;

On the top of your firefox window click on Tools and then Options.

In this window click on the advanced tab

In this window you will see two sets of options for your auto-updates. Select the "Ask me what I want to do" under the "When updates to firefox are found" section.

Click OK on the bottom of the window to save your selection.

You may now install any earlier version of firefox you like and it will ask you before installing the most recent one, so you can update in the future when hopefully this problem is fixed.

This is only a temporary work around, but hopefully it will help those of you experiencing problems until a real fix is released.

Me again, after installing a previous version of Firefox and getting rid of the plugin-container.exe everything have been working fine. If you wish to downgrade you can find a walkthrough here http://support.mozilla.com/en-US/kb/Installing%20a%20previous%20version%20of%20Firefox Here is a step by step to download version 3.5.9 which does not have plugin-container.exe and works just fine currently. -------------------- Go here: ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/ --- Click on the folder named 3.5.9 --- Click on the folder named win32 --- This is the language selection, for English click on the folder en-US --- Click on and download Firefox Setup 3.5.9.exe --- After you download this but before you install, be sure to disable the automatic updates, to do this do the following; On the top of your firefox window click on Tools and then Options. In this window click on the advanced tab In this window you will see two sets of options for your auto-updates. Select the "Ask me what I want to do" under the "When updates to firefox are found" section. Click OK on the bottom of the window to save your selection. You may now install any earlier version of firefox you like and it will ask you before installing the most recent one, so you can update in the future when hopefully this problem is fixed. This is only a temporary work around, but hopefully it will help those of you experiencing problems until a real fix is released.

Question owner

The last solution for Linux, Fedora 13 users is not a nice fix. My system:

Fedora Release 13 (Goddard) Kernel Linux 2.6.33.5-124.fc13.i686.PAE GNOME 2.30.0 Memory: 1.5 GiB Processor: Intel(R) Pentium(R) 4 CPU 2.80GHz Dell Dimension 2400

Interesting Opera has the same problem and it doesn't use plugin-container, but opera-plugin. Next step try Chrome.

The last solution for Linux, Fedora 13 users is not a nice fix. My system: Fedora Release 13 (Goddard) Kernel Linux 2.6.33.5-124.fc13.i686.PAE GNOME 2.30.0 Memory: 1.5 GiB Processor: Intel(R) Pentium(R) 4 CPU 2.80GHz Dell Dimension 2400 Interesting Opera has the same problem and it doesn't use plugin-container, but opera-plugin. Next step try Chrome.
TXGuy 87 solutions 861 answers

See the following for information on disabling plugin-container.exe:

https://support.mozilla.com/en-US/forum/1/713600?#threadId719044
<u>'''See the following for information on disabling plugin-container.exe:'''</u> https://support.mozilla.com/en-US/forum/1/713600?#threadId719044

Question owner

Thanks TXGuy, for your suggestion, but following it didn't help. However, I did find a solution to my problem. I was using a Flash Downloader, and now, I can't remember where I got it, or what it was called. It was listed as an extension and it had rotating, colored leaves when there was a flash available to download. Once I deleted it, the flash player and viewing flash content did not peg my machine's CPU as before.

Thanks TXGuy, for your suggestion, but following it didn't help. However, I did find a solution to my problem. I was using a Flash Downloader, and now, I can't remember where I got it, or what it was called. It was listed as an extension and it had rotating, colored leaves when there was a flash available to download. Once I deleted it, the flash player and viewing flash content did not peg my machine's CPU as before.

Question owner

The same problem here. Flash 10.1 and when playing on Facebook Frontiervilie my CPU temperature rises from 43 (usually at hot days) to 60 in secends. After closing Flash it drops in a minute to the normal temperature.

The same problem here. Flash 10.1 and when playing on Facebook Frontiervilie my CPU temperature rises from 43 (usually at hot days) to 60 in secends. After closing Flash it drops in a minute to the normal temperature.
the-edmeister
  • Top 10 Contributor
  • Moderator
3931 solutions 29649 answers

Ric,

First, make sure one of your extensions isn't causing that problem. http://support.mozilla.com/en-US/kb/troubleshooting+extensions+and+theme...

Second, if that doesn't solve your problem, try disabling the "Crash Protection" provided by the Plugin Container feature. http://kb.mozillazine.org/Plugin-container_and_out-of-process_plugins

Ric, First, make sure one of your extensions isn't causing that problem. [http://support.mozilla.com/en-US/kb/troubleshooting+extensions+and+themes] Second, if that doesn't solve your problem, try disabling the "Crash Protection" provided by the Plugin Container feature. http://kb.mozillazine.org/Plugin-container_and_out-of-process_plugins

Question owner

My experience is similar to previous posters - high CPU usage with Flash video playback (well over 50% in my case, with dual-core 2.5GHz). Task Manager showed both firefox and plugin-container.exe using 20-30%. I tried disabling plugin-container, but it simply switched the load onto Firefox itself.

When I switched to IE Tab, however, the load drops to10-15% in total, a little higher if I increase the quality (Firefox is 8-10%). To me, this suggests the problem is the Flash plugin (I think IE Tab uses the ActiveX component). I updated Flash to 10.1 only yesterday, but I was seeing this before with 10.0.

Chrome and Safari also show high CPU usage. Both use the same Flash plug-in. Chrome has an extra one (gcswf32), but shows no change if I disable NPSWF32.

I don't know who's responsible for fixing this, but my workaround is to switch to IE - the tab extension makes this simple.

My experience is similar to previous posters - high CPU usage with Flash video playback (well over 50% in my case, with dual-core 2.5GHz). Task Manager showed both firefox and plugin-container.exe using 20-30%. I tried disabling plugin-container, but it simply switched the load onto Firefox itself. When I switched to IE Tab, however, the load drops to10-15% in total, a little higher if I increase the quality (Firefox is 8-10%). To me, this suggests the problem is the Flash plugin (I think IE Tab uses the ActiveX component). I updated Flash to 10.1 only yesterday, but I was seeing this before with 10.0. Chrome and Safari also show high CPU usage. Both use the same Flash plug-in. Chrome has an extra one (gcswf32), but shows no change if I disable NPSWF32. I don't know who's responsible for fixing this, but my workaround is to switch to IE - the tab extension makes this simple.
Morbus 135 solutions 2340 answers

Helpful Reply

Hello everyone.

Issues of this sort are, unfortunately, more common and the we'd like them to be. However, they tend not to be cause by Firefox itself, but rather by software that is running either inside or alongside it, such as add-ons or firewalls. Since these issues have a broad span of possible causes, you need to diagnose your problems before fixing them. Follow these instructions to the line, as they'll probably help you diagnose and fix the problems you're having.

  1. run Firefox in safe-mode to disable all extensions, themes and plugins. If this fixes your problem, be it with RAM or CPU usage, then you know it's a problem with add-ons (plugins, themes or extensions). Proceed to number 2. If safe-mode doesn't fix your problem, then read bellow, after this list;
  2. update all extensions (go into Tools > Add-ons > Extensions > Find Updates), themes and plugins (see this page in your Firefox. If this doesn't solve the issues, proceed to the following number;
  3. disable all extensions, themes and plugins in your Firefox (not running safe-mode). This is temporary and for diagnostic purposes only. Being certain that, as in safe-mode, the problems you're having have gone away, enable one plugin at a time. You should be certain that you actually want that plugin to be enabled. It's best to keep the overall number of enabled plugins as low as possible. When you encounter problems, you know you've found a problematic plugin, so disable it for good. Keep enabling all plugins (except problematic ones) until you've gone through them all. If you need support for a problematic plugin, you need to contact its author for support;
  4. enable one extension at a time. Again, be certain that you actually want that extension to be enabled. As with plguins, it's best to keep the overall number of enabled extensions as low as possible. Also, try the theme you want to have installed so see if that is what's causing the problem. When you encounter problems, you know you've found a problematic extension/theme, so disable it for good. Keep enabling all your extensions (except problematic ones) until you've gone through them all. Just the same as with plugins, if you need support for a problematic extension/plugin, you need to contact its author;
  5. if you've followed my instructions above, you're done! You've fixed your problems with problematic add-ons. If you want to keep using those problematic add-ons, please contant their authors for support.

Ok, now... If disabling all extensions and plugins through safe-mode didn't work to fix your problems (or, in other words, if you've just read number 1 on the list above and come straight here), then you have different issue. The most likely scenario is that you have a third party software running on your computer that is messing with Firefox. Detecting which program it is may be tricky, but the following list should help you. Make sure you follow it carefully. Don't forget to answer the question on the last point, if nothing else helps.

  1. try reinstalling Firefox. No data will be lost. You can get the latest version (for free, as always) at getfirefox.com. Make sure you uninstall Firefox prior to reinstalling it. For help installing Firefox, see this support article. If that doesn't fix the problem, proceed;
  2. do a virus/malware check on your computer. See this support article for help on this point. This is a very important step, so please pay attention to it. If your problem is not due to viruses/malware, proceed;
  3. disable all software running in the background that you don't want to have running in the background (in Windows operating systems, this is done by pressing WINDOWS+R in your keyboard, typing msconfig and pressing Enter; now, under the Startup tab, you can uncheck the software you don't want, and reboot your system for changes to take effect; if you're unsure of what software you want running, ask someone with more experience). If this doesn't fix your issues with Firefox, proceed;
  4. check if your firewall/antivirus/security suite is conflicting in any way with Firefox's normal behavior. Check for enabled functions/features that you don't want and/or may be causing problems with Firefox. You'll find that these features are most likely tied to Internet Security features, such as link scanners or URL checkers and the like. If you're not sure they are conflicting with Firefox, simply try to disable them temporarily to see whether or not that's true. If this doesn't solve the issues, proceed to the following number;
  5. check your operating system security options, mainly advanced options that are not configured by default. While it's very unlikely that this may be the cause of the problem, it's remotely possible. If this doesn't work, proceed to the following point;
  6. update your modem/router software. There have been some reports that some modem/router software may cause Firefox and other browsers to loose performance and/or stability. If updating doesn't fix your issue, try other versions of the software, if possible. If you need support with this, contact your modem/router manufacturer. If this doesn't help, proceed;
  7. if you are using a Windows operating system, clean up your OS registry using appropriate software. There have been reports that badly maintained Windows Registries may case problems with Firefox. If this doesn't help, see the following point;
  8. please try creating a new temporary Firefox profile (managing profiles) and see if the issues persist. Please report the results, so we can help you further.
Hello everyone. Issues of this sort are, unfortunately, more common and the we'd like them to be. However, they tend not to be cause by Firefox itself, but rather by software that is running either inside or alongside it, such as add-ons or firewalls. Since these issues have a broad span of possible causes, you need to diagnose your problems before fixing them. Follow these instructions ''to the line'', as they'll probably help you diagnose and fix the problems you're having. #run Firefox in [http://support.mozilla.com/en-US/kb/Safe+Mode safe-mode] to disable all extensions, themes and plugins. If this fixes your problem, be it with RAM or CPU usage, then you know it's a problem with add-ons (plugins, themes or extensions). Proceed to number 2. If safe-mode doesn't fix your problem, then read bellow, after this list; #update all extensions (go into ''Tools > Add-ons > Extensions > Find Updates''), themes and plugins (see [https://www.mozilla.com/en-US/plugincheck/ this page] in your Firefox. If this doesn't solve the issues, proceed to the following number; #disable all extensions, themes and plugins in your Firefox (not running safe-mode). This is temporary and for diagnostic purposes only. Being certain that, as in safe-mode, the problems you're having have gone away, enable one plugin at a time. You should be certain that you actually want that plugin to be enabled. It's best to keep the overall number of enabled plugins as low as possible. When you encounter problems, you know you've found a problematic plugin, so disable it for good. Keep enabling all plugins (except problematic ones) until you've gone through them all. If you need support for a problematic plugin, you need to contact its author for support; #enable one extension at a time. Again, be certain that you actually want that extension to be enabled. As with plguins, it's best to keep the overall number of enabled extensions as low as possible. Also, try the theme you want to have installed so see if that is what's causing the problem. When you encounter problems, you know you've found a problematic extension/theme, so disable it for good. Keep enabling all your extensions (except problematic ones) until you've gone through them all. Just the same as with plugins, if you need support for a problematic extension/plugin, you need to contact its author; #if you've followed my instructions above, you're done! You've fixed your problems with problematic add-ons. If you want to keep using those problematic add-ons, please contant their authors for support. Ok, now... ''If'' disabling all extensions and plugins through safe-mode didn't work to fix your problems (or, in other words, if you've just read number 1 on the list above and come straight here), then you have different issue. The most likely scenario is that you have a third party software running on your computer that is messing with Firefox. Detecting which program it is may be tricky, but the following list should help you. Make sure you follow it carefully. Don't forget to answer the question on the last point, if nothing else helps. #try reinstalling Firefox. No data will be lost. You can get the latest version (for free, as always) at [http://www.getfirefox.com/ getfirefox.com]. Make sure you [http://support.mozilla.com/en-US/kb/Uninstalling+Firefox uninstall Firefox] prior to reinstalling it. For help installing Firefox, see [https://support.mozilla.com/en-US/kb/Installing+Firefox this support article]. If that doesn't fix the problem, proceed; #do a virus/malware check on your computer. See [https://support.mozilla.com/en-US/kb/Is+my+Firefox+problem+a+result+of+malware?s=malware&as=s this support article] for help on this point. ''This is a very important step'', so please pay attention to it. If your problem is not due to viruses/malware, proceed; #disable all software running in the background that you don't want to have running in the background (in Windows operating systems, this is done by pressing WINDOWS+R in your keyboard, typing ''msconfig'' and pressing Enter; now, under the ''Startup'' tab, you can uncheck the software you don't want, and reboot your system for changes to take effect; if you're unsure of what software you want running, ask someone with more experience). If this doesn't fix your issues with Firefox, proceed; #check if your firewall/antivirus/security suite is conflicting in any way with Firefox's normal behavior. Check for enabled functions/features that you don't want and/or may be causing problems with Firefox. You'll find that these features are most likely tied to Internet Security features, such as link scanners or URL checkers and the like. If you're not sure they are conflicting with Firefox, simply try to disable them temporarily to see whether or not that's true. If this doesn't solve the issues, proceed to the following number; #check your operating system security options, mainly advanced options that are not configured by default. While it's very unlikely that this may be the cause of the problem, it's remotely possible. If this doesn't work, proceed to the following point; #update your modem/router software. There have been some reports that some modem/router software may cause Firefox and other browsers to loose performance and/or stability. If updating doesn't fix your issue, try other versions of the software, if possible. If you need support with this, contact your modem/router manufacturer. If this doesn't help, proceed; #if you are using a Windows operating system, clean up your OS registry using appropriate software. There have been reports that badly maintained Windows Registries may case problems with Firefox. If this doesn't help, see the following point; #please try creating a new temporary Firefox profile ([http://support.mozilla.com/en-US/kb/Managing+profiles managing profiles]) and see if the issues persist. Please report the results, so we can help you further.
randyh2 0 solutions 1 answers

Firefox 4 would occasionally take over 90% cpu for me too. I turned the plugin-container off and it still used 90%. After a little digging, I found out it was Javascript sucking the cpu. The site causing it is...

http://www.50plus.com/steve-dotto/social-coupons-such-a-deal/112791/

It works okay in IE, but also sucks cpu in Opera.

Firefox 4 would occasionally take over 90% cpu for me too. I turned the plugin-container off and it still used 90%. After a little digging, I found out it was Javascript sucking the cpu. The site causing it is... http://www.50plus.com/steve-dotto/social-coupons-such-a-deal/112791/ It works okay in IE, but also sucks cpu in Opera.
sibiantony 0 solutions 3 answers

Hello all,

I had exactly same problem and has not appeared since I created a new profile and started using that. Unfortunately this workaround is listed as the last tip in Morbus' post above, so many wouldn't have tried that out. There seems to be some nasty bug to be fixed with old profiles ? :)

I was using Fedora 15(2.6.38.8-35.fc15.x86_64), and 64-bit firefox 5. I started noticing firefox eating away CPU a month back. For sure, I havn't noticed the same before. Occasionally, the browser started freezing and my CPU fan running in full speed. From 'top' I could see plugin-container almost at 90-100% and this would stay for 30-60 seconds. This kept repeating every 15 minutes or so... This would happen even when browser is idle - and even when there are no pages opened with flash content. I didn't have any extensions or themes installed, so was wondering what is causing this problem. There were no javascript-heavy pages opened either - even with a single-blank-idle-tab the browser would freeze and make other apps crawl.

At one point I even decided to switch to chrome, but later thought of trying some workarounds.

First I started with safe mode option - disabled all plugins - flash and googletalk-plugin. I attempted tweaking the dom.ipc.plugins.* booleans in the config. The problem was still there. Havn't thought of 'renicing' etc, which in my opinion is not a solution at all.

After reading the kb article here I attempted a profile switch. I havn't had the problem since that time, and things are normal. Firefox devs, please consider looking into this - specifically old profiles - if you think something needs to be addressed there.

Hope this helps someone.

Hello all, I had exactly same problem and '''has not appeared since I created a new profile''' and started using that. Unfortunately this workaround is listed as the last tip in Morbus' post above, so many wouldn't have tried that out. There seems to be some nasty bug to be fixed with old profiles ? :) I was using '''Fedora 15(2.6.38.8-35.fc15.x86_64), and 64-bit firefox 5'''. I started noticing firefox eating away CPU a month back. For sure, I havn't noticed the same before. Occasionally, the browser started freezing and my CPU fan running in full speed. From 'top' I could see plugin-container almost at 90-100% and this would stay for 30-60 seconds. This kept repeating every 15 minutes or so... This would happen even when browser is idle - and even when there are no pages opened with flash content. I didn't have any extensions or themes installed, so was wondering what is causing this problem. There were no javascript-heavy pages opened either - even with a single-blank-idle-tab the browser would freeze and make other apps crawl. At one point I even decided to switch to chrome, but later thought of trying some workarounds. First I started with safe mode option - disabled all plugins - flash and googletalk-plugin. I attempted tweaking the dom.ipc.plugins.* booleans in the config. The problem was still there. Havn't thought of 'renicing' etc, which in my opinion is not a solution at all. After reading the kb article [http://kb.mozillazine.org/Profile_Manager here] I attempted a profile switch. I havn't had the problem since that time, and things are normal. Firefox devs, please consider looking into this - specifically old profiles - if you think something needs to be addressed there. Hope this helps someone.

Modified by sibiantony

Naceira 0 solutions 1 answers

The flash downloader "AnonymousUser" talks about is "Download Helper" and, disabling it, worked for me like a charm. No more cpu overuse by plugin-container. So check your firefox add-ons for incompatibilities!

The flash downloader "AnonymousUser" talks about is "'''Download Helper'''" and, disabling it, worked for me like a charm. No more cpu overuse by plugin-container. So check your firefox add-ons for incompatibilities!