X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Problems with Plugin Container after upgraded to firefox 3.6.4

Posted

I upgraded to Firefox 3.6.4 and when I opened the browser a window came up: Plugin Container for Firefox stopped going on. If I close that window,the firefox closes immediately,If I dont close it,i can use it on several websites but not every! How could I fix this plugin container thing?

Operating system

windows vista

Chosen solution

Instead of downgrading Firefox you can keep Firefox 3.6.4 (which has the latest security updates) and try this:

Disable the new plugin crash protection (OOPP) feature in Firefox 3.6.4 by going to about:config (check the link for details) and then toggle the individual dom.ipc.plugins.enabled. preferences to false.

...e.g., on Windows, enter about:config in the Firefox Location Bar (address bar), and then double-click these preferences to set them to false: dom.ipc.plugins.enabled.npctrl.dll (Microsoft Silverlight) dom.ipc.plugins.enabled.npqtplugin.dll (Apple QuickTime) dom.ipc.plugins.enabled.npswf32.dll (Adobe Flash)

Note: The dom.ipc.plugins.enabled preference should already be set to "false", by default. This preference covers all other plugins not specified by an individual filename.

If you are only having a problem with a specific plugin, such as the Adobe Flash Player plugin, just disable that one preference.

Ref: http://forums.mozillazine.org/viewtopic.php?f=38&t=1929497 http://mozillalinks.org/wp/2010/06/firefox-3-6-4-now-available/ http://benjamin.smedbergs.us/blog/2010-03-03/firefox-safe-from-plugin-crashes/

If you still want to downgrade Firefox after trying the above, read: http://kb.mozillazine.org/Go_back_to_an_old_version_of_Firefox

Read this answer in context 9

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; hu; rv:1.9.2.4) Gecko/20100611 Firefox/3.6.4 (.NET CLR 3.5.30729)

More Information

Question owner

Hi I'm the anonymous guy from 11:52. Some people say the problem lies with the flash plug-in, but i severly doubt that. I just reinstalled firefox 3.63 (I always save my older versions, just in case) with the latest flash plug-in (10.1.53.64) still running, and tested it by watching some video's on youtube and playing some flash games.With 3.6.4 running I had about 5 seconds before firefox locked up but now I have no more problems. I suggest everyone who is experienceing the "container" problem to reinstall 3.6.3. I could be that you saved the version, look for a file named "firefox setup" on your computer. Just install it and firefox will downgrade automatically, make sure NOT to have automatic updates enabled in firefox. I hope this helps.

Question owner

i have the same problem n frustrating thing is I can see so many people have same problem here and there is no solution provided here in this page.

there should be some mozilla admin people to post the solution here.

COME ON WAKE UP MOZILLA TEAM

Question owner

Uhm, there's a possible solution in the post just above yours.

Question owner

but I'm working with XP pro

Question owner

I changed to Firefox Safe mode and i dont have the problem with the plugin container now! but i dont even know whats the difference between the normal and safe mode..

Question owner

in addition to previous post, safe mode doesn't help anyhow.

Question owner

where is 3.6.4.patch? Seriously, Mozilla needs a fix, like yesterday!

Question owner

same problem. the "plugin container is using between 50 and 95 % of CPU. i tried to delete it, and ff woul;d just crash on the next use.

Question owner

Seems everyone is having firefox freeze on any flash site with the 3.6.4 update, I had to go back to 3.6.3 which fixes the problem. The old version can be found here....

http://www.oldapps.com/firefox.php

Seems apparent they did not test this release much before putting it out!!! Kind of funny they are saying they made changes and added a separate container for plugins like flash so it would not lock up the browser if flash crashed, when all they have really done is made it so flash content now locks up the browser almost every single time... lol

Question owner

Yeah.

Ever since my Firefox updated to 3.6.4, Firefox would just hang or crash when on a site that uses flash. I also notice that CPU usage increased a fair bit compare to the previous version. Strangely, the plugin-container.exe continued to run even when I exit the said site that uses flash and when I exit Firefox entirely.

Also when I watch videos from Youtube, they seem become very choppy. I confirm that it has nothing to do with my add-ons since they are all up to date, that I only have 4 of them, and I tried disabling them with no improvement. Moreover, I never have this problem of slowdowns in 3.6.3.; the slowdown occurred just as my Firefox updated to 3.6.4.

As a result, I sadly had to revert back to 3.6.3 and have to keep the update off. Hopefully this problem will be resolved soon, whenever that will be.

Question owner

Will have to regress to 3.6.3 also.

Way to go Mozilla, blaming the Plug Ins, when it's your plugin-container executable that causes the problem... "We're right and everybody else is wrong" - talk about arrogant.

AliceWyman
  • Top 25 Contributor
  • Moderator
191 solutions 1967 answers

Chosen Solution

Instead of downgrading Firefox you can keep Firefox 3.6.4 (which has the latest security updates) and try this:

Disable the new plugin crash protection (OOPP) feature in Firefox 3.6.4 by going to about:config (check the link for details) and then toggle the individual dom.ipc.plugins.enabled. preferences to false.

...e.g., on Windows, enter about:config in the Firefox Location Bar (address bar), and then double-click these preferences to set them to false: dom.ipc.plugins.enabled.npctrl.dll (Microsoft Silverlight) dom.ipc.plugins.enabled.npqtplugin.dll (Apple QuickTime) dom.ipc.plugins.enabled.npswf32.dll (Adobe Flash)

Note: The dom.ipc.plugins.enabled preference should already be set to "false", by default. This preference covers all other plugins not specified by an individual filename.

If you are only having a problem with a specific plugin, such as the Adobe Flash Player plugin, just disable that one preference.

Ref: http://forums.mozillazine.org/viewtopic.php?f=38&t=1929497 http://mozillalinks.org/wp/2010/06/firefox-3-6-4-now-available/ http://benjamin.smedbergs.us/blog/2010-03-03/firefox-safe-from-plugin-crashes/

If you still want to downgrade Firefox after trying the above, read: http://kb.mozillazine.org/Go_back_to_an_old_version_of_Firefox

Zedd1 0 solutions 1 answers

Same problem for me too. Ever since the upgrade the plugin container keeps running amok uses incredible amount of memory, freezes everything up, crashes, slows computer down.

BicycleGuy 0 solutions 1 answers

i disabled Firefox from task mngr and all that happens is Adobe crashes and then Firefox crashes. i had already had the latest version of Adobe installed before the plugin container started crashing.

pylonix 0 solutions 1 answers

same problem here but already solved

step 1 put your laptop in the microwave step 2 turn on the microwave 5 minutes should do the trick step 3 buy new one and use opera or something