X
Tap here to go to the mobile version of the site.

Support Forum

Since upgrading to latest version, when I open Firefox by clicking a link a second blank page appears behind destination page. Why is this?

Posted

When I open Firefox by clicking on a link, a 2nd blank page opens behind destination. Why is this!

This happened

A few times a week

== I upgraded to latest version of Firefox 3.6.3

When I open Firefox by clicking on a link, a 2nd blank page opens behind destination. Why is this! == This happened == A few times a week == I upgraded to latest version of Firefox 3.6.3

Additional System Details

Installed Plug-ins

  • -Gecko default plugin
  • RealPlayer Plugin
  • Plugin for viewing Sibelius(tm) music scores http://www.sibelius.com
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Shockwave Flash 10.0 r32
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

More Information

Nothing relevant. I'm running OS X 10.4.11

Morbus 135 solutions 2340 answers

Hello David.

You may be having a problem with some extension or plugin that is hindering your Firefox's normal behavior. Have you tried disabling all add-ons (just to check), to see if Firefox goes back to normal?

Hello David. You may be having a problem with some extension or plugin that is hindering your Firefox's normal behavior. Have you tried disabling all add-ons (just to check), to see if Firefox goes back to normal?
cor-el
  • Top 10 Contributor
  • Moderator
17516 solutions 158398 answers

Can be this bug: https://bugzilla.mozilla.org/show_bug.cgi?id=531552 - Firefox 3.6b opens two windows when opening external links

Can be this bug: https://bugzilla.mozilla.org/show_bug.cgi?id=531552 - Firefox 3.6b opens two windows when opening external links

Question owner

The link posted by cor-el refers to the exact same problem; apparently common and not fixed yet. In my case it happens when I click on links in mail. Doesn't seem likely that it's related to plug-ins, since it's so common. I also don't know how to temporarily disable the plug-ins. However I have no idea what the gecko default plug-in is, or how I acquired it.

The link posted by cor-el refers to the exact same problem; apparently common and not fixed yet. In my case it happens when I click on links in mail. Doesn't seem likely that it's related to plug-ins, since it's so common. I also don't know how to temporarily disable the plug-ins. However I have no idea what the gecko default plug-in is, or how I acquired it.
Morbus 135 solutions 2340 answers

David. Running firefox in safe mode will let you disable all add-ons temporarily with ease.

Gecko default plug-in is not used although it comes with Firefox. You can disable it without loss of functionality.

David. Running firefox in [http://support.mozilla.com/en-US/kb/Safe+Mode safe mode] will let you disable all add-ons temporarily with ease. Gecko default plug-in is not used although it comes with Firefox. You can disable it without loss of functionality.

Question owner

Above post from Morbus answers two questions very efficiently. One weird thing happened: the link to the safe mode article that I received in the email version of that post was incorrect. However the link above is correct.

Above post from Morbus answers two questions very efficiently. One weird thing happened: the link to the safe mode article that I received in the email version of that post was incorrect. However the link above is correct.
Morbus 135 solutions 2340 answers

I believe that has something to do with how we insert links here in the forum and how some email clients interpret them. In other words, text formating here in the forums doesn't translate in the email notifications (which is something to work on, I guess. I will notify the moderators). Here's an example:

this text is underlined in the forums but not in the email notifications

Thanks for pointing that out, David.

I believe that has something to do with how we insert links here in the forum and how some email clients interpret them. In other words, text formating here in the forums doesn't translate in the email notifications (which is something to work on, I guess. I will notify the moderators). Here's an example: <u>this text is underlined in the forums but not in the email notifications</u> Thanks for pointing that out, David.
cor-el
  • Top 10 Contributor
  • Moderator
17516 solutions 158398 answers

That is done deliberately. In the past there were a lot of problems with TikiWiki markup and emails and that doesn't work, so all markup is removed in an email.

Bug 409904 – [ForumUX] Forum post e-mail notifications should not be output with tiki markup

That is done deliberately. In the past there were a lot of problems with TikiWiki markup and emails and that doesn't work, so all markup is removed in an email. [https://bugzilla.mozilla.org/show_bug.cgi?id=409904 Bug 409904] – [ForumUX] Forum post e-mail notifications should not be output with tiki markup

Question owner

I have exactly the same problem which started shortly after updating to the latest version.

My add ons are :-

Firefox Sync 1.3 true {340c2bbc-ce74-4362-90b5-7c26312808ef} Java Console 6.0.20 true Java Quick Starter 1.0 true jqs@sun.com Microsoft .NET Framework Assistant 0.0.0 true {20a82645-c095-46ed-80e3-08825760534b} Netcraft Anti-Phishing Toolbar 1.4.5.1 true {0e10f3d7-07f6-4f12-97b9-9b27e07139a5} McAfee SiteAdvisor 3.1 true PDF Download 3.0.0.1 true {37E4D8EA-8BDA-4831-8EA1-89053939A250} Adblock Plus 1.2 true AI Roboform Toolbar for Firefox 6.9.98 true {22119944-ED35-4ab1-910B-E619EA06A115}

I have exactly the same problem which started shortly after updating to the latest version. My add ons are :- Firefox Sync 1.3 true {340c2bbc-ce74-4362-90b5-7c26312808ef} Java Console 6.0.20 true Java Quick Starter 1.0 true jqs@sun.com Microsoft .NET Framework Assistant 0.0.0 true {20a82645-c095-46ed-80e3-08825760534b} Netcraft Anti-Phishing Toolbar 1.4.5.1 true {0e10f3d7-07f6-4f12-97b9-9b27e07139a5} McAfee SiteAdvisor 3.1 true PDF Download 3.0.0.1 true {37E4D8EA-8BDA-4831-8EA1-89053939A250} Adblock Plus 1.2 true AI Roboform Toolbar for Firefox 6.9.98 true {22119944-ED35-4ab1-910B-E619EA06A115}
Morbus 135 solutions 2340 answers

This is what I'd do:

Java Console, trash. Java Quick Starter, trash, Microsoft .NET Framework Assistant, trash, Netcraft Anti-Phishing Toolbar, trash and McAfee SiteAdvisor, trash and burn.

But in your case, running Firefox in safe mode to easily disable all add-ons and see if they are the ones causing the issue is probably the best course of action.

This is what I'd do: Java Console, trash. Java Quick Starter, trash, Microsoft .NET Framework Assistant, trash, Netcraft Anti-Phishing Toolbar, trash and McAfee SiteAdvisor, trash and burn. But in your case, running Firefox in [http://support.mozilla.com/en-US/kb/Safe+Mode safe mode] to easily disable all add-ons and see if they are the ones causing the issue is probably the best course of action.

Question owner

Since I don't have any of the plug-ins that Ron has, it doesn't seem likely that they are causing this. I think it's just an odd glitch in the latest version of Firefox. Since I have preference settings to open Firefox with a blank page, that's what I get in the second window. People who have it set to open to a homepage get that in the second window, which is likely more of an annoyance.

Since I don't have any of the plug-ins that Ron has, it doesn't seem likely that they are causing this. I think it's just an odd glitch in the latest version of Firefox. Since I have preference settings to open Firefox with a blank page, that's what I get in the second window. People who have it set to open to a homepage get that in the second window, which is likely more of an annoyance.

Question owner

If I run Firefox in safe mode and leave it open then a link opens just the linked page. But if I leave "normal" Firefox open I still only get one page - so I can't prove or disprove the effect of any add ons.

If I run Firefox in safe mode and leave it open then a link opens just the linked page. But if I leave "normal" Firefox open I still only get one page - so I can't prove or disprove the effect of any add ons.

Question owner

This gets more crazy. If I click the link in the email re David's answer I only get the linked page. If I click the link in another email I still get two pages.

???

This gets more crazy. If I click the link in the email re David's answer I only get the linked page. If I click the link in another email I still get two pages. ???
Morbus 135 solutions 2340 answers

Ron, to see which add-on is causing this, disable them all, then enable them one at a time until you find the problem.

David, other add-ons may cause this issue. It may be a glitch from Firefox, but what causes that glitch? My guess is: some add-on. And they may not always be the same one.

Ron, to see which add-on is causing this, disable them all, then enable them one at a time until you find the problem. David, other add-ons may cause this issue. It may be a glitch from Firefox, but what causes that glitch? My guess is: some add-on. And they may not always be the same one.

Question owner

Thanks for the suggestion. However I am now in the situation where one link, e.g. the ones from David and Morbus, bring up a single page whereas a link I received from my financial sharres company brings up two separate pages - usually with my blank home oage in the foreground. Furthermore, this only happens on my laptop which is running XP Home- on my older desktop running XP Pro; with the same add ons; there is no problem. Curioser and curioser !!

Thanks for the suggestion. However I am now in the situation where one link, e.g. the ones from David and Morbus, bring up a single page whereas a link I received from my financial sharres company brings up two separate pages - usually with my blank home oage in the foreground. Furthermore, this only happens on my laptop which is running XP Home- on my older desktop running XP Pro; with the same add ons; there is no problem. Curioser and curioser !!

Question owner

Ron, do you already have your browser open when this does or doesn't happen? I've noticed that if I click on a link in mail with firefox already open, I just get one page. It's not related to a specific mail program though, since people have reported the same phenomena with different ones. I also have a different OS than either of yours.

Ron, do you already have your browser open when this does or doesn't happen? I've noticed that if I click on a link in mail with firefox already open, I just get one page. It's not related to a specific mail program though, since people have reported the same phenomena with different ones. I also have a different OS than either of yours.

Question owner

David I only get the two pages if the browser is closed.

If I leave it open then there are no problems

David I only get the two pages if the browser is closed. If I leave it open then there are no problems