X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

why does Firefox ask me always for permission to use some obscure fonts?

Posted

Why does Firefox always ask for permission to use some obscure fonts?

This happened

Every time Firefox opened

== A few weeks ago

Additional System Details

Installed Plug-ins

  • -Gecko default plugin
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • iPhoto6
  • Yahoo! Installer Plug-in provides application installation support
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Office Live Update v1.0
  • Java Plug-In 2 for NPAPI Browsers
  • Allows webpages to support pressure-sensitive drawing on Wacom pen tablets.
  • 3.0.50106.0
  • Garmin Communicator Plug-in Version 2.9.2.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • Shockwave Flash 10.0 r45

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

More Information

Why does Firefox always ask for permission to use some obscure fonts?

Cheng Wang
  • Administrator
  • Moderator
36 solutions 435 answers

This is a Mac OS X issue. If the permissions on your font folder aren't set right and a website tries to use obscure (or "any" font), Mac OSX will ask you for your password to use fonts (perhaps for each font requested). There are a few websites out there that explain and help you fix it like that one:

http://homepage.mac.com/macdrben/blogwavestudio/LH20041002162312/LHA20050717180701/index.html

Question owner

The proposed soltion involves permissions and blames the OS.

Before the latest Firefox (3.6.3) it didn't search external drives sweeping for any random font to load. Its trying to add in Hebrew, Cyrillic and tons of fonts from my internal and external folders.

The external system folders are bootable systems, I cannot just use batchmod and change all their permissions.

Safari and Chrome do not have this problem.

Question owner

Sorry but the program you suggest using doesn't work to fix the problem and should not be necessary at all. Even if the program did work I shouldn't have to do this for every font to use a browser - you'd think that what this program does would happen when you check the box to always allow Firefox to use the font. I'm moving to Safari.

cor-el
  • Top 10 Contributor
  • Moderator
10742 solutions 96657 answers

If Firefox finds them while that external drive is not connected then you must have an indexing service that responds to the query that Firefox makes while scanning for font files. So you may need to look at the settings in Finder and Spotlight and exclude external drives from getting indexed. See also http://en.wikipedia.org/wiki/Spotlight_%28software%29

Question owner

If you were to turn off Searchlight's indexing of fonts or external drives in general, wouldnt this make your system less efficient for everything else that might need to be able to access these? I wonder about this since you cant tell it to only exclude a drive. etc when Firefox makes a request...

brianberneker 0 solutions 1 answers

Helpful Reply

Yeah the whole "blame the OS" thing is a red herring. What the hell is Firefox doing looking on my external drives in the first place? It asks permission to use a font on another drive, but what else is it looking at outside of the Applications folder where it should know enough to mind its own business?

joshintosh 0 solutions 1 answers

webfonts. I think this is the actual issue here. I'm not an expert, but I am a web designer and developer. I think the sites you're going to are using @font-face. This allows a web site to host the font file that you probably don't have on your computer. What happens is that the font is downloaded form the server and then your browser uses the font. It seems that the computer thinks this might be a security threat. The odd thing is that it don't happen for every server hosted font using @font-face. You can go to http://www.google.com/webfonts to see a whole bunch of these fonts in action. I'm not sure whats going on with it. That's how I ended up here.

cor-el
  • Top 10 Contributor
  • Moderator
10742 solutions 96657 answers

Helpful Reply


Move all User fonts in Font Book to Computer fonts.

  1. Launch Font Book (/Applications/Utilities/)
  2. Open Font Book > Preferences
  3. Deselect: "Automatic Font Activation"
  4. Set the "Default Install Location" for fonts to "Computer"
  5. Select all User fonts
  6. Move the selected User fonts to Computer fonts
  7. Remove all duplicate fonts in Computer fonts