X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I want to open file attachments, but Firefox forces me to save them to a file

Posted

Firefox forces me to save email attachments that I get, rather than just opening them up. I found the tools menu item that allows me to decide where to save them but it does not seem to give me the option to just open them.

Chosen solution

See also "File handling in Firefox 3 and SeaMonkey 2": http://kb.mozillazine.org/File_types_and_download_actions

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • -Default Plug-in
  • Shockwave Flash 10.0 r32
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 ( .NET CLR 3.5.30729)

More Information

Mircosoft.net framework assistant is the only thing i see in add-ons

Question owner

I have the same problem. Windows 7, Firefox 3.6.3. I don't have this problem on my XP machine but there may be no connection to operating system.

Question owner

Same thing. Recent. I use Onebox not Evolution. When I choose to open the attachment, there is only the choice to save the file. (This is with any kind of attachment JPEG or others.) So, I have to save it. It goes automatically onto my desktop.

This only happens in my e-mail.

I don't know how to find out what Mozilla Firefox version I'm using. I got the most recent version within the last two months and keep up on any updates - for Ubuntu also.

Ubuntu 8.4 or 8.04 ? (Dapper Drake)

Question owner

My windows mail attachments turn into firefox attachments that say "click on file name" but are broken links! I can't get any of my attachments...WTF.

Morbus 134 solutions 2338 answers

Hello everyone.

Hopefully this support article is what you need:

http://support.mozilla.com/en-US/kb/Options+window+-+Applications+panel

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96750 answers

Chosen Solution

See also "File handling in Firefox 3 and SeaMonkey 2": http://kb.mozillazine.org/File_types_and_download_actions

jennjoreilly 0 solutions 1 answers

Helpful Reply

This is a ridiculously complex solution to something that the Mozilla Foxfire browser used to do automatically. I do not understand why the handling of attachments has to be made this complicated. Previously, I could click download, the download window dialog box would open and I could choose to open, save, delete the file regardless of what type file it is. Now, for no good reason, I click to download, the same window comes up, indicates the file downloads then the file disappears from that window and I have to go to a designated file where it has been saved to open it. Then, I have to remember to delete it from that file if it's not something (most things are not) something I want to keep!

I've changed the options as provided in the settings for downloads several times but the result is always the same. Why did this change occur? It's enough to make me seriously consider dumping Firefox completely.

ctc2472 0 solutions 1 answers

i know why mines did that. i accidentally checked the little box on the bottom of the pop up for opening or saving attachments and now I cannot find out where to go to uncheck this feature. it was that "from now on" type of choice. any ideas where it is located?

Modified by ctc2472

catlou9 0 solutions 4 answers

Did you ever find out where that was located?

ElaineRuth 0 solutions 5 answers

I accidentally checked the little box on the bottom of the pop up for opening or saving attachments and now I cannot find out where to go to uncheck this feature. it was that "from now on" type of choice. any ideas where it is located?

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96750 answers

Helpful Reply

See "Tools > Options > Applications" and change the file action to "Always ask"