X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

When I open Firefox the following alert appears: "Could not initialize the application's security component. The most likely cause is problems with files in your application's profile directory." There is a solution in the forum but only for Windows based

Posted

When I open the application the following alert appears: "Could not initialize the application's security component. The most likely cause is problems with files in your application's profile directory." There is a solution on the support site but only for Windows-based Firefox, and I'm a Mac user. I have plenty of room on my hard disk.

This happened

Every time Firefox opened

== Two days ago, for no apparent reason.

Additional System Details

Installed Plug-ins

  • -Gecko default plugin
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • iPhoto6
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.0 r42

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

More Information

I tried to find out my extensions but when I clicked on Tools > Add-ons this message appeared:
An error occurred during a connection to services.addons.mozilla.org:443.
Can't connect securely because the SSL protocol has been disabled.
(Error code: ssl_error_ssl_disabled)

Question owner

This started happening for me yesterday after I installed some Mac OS updates (including a Java-related update). I suspect this is the reason but I have no solution yet.

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Rename (or delete) secmod.db (secmod.db.old) and maybe also cert8.db (cert8.db.old) in the Profile Folder in case there is a problem with the files. The file cert8.db stores your user certificates, so if you have user certificates then you may want to export them now and import them after having removed cert8.db. See Tools > Options > Advanced > Encryption: Certificates: View Certificates If that works then you can delete the renamed files or undo the changes if you want to revert the process.

Helpful Reply

when i deleted the cert8.dat from the profile folder (it is recreated on next start of firefox), this problem was fixed

Question owner

Deleting cert8.dat did the trick for me. Thanks!

BTW, I was using Chrome in the interim for a few weeks and wasn't a fan. I'm happy to be back to Firefox.

ksp3008 0 solutions 1 answers

Helpful Reply

for MAC users u delete those secmod.db and cert8.db files. these files can be found in Library -> application support ->firefox ---> profiles --> xxxx.default ---> then those 2 files can be found there. hav fun with firefox! hope it helps

dadamson21 0 solutions 2 answers

There is no Firefox folder in my LIbrary under Application support. Where else should I look?

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

In Mac OS X v10.7, the $HOME/Library folder is a hidden folder.

Open Finder and use one of these:

  • Go > Go To Folder (Shift-Command-G) and in the dialog type: ~/Library
  • Open the "Go" menu and hold down the Option key to make the Library appear

You can also use this command in a Terminal window to remove the hidden flag.

  • Mac HD > Applications > Utilities > Terminal
  • chflags nohidden ~/Library
dadamson21 0 solutions 2 answers

I can find the LIbrary folder with no problem. But there is no Firefox folder in the application support folder, and if it's hidden, I can't make it appear.