Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Global Search not working

  • 2 replies
  • 1 has this problem
  • 9 views
  • Last reply by mozilla516

more options

I found the setting for Global Search and turned it on. I'd like to be able to search all folders (imap and my many local folders). No matter what I put in I get zero results. Is there a time period I need to wait for it to build an index? I found an older thread about this on this forum where someone was told to add a folder to the inclusion list for global search. I have tons of folders, if this is the issue, do I really have to do this for every single folder, one by one, including even my inbox?! thanks

I found the setting for Global Search and turned it on. I'd like to be able to search all folders (imap and my many local folders). No matter what I put in I get zero results. Is there a time period I need to wait for it to build an index? I found an older thread about this on this forum where someone was told to add a folder to the inclusion list for global search. I have tons of folders, if this is the issue, do I really have to do this for every single folder, one by one, including even my inbox?! thanks

Chosen solution

re :I found the setting for Global Search and turned it on.

Just in case anyone else sees this question and wants to know how you did it....

  • Settings > General
  • Scroll to bottom section called 'Indexing'
  • select checkbox 'Enable Global Search and Indexer'

Suggest a restart of Thunderbird to make sure this preference has been correctly saved.

To check a folder is selected for Global Search:

  • Right click on folder and select 'Properties'
  • On 'General Information' tab
  • select checkbox 'Include messages in this folder in Global Search results'

Usually, by default, all folders except Trash and Junk/Spam are auto selected.

Help Articles on how to use the 'Global Search' and repair global database file:

Read this answer in context 👍 0

All Replies (2)

more options

Chosen Solution

re :I found the setting for Global Search and turned it on.

Just in case anyone else sees this question and wants to know how you did it....

  • Settings > General
  • Scroll to bottom section called 'Indexing'
  • select checkbox 'Enable Global Search and Indexer'

Suggest a restart of Thunderbird to make sure this preference has been correctly saved.

To check a folder is selected for Global Search:

  • Right click on folder and select 'Properties'
  • On 'General Information' tab
  • select checkbox 'Include messages in this folder in Global Search results'

Usually, by default, all folders except Trash and Junk/Spam are auto selected.

Help Articles on how to use the 'Global Search' and repair global database file:

Helpful?

more options

Thanks, that was selected but a restart fixed it. Working nice now. In case you're able to do anything about it, I have a complaint about the email notifications. Two actually!

1. I detest this modern way of only giving me two options to click and get BACK to the thread! I either have to mark it as solved, or click that it doesn't help me. When often neither is the case!

2. When I do click the "solved" button, i get a 404 (405 actually) error and the page wont load, yet if I click the "this didn't help me" link, it opens fine!

Maybe I'm just old, but whatever happened to just a good old fashioned LINK to the damn thread?! :D Thanks for your help

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.