Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox taking over PDFs

  • 5 replies
  • 0 have this problem
  • 1 view
  • Last reply by cor-el

more options

Every time I update Firefox I find it has taken over opening pdf files. Yes I know how to fix it but it is a pain having to do that after every update. How do I fix this other than stopping all Firefox updates?

Every time I update Firefox I find it has taken over opening pdf files. Yes I know how to fix it but it is a pain having to do that after every update. How do I fix this other than stopping all Firefox updates?

All Replies (5)

more options

You can disable Firefox as a pdf reader by making the following preference true in about:config. pdfjs.disabled

https://support.mozilla.org/en-US/kb/about-config-editor-firefox

Modified by Terry

Helpful?

more options

Is there an application set for PDF in Windows ?

I think that Firefox would only do this if it finds that no application is set to handle PDF files.

Helpful?

more options

Thanks Terry, have followed your suggestion and will see if it works next time I update Firefox.

Helpful?

more options

Reply to cor-el. Yes, of course I had a default pdf app set. As I said, I knew how to fix it when it happened. Am trying Terry's suggestion and am hopeful it will fix the problem.

Helpful?

more options

Flipping the pdfjs.disabled pref will disable the built-in Firefox PDF Viewer, so pages that embed a PDF file will stay blank.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.