Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

"Not Junk" not working

  • 6 replies
  • 2 have this problem
  • 30 views
  • Last reply by christ1

more options

This started when I received an email that spoofed my own email address and I marked it "Junk". The problem is that I send myself emails with reminders and other information that I want to access later. Now, whenever I send myself an email, it ends in Junk. I made sure my email address is in all of the address/contacts lists on Thunderbird. Every time emails from my own address end up in Junk, I use shift+J to mark them "not junk". I have done this at least a 100 times for numerous messages. I disabled junk processing, restarted, delete the junk folder, re-enable junk processing, start thunderbird again. How can I remove my own email address from the Junk filter?

This started when I received an email that spoofed my own email address and I marked it "Junk". The problem is that I send myself emails with reminders and other information that I want to access later. Now, whenever I send myself an email, it ends in Junk. I made sure my email address is in all of the address/contacts lists on Thunderbird. Every time emails from my own address end up in Junk, I use shift+J to mark them "not junk". I have done this at least a 100 times for numerous messages. I disabled junk processing, restarted, delete the junk folder, re-enable junk processing, start thunderbird again. How can I remove my own email address from the Junk filter?

All Replies (6)

more options

Try to reset the training data in your Global junk preferences. https://support.mozilla.org/kb/thunderbird-and-junk-spam-messages

Note, you'll have to train the filter again after this.

more options

Thx for trying to help. As I attempted to state in my initial message, I have followed the instructions in https://support.mozilla.org/en-US/kb/thunderbird-and-junk-spam-messages. I've done this multiple times over the last several weeks. I've "trained" the filter again using Shift+J. (the "not junk" button does not appear). Per the instructions, I have Shift+J the messages 100 times or more. My email address is on the white list. Nonetheless, the filter continues to send emails sent from my own email address to the Junk folder. My question is to find a better way to remove the "junk" marker from emails sent from my own email address. Would re-installing Thunderbird solve the problem? Or, would the saved backup file also include the junk marker on my own email address?

more options

Did you reset the training data as suggested above?

the "not junk" button does not appear

That's broken in TB115, and developers do not bother to fix this. https://bugzilla.mozilla.org/show_bug.cgi?id=1831713

So you can either right-click a message - Mark - As Not Junk, or use the keyboard shortcut Alt-N for a selected message.

more options

This is definitely broken.

more options

At this point I want to disable all of TB junk-spam filtering capabilities. I have un-checked "Enable adaptive junk mail controls for this account", closed TB and restarted my computer. On restart, even though "Enable adaptive junk mail controls for this account" remains un-checked, emails still go to the junk folder. Note that the only emails that go to the junk folder are the ones in which I have cc'd myself. In other words, only my own email address is going to junk. BTW my own email address is on the white-list. I have spent way too much time reading all the Support community discussions and find no solution for HOW TO TURN IT OFF. Please help. Thanks. [TB 115.4.2, Win 11, have been TB user for 13 years & it's worked great until now]

more options

What is your account type - POP or IMAP? In case of IMAP junk filtering may already occur on the server.