Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

HTTPS-Only Mode Exception List isn't saved between browser restart

  • 2 replies
  • 0 have this problem
  • 4 views
  • Last reply by tetratheta

more options

If I add sites to 'Exceptions - HTTPS-Only Mode' list, I expect that sites are preserved after browser close and restart. But after I close and restart Firefox, the list become empty.

I don't know why this happens. I even deleted every profiles and created new profile. The problem still exists.

Is there any way to manually add HTTPS-Only exception list by editing files in profile directory like 'prefs.js' as a workaround? If Firefox can't save the data, I will manually edit that file and mark it as read-only.

If I add sites to 'Exceptions - HTTPS-Only Mode' list, I expect that sites are preserved after browser close and restart. But after I close and restart Firefox, the list become empty. I don't know why this happens. I even deleted every profiles and created new profile. The problem still exists. Is there any way to manually add HTTPS-Only exception list by editing files in profile directory like 'prefs.js' as a workaround? If Firefox can't save the data, I will manually edit that file and mark it as read-only.
Attached screenshots

All Replies (2)

more options

Make sure to keep the "Site settings".

  • clearing "Site settings" clears exceptions for cookies, images, pop-up windows, and software installation and exceptions for passwords and other website specific data
  • Settings -> Privacy & Security
    Firefox will: "Use custom settings for history":
    [X] "Clear history when Firefox closes" -> Settings

Helpful?

more options

cor-el said

Make sure to keep the "Site settings".
  • clearing "Site settings" clears exceptions for cookies, images, pop-up windows, and software installation and exceptions for passwords and other website specific data
  • Settings -> Privacy & Security
    Firefox will: "Use custom settings for history":
    [X] "Clear history when Firefox closes" -> Settings

So you're telling me to uncheck 'Site Settings' in 'Clear history when firefox closes'?

EDIT: Yes, that seems to solve the problem. Thank you a lot! I don't get why it didn't work when I first had that issue. I remember I unchecked that first, but it didn't work so I re-checked 'site settings'...

Modified by tetratheta

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.