Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Bold thread subject in table view stopped working in latest update 115.13.1

  • 8 replies
  • 1 has this problem
  • 71 views
  • Last reply by Toad-Hall

more options

In the past, I had followed this post and created the userChrome.css file so that when I have my emails shown in Table View, if one email within a thread is unread, the whole thread is collapsed, but the subject line remains in bold.

With this latest Thunderbird update to version 115.13.1 I have lost the functionality; now the subject line of the collapsed thread shows as underlined. How can I go back to my preferred bold view?

Thanks

In the past, I had followed [https://support.mozilla.org/en-US/questions/1366417 this post] and created the userChrome.css file so that when I have my emails shown in Table View, if one email within a thread is unread, the whole thread is collapsed, but the subject line remains in bold. With this latest Thunderbird update to version 115.13.1 I have lost the functionality; now the subject line of the collapsed thread shows as underlined. How can I go back to my preferred bold view? Thanks

Modified by DonDowner

Chosen solution

Just in case someone is reading this and has never created a 'userChrome.css' file before, I'm including all the necessary information.

Please check in Thunderbird to see if a setting needs switching on.

  • Settings > General
  • Scroll to bottom and click on 'Config Editor' button
  • In search type : legacy
  • look for this line: toolkit.legacyUserProfileCustomizations.stylesheets
  • If it is set as 'false' :
  • click on the far right arrow type icon to toggle from 'false' to say * 'TRUE'

Now Do this: In Thunderbird

  • Help > Troubleshooting Information
  • in 'Application Basics' - Profile Folders - click on 'Open Folder'

A new window opens showing the contents of your profile name folder.

  • Exit Thunderbird now. This is important.
  • In the 'profile name ' folder create a new folder and call it 'chrome'. The spelling is important - note it is all lower case.
  • Then open a simple text editor program such as 'Notepad'.
  • Copy all the text between the lines below and paste it into 'Notepad'.

@import url("chrome://messenger/content/unifiedtoolbar/unifiedToolbarWebextensions.css");
@namespace html url("http://www.w3.org/1999/xhtml");

/*
    * Collapsed read thread, but the thread contains unread , set text to bold black on top level thread
*/

#threadTree tbody .children.collapsed[data-properties~="hasUnread"]
  :where(td, .subject-line) {
  text-decoration: none !important;
  font-weight: bold !important;
  color: #000000 !important;
}


  • Save the file as 'userChrome.css' - note the spelling of this is important - all lower case except the C.
  • Save it in the 'chrome' folder. - see attached image as guide.

Check that file really is called 'userChrome.css' and not 'userChrome.css.txt' - it has to be saved as a Cascading Style Sheet (css) and not a text document. So if you see 'userChrome.css.txt' - no problem - just rename it by removing the .txt - you will get ask are you sure as it may effect things - just say yes because you really do want to do it.

Start Thunderbird

Read this answer in context 👍 0

All Replies (8)

more options

Chosen Solution

Just in case someone is reading this and has never created a 'userChrome.css' file before, I'm including all the necessary information.

Please check in Thunderbird to see if a setting needs switching on.

  • Settings > General
  • Scroll to bottom and click on 'Config Editor' button
  • In search type : legacy
  • look for this line: toolkit.legacyUserProfileCustomizations.stylesheets
  • If it is set as 'false' :
  • click on the far right arrow type icon to toggle from 'false' to say * 'TRUE'

Now Do this: In Thunderbird

  • Help > Troubleshooting Information
  • in 'Application Basics' - Profile Folders - click on 'Open Folder'

A new window opens showing the contents of your profile name folder.

  • Exit Thunderbird now. This is important.
  • In the 'profile name ' folder create a new folder and call it 'chrome'. The spelling is important - note it is all lower case.
  • Then open a simple text editor program such as 'Notepad'.
  • Copy all the text between the lines below and paste it into 'Notepad'.

@import url("chrome://messenger/content/unifiedtoolbar/unifiedToolbarWebextensions.css");
@namespace html url("http://www.w3.org/1999/xhtml");

/*
    * Collapsed read thread, but the thread contains unread , set text to bold black on top level thread
*/

#threadTree tbody .children.collapsed[data-properties~="hasUnread"]
  :where(td, .subject-line) {
  text-decoration: none !important;
  font-weight: bold !important;
  color: #000000 !important;
}


  • Save the file as 'userChrome.css' - note the spelling of this is important - all lower case except the C.
  • Save it in the 'chrome' folder. - see attached image as guide.

Check that file really is called 'userChrome.css' and not 'userChrome.css.txt' - it has to be saved as a Cascading Style Sheet (css) and not a text document. So if you see 'userChrome.css.txt' - no problem - just rename it by removing the .txt - you will get ask are you sure as it may effect things - just say yes because you really do want to do it.

Start Thunderbird

more options

Thank you very much. The new code solved my problem. Best!

more options

just fyi for anyone else reading this, I removed the `color: #000000 !important;` so that the subject line is compatible with Dark Mode.

more options

DonDowner said

just fyi for anyone else reading this, I removed the `color: #000000 !important;` so that the subject line is compatible with Dark Mode.

Or if you are only using dark mode then set color to use #ffffff which is white.

more options

Toad-Hall said

DonDowner said

just fyi for anyone else reading this, I removed the `color: #000000 !important;` so that the subject line is compatible with Dark Mode.

Or if you are only using dark mode then set color to use #ffffff which is white.

Hello Toad-Hall,

I had removed that `color: #000000 !important;` line altogether, which works well when in Light mode by changing the subject to bold and text in black. However, I just noticed it doesn't work well in Dark mode (I have my Mac set to Auto, so it changes at night and in the morning again), as the subject text is bold but the color is gray (same as the read emails) and not white like the regular unread emails. Therefore it's very hard to distinguish the collapsed threads with unread emails.

I tried setting the color to #ffffff, but that only works in Dark mode.

Any idea how to have the subject text color change to black in Light mode, and to white (not gray) in Dark mode) ?

Thanks

more options

Hey Did the selectors change? The code doesnt work for me. I tried changing body color, and it works, so I guess the issue is in Selectors. My version is WIN 115.6.1 (64-bit)

more options

For me this worked

   * Collapsed read thread, but the thread contains unread, set headline text to bold black
  • /
  1. threadTree tbody .children[data-properties~="hasUnread"] .subject-line {
 font-weight: bold !important;

}


it marked subject line of a tread bold if the tread has any unread messages.

more options

re :Any idea how to have the subject text color change to black in Light mode, and to white (not gray) in Dark mode) ?

Sorry for delay. Try this, it works for me.

For the 'color' line in the code I previously supplied use this:


color:  var(--thread-pane-unread-color) !important;