Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Downgrade from 115 to 102

  • 5 replies
  • 28 have this problem
  • 1818 views
  • Last reply by petejc

more options

Since I have problems with version 115 (ImportExportTools NG does not work in this version) I am forced to restore version 102. Unfortunately I can't find a way to download this version anymore. A download possibility for older versions would be very helpful. Thanks a lot

Since I have problems with version 115 (ImportExportTools NG does not work in this version) I am forced to restore version 102. Unfortunately I can't find a way to download this version anymore. A download possibility for older versions would be very helpful. Thanks a lot

Chosen solution

@Philip Kiff: Thank you for your comment. This is very helpful. On the GIT for "ImportExportTools NG" I was able to find a beta version which works for our purposes with V115. With this we should be able to make it until a SR is released.

Read this answer in context 👍 3

All Replies (5)

more options

I also couldn't find a link to version 102.x, but was able to download the file by manually replacing the version number with the latest 102.x version number in the download URL.

Caution: I understand that "downgrading" is not recommended, and version 102.x is probably no longer supported. So I would not install 102.x unless you have a complete copy of your old Thunderbird profile from before upgrading to 115!

Having said that, you should be able to access old versions like this:

To ensure that you are downloading the correct OS and language version for your computer, I'd recommend starting by copying the 115.x download URL provided when you browse to the site using your computer. Today, mine looked like this (for a 64-bit Windows machine, language region English (Canada): https://download.mozilla.org/?product=thunderbird-115.2.2-SSL&os=win64&lang=en-CA

Then, replace the "115.2.2" version number in the URL you copied with the latest 102.x version number, which is 102.15.1 today. (A new version was released just two days ago with an security patch for the WebP vulnerability that affected many browsers and other tools this week). So, if you are using a 64-bit machine with the English (Canada) region, then the download URL will be: https://download.mozilla.org/?product=thunderbird-102.15.1-SSL&os=win64&lang=en-CA

To double-check the exact, current number for the latest 102.x version, you can consult the Thunderbird Release Notes page, though I'm pretty sure they are finished updating the 102.x version: https://www.thunderbird.net/en-US/thunderbird/releases/

Modified by Philip Kiff

more options

Chosen Solution

@Philip Kiff: Thank you for your comment. This is very helpful. On the GIT for "ImportExportTools NG" I was able to find a beta version which works for our purposes with V115. With this we should be able to make it until a SR is released.

more options

Actually reverting from an installed 115 version to 102.15.1:

Download Thunderbird 102.15 installer:

https://download.mozilla.org/?product=thunderbird-102.15.1-SSL&os=win64&lang=en-US

WITH THUNDERBIRD CLOSED:

1 Open your Thunderbird Profile directory. 2 Delete compatibility.ini file from the Profile folder. 3 Use the downloaded Thunderbird 102.15 installer to re-install the older version (overwrite the newer one). 4 Relaunch Thunderbird.

Version 102 should be restored. (This worked for me.)

more options

Thankyou so much - worked like a dream. Just hope I've set up no-updates properly now...

more options

PROFILE NOT AVAILABLE!!!! Damn it, TB (102) said it has an update. I was half asleep and permitted it. Of course it installed 115. I went through the procedure and got 102 back with all my accounts just fine. Then I shutdown. I started up today and I was back to TB 115. It found that I had installs of both 102 and 115 and 115 is what booted. I uninstalled 115 and installed 102. When it comes up I have no profiles. My old profile is still there. I reinstalled 102 When I try to run it I get what is in the image. At some point I got a message that the profile was used by 115 and could be uncompatible with 102.

HELP!