Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

stop searches in URL bar

  • 3 replies
  • 2 have this problem
  • 46 views
  • Last reply by ShaunTru6

more options

I have Firefox 115.1.0esr. Google is my home page. When I search for things I want to ONLY use the Google bar. I DON'T want to start typing and have the URL bar start to fill in. See screenshot, I've unchecked what I think should allow only the Google bar to fill in and search. But it's still going to the MAIN URL bar above. Please help me fix this, it's driving me crazy!!!!!

I have Firefox 115.1.0esr. Google is my home page. When I search for things I want to ONLY use the Google bar. I DON'T want to start typing and have the URL bar start to fill in. See screenshot, I've unchecked what I think should allow only the Google bar to fill in and search. But it's still going to the MAIN URL bar above. Please help me fix this, it's driving me crazy!!!!!
Attached screenshots

Chosen solution

Further to the previous response, the separate search bar may also disappear so everyone will be compelled to use the not-so-awesome bar.

Read this answer in context 👍 0

All Replies (3)

more options

The search box shown on your home page is not the search bar referred to in Settings (shown in your screenshot. If you want to use the box on your home page, enter about:config in the address bar, search for handoff and change the value of the preference below to false. I gather it may soon be impossible to make that change so you should consider using the search bar alongside the address bar. browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar

more options

Chosen Solution

Further to the previous response, the separate search bar may also disappear so everyone will be compelled to use the not-so-awesome bar.