Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to enable saving of all cookies in Firefox?

  • 3 replies
  • 2 have this problem
  • 55 views
  • Last reply by cor-el

more options

In "Privacy & Security" settings I enabled in "History" section to remember all history. But when I load, for example, https://conan.io site I see a notification about cookies with button to allow them, everytime I load site I see this message, and I forced to click and click "Accept All Cookies" button.

How can I enable to store all cookies in Firefox to avoid this annoyable message?

Thank you.

In "Privacy & Security" settings I enabled in "History" section to remember all history. But when I load, for example, https://conan.io site I see a notification about cookies with button to allow them, everytime I load site I see this message, and I forced to click and click "Accept All Cookies" button. How can I enable to store all cookies in Firefox to avoid this annoyable message? Thank you.

Chosen solution

Hi Igor, usually this is a notice from the site rather than a notice from Firefox. After you accept cookies on their panel, the site can set a cookie so it knows you already answered the question.

That particular site seems to be completely broken -- they can't even keep track of your choice from one page load to the next.

If that is the only site that loses your preferences frequently, I think your settings are correct. You can let the site know that their code doesn't work correctly in Firefox.

If you see the problem on other sites:

How soon do you see the message a second time? For example, after closing a site's tab/the next time you open a tab to the site, or only after you exit out of Firefox and revisit the site in a new session, etc.

Read this answer in context 👍 1

All Replies (3)

more options

Chosen Solution

Hi Igor, usually this is a notice from the site rather than a notice from Firefox. After you accept cookies on their panel, the site can set a cookie so it knows you already answered the question.

That particular site seems to be completely broken -- they can't even keep track of your choice from one page load to the next.

If that is the only site that loses your preferences frequently, I think your settings are correct. You can let the site know that their code doesn't work correctly in Firefox.

If you see the problem on other sites:

How soon do you see the message a second time? For example, after closing a site's tab/the next time you open a tab to the site, or only after you exit out of Firefox and revisit the site in a new session, etc.

more options

Hi jscher2000,

conan.io always asks for cookies accept (new tab, closing Firefox). You guess that this is a problem of conan.io, OK, maybe, in this case I don't have more questions. I saw earlier the same problem on some other sites, but I don't remember what they are...

Thank you for your quick reply.

more options

You can try to create a cookie allow exception for those websites. Make sure not to clear the "Site settings" as this includes exceptions.


You can use these steps to make a website recognize and remember you.

  • create a cookie allow exception with the proper protocol (https:// or http://) to make a website remember you

You can check that you aren't clearing important cookies.

  • using "Delete cookies and site data when Firefox is closed" to clear cookies keeps cookies with an allow exception
    in 102+ version toggling this setting makes changes to the "Clear history when Firefox closes" settings and those settings prevail
  • using "Clear history when Firefox closes" in Firefox 102+ honors exceptions and keeps cookies with an allow exception, previous versions removed all cookies

Make sure to keep the "Site settings".

  • clearing "Site settings" clears exceptions for cookies, images, pop-up windows, and software installation and exceptions for passwords and other website specific data
  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Exceptions"
  • Settings -> Privacy & Security
    Firefox will: "Use custom settings for history":
    [X] "Clear history when Firefox closes" -> Settings