Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Youtube, Odysse, Twitch videos wont play

  • 6 replies
  • 1 has this problem
  • 39 views
  • Last reply by zeroknight

more options

I am desperatly trying to play a youtube video, the on hover preview plays, but the video wont. I turned hardware acceleration of and tested in safe mode. I am using Firefox version 115.0.3 from the AUR. pls help

I am desperatly trying to play a youtube video, the on hover preview plays, but the video wont. I turned hardware acceleration of and tested in safe mode. I am using Firefox version 115.0.3 from the AUR. pls help

All Replies (6)

more options

You might need to install ffmpeg with something like:

sudo pacman -S ffmpeg-compat-58

more options

I did, nothing changed

more options

What hardware are you running? What OS? What Desktop? X11 or Wayland? All my laptops are running the same OS, but my 1 of my older laptops is having issues just with odysee. My current laptop works fine. see screenshot

more options

Now on my older laptop that same video will not play. see screenshot


Operating System: openSUSE Tumbleweed 20230728 KDE Plasma Version: 5.27.6 KDE Frameworks Version: 5.108.0 Qt Version: 5.15.10 Kernel Version: 6.4.6-1-default (64-bit) Graphics Platform: X11 Processors: 4 × Intel® Core™ i7-4810MQ CPU @ 2.80GHz Memory: 31.0 GiB of RAM Graphics Processor: Mesa Intel® HD Graphics 4600 Manufacturer: Hewlett-Packard Product Name: HP ZBook 17 G2 System Version: A3009DD10303

more options

Same HP ZBook 17 G2 dual boots openSUSE and Win 7. You can see from the screenshot that the same version of Firefox works with Odysee in Windows, but not openSUSE on this laptop. see screenshot

Modified by jonzn4SUSE

more options
Tip: Firefox might not play video if audio is not configured. If you are intending to use PipeWire and WirePlumber, make sure they are working properly and have the necessary pipewire-pulse compatibility layer.

https://wiki.archlinux.org/title/Firefox#Multimedia_playback