Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to fix menu bar position in the new supernova UI

  • 3 replies
  • 13 have this problem
  • 42 views
  • Last reply by Andy_P

more options

So I want my UI to look proper so title bar at the top, with the title only, menu bar below it, and the rest tabs etc below that, you know like i trained my brain for the last quatre century.

Unfortunately with this new supernova UI this is messed up, see attached image. I consider this a UI bug its absolutely counter intuitive, please fix.

Also the font looke now more washed out in comparison with the previouse build, I want my font crisk #000000 on #FFFFFF no gray or grayisch or anything, the UI ist nto an art peace, its a tool, as simple as that.

So I want my UI to look proper so title bar at the top, with the title only, menu bar below it, and the rest tabs etc below that, you know like i trained my brain for the last quatre century. Unfortunately with this new supernova UI this is messed up, see attached image. I consider this a UI bug its absolutely counter intuitive, please fix. Also the font looke now more washed out in comparison with the previouse build, I want my font crisk #000000 on #FFFFFF no gray or grayisch or anything, the UI ist nto an art peace, its a tool, as simple as that.
Attached screenshots

All Replies (3)

more options

If you are familiar with userChrome.css, you might try this, as it works for me:

/*  #######    */
@namespace html url("http://www.w3.org/1999/xhtml");

#toolbar-menubar {
  order: 1;             
}

unified-toolbar {
  order: 2;             
}

#tabs-toolbar {
  order: 3;              
}

If not, I'll add more instructions:

more options

Okay. I probably should have done initially, but I was in a hurry: here goes - click settings>general and scrollodown to config editor - search for toolkit.legacyUserProfileCustomizations.stylesheets and change to true - then you need the chrome folder in profile, and a userChrome.css file. - exit and restart TB and it should work, although I've sometimes found I have to restart TB twice to see changes in userChrome.css

more options

@David Pardon my ignorance, but is this Chrome Folder (and the userChrome.css within it) to be created in my Mozilla profile (as per every article I've found online about creating a userChrome.css file) or in one (or both!) of the Thunderbird folders that I've found, at these locations? C:\Users\Andy\AppData\Roaming\Thunderbird\Profiles C:\Users\Andy\AppData\Local\Thunderbird\Profiles

Both of these Profiles folders have two subfolders, I'm guessing the new Chrome folder goes inside the sub-folder with "default" in the name?

So.... I've tried copying your suggested text into a new text file, I've named it "userChrome.css" and I've put it into a new folder called "Chrome" in both of the Thunderbird "default" profile locations above and I've changed the Config Editor entry for "toolkit.legacyUserProfileCustomizations.stylesheets" to "true"

But there is no change... the Menu Bar (with File, Edit, View etc.) is still BELOW the toolbar with Get Messages, Write Message, Chat, etc.

Can you give even more simple instructions?

EDIT: I worked it out, the correct profile subfolder was NOT the one with "default" in the name, but the other one that has "recovery" in the name. Obviously there must have been a major crash in the past that I've forgotten about.

Modified by Andy_P