Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Starting Firefox the first time after boot is really slow

  • 5 replies
  • 0 have this problem
  • 34 views
  • Last reply by jonzn4SUSE

more options

os Arch Linux host x86_64 kernel 6.3.9-zen1-1-zen wm xmonad graphics-server X Mozilla Firefox 114.0.2 20230620210812 20230620210812

Hello,

after porting my SSD Arch installation from my old Laptop to a desktop PC, i have a really long startup time (about 30s-45s) for the first time after booting my PC. This problem doesn't occur with any other programs. The subsequent openings of firefox happen instant.

Have tried using "refresh" functionality to clean up firefox so my about:config is as clean as it gets, didn't help. Have tried starting it with "firefox --no-remote", didn't help. Have tried starting it with "firefox --safe-mode", didn't help. Have tried starting it with a completely fresh profile, didn't help. Tried purging it from the system and reinstalling it, didn't help. Same problem when I start it normally via dmenu/rofi.

I don't get any stdout log on any of these methods of starting.

I also don't know where to look for helpful log files.

Any help or hints on where to trace this fault are much appreciated.

Have a nice day :)

os Arch Linux host x86_64 kernel 6.3.9-zen1-1-zen wm xmonad graphics-server X Mozilla Firefox 114.0.2 20230620210812 20230620210812 Hello, after porting my SSD Arch installation from my old Laptop to a desktop PC, i have a really long startup time (about 30s-45s) for the first time after booting my PC. This problem doesn't occur with any other programs. The subsequent openings of firefox happen instant. Have tried using "refresh" functionality to clean up firefox so my about:config is as clean as it gets, didn't help. Have tried starting it with "firefox --no-remote", didn't help. Have tried starting it with "firefox --safe-mode", didn't help. Have tried starting it with a completely fresh profile, didn't help. Tried purging it from the system and reinstalling it, didn't help. Same problem when I start it normally via dmenu/rofi. I don't get any stdout log on any of these methods of starting. I also don't know where to look for helpful log files. Any help or hints on where to trace this fault are much appreciated. Have a nice day :)

All Replies (5)

more options

Try downloading Firefox from Mozilla. Download, unzip, and run firefox-bin from the folder and see if you have the same issue. https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

more options

Thanks for the idea, I tried it but this results in the exact same problem. I should also notice, it's probably not some stuff blocking after startup because even if I wait 10 minutes after booting before I start firefox, I have the same problem. Other browsers open instantly.

Thunderbird has the same problem!! But if Firefox was opened first, Thunderbird opens instantly. Its really just the first time opening a Mozilla product after startup that takes so long. As soon as one mozilla product has openend, any subsequent mozilla products open instantly.

more options

Hi,

I'm sorry to hear that you're experiencing slow startup times with Firefox on your Arch Linux desktop. As a Firefox support volunteer, I can try to assist you with troubleshooting this issue.

First, let's try a few steps to see if they help improve the startup time:

Clear the cache: Open Firefox and go to Preferences (about:preferences), then click on "Privacy & Security" in the left sidebar. Scroll down to the "Cookies and Site Data" section and click on the "Clear Data" button. Make sure to select both "Cookies and Site Data" and "Cached Web Content" and click "Clear."

Disable unnecessary extensions: Sometimes, certain extensions can slow down the browser startup. Open Firefox and go to Add-ons (about:addons). Disable any extensions that you don't need or suspect could be causing the issue. Restart Firefox and check if the startup time improves.

Create a new Firefox profile: A corrupted profile could also be the cause of slow startup. You mentioned that you tried starting with a fresh profile, but let's try creating a new one following these steps:

Close Firefox completely. Open a terminal and run the following command: firefox --ProfileManager In the Profile Manager window, click on "Create Profile" and follow the prompts to create a new profile. Once the new profile is created, select it and click "Start Firefox." Test the startup time with the new profile and see if it improves.

If none of the above steps help, we can try enabling additional logging to gather more information about the startup process. Here's how:

Open a terminal and run the following command: firefox --MOZ_LOG_FILE=log.txt --MOZ_LOG=timestamp,nsHttp:5,nsSocketTransport:5,nsHostResolver:5,nsLoadGroup:5,nsDocLoader:5,nsPref:5,nsDNSPrefetch:5 Reproduce the slow startup issue. After the issue occurs, close Firefox. Locate the "log.txt" file that was created in the current directory. It will contain the logged information about the startup process. Please provide the log file so that we can analyze it and further assist you in resolving the issue.

I hope these steps help in troubleshooting the slow startup problem. Let me know if you have any questions or need further assistance.

Best regards, Suram Firefox Support Volunteer

more options

If the hostname -f command also takes a long time to respond, you will need to edit /etc/hosts and assign 127.0.1.1 to your hostname (found in /etc/hostname).

Another common startup delay is a DBus timeout when fetching the system theme, this can be avoided by going to about:config and changing widget.use-xdg-desktop-portal.settings = 0.

more options

John said

os Arch Linux host x86_64 kernel 6.3.9-zen1-1-zen wm xmonad graphics-server X

You're having the same issue with the distro and Mozilla version, sounds like an environment issue. Are you running X11 or Wayland? I would try another desktop. Can you run a virtual machine or usb live stick to test? The below cmd will create a log file (firefox_debug.txt) to show what's happening when you run Firefox. strace -t -o firefox_debug.txt firefox &

Modified by jonzn4SUSE