Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How can I stop .pdf files from automatically downloading to my computer?

  • 2 replies
  • 3 have this problem
  • 272 views
  • Last reply by thrud00

more options

Why has this started up again? Pdf files are automatically downloading to my computer when all I want to do is look at the file. So many files that now need to be trashed after looking at them. This problem has happened in the past, but was resolved, only now I am finding it happen again. I do not want to have files saved unless I want to save them, not Firefox deciding that any file I open should be saved. I have Windows 11 & Firefox Version 113.0.1. Is there a way to revert to an older version of Firefox?

Why has this started up again? Pdf files are automatically downloading to my computer when all I want to do is look at the file. So many files that now need to be trashed after looking at them. This problem has happened in the past, but was resolved, only now I am finding it happen again. I do not want to have files saved unless I want to save them, not Firefox deciding that any file I open should be saved. I have Windows 11 & Firefox Version 113.0.1. Is there a way to revert to an older version of Firefox?

Chosen solution

Try entering about:config in the address bar and changing this preference to true. browser.download.start_downloads_in_tmp_dir

https://bugzilla.mozilla.org/show_bug.cgi?id=1738574#c133 https://support.mozilla.org/en-US/kb/about-config-editor-firefox

Read this answer in context 👍 3

All Replies (2)

more options

Chosen Solution

Try entering about:config in the address bar and changing this preference to true. browser.download.start_downloads_in_tmp_dir

https://bugzilla.mozilla.org/show_bug.cgi?id=1738574#c133 https://support.mozilla.org/en-US/kb/about-config-editor-firefox

more options

There's now a better way, if you don't want PDFs automatically downloading at all.

Change browser.download.open_pdf_attachments_inline to true. As documented in this thread:

https://connect.mozilla.org/t5/discussions/stop-saving-pdfs-to-downloads-when-viewing-in-firefox/td-p/10225